nautilus shows drive labels instead of volume labels

Bug #30867 reported by Trouilliez vincent on 2006-02-08
50
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Nautilus recently started to show incorrect labels for the hard drive partitions (/dev/hdxy) I mounted under /media.

The mounting points are :

/media/Windows
/media/Breezy_System
/media/Breezy_Home
/media/Backup

but insted of displaying labels (like it used to) like this:

Windows
Breezy_System
Breezy_Home
Backup

It now displays this instead:

9.3 GB Volume
/
/home
/media/Backup

Sebastien Bacher (seb128) wrote :

Nautilus uses the name of the drive returned by hal, I'm not sure if that should be considered as a bug

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed

Wow... it really looks horrible in any case :-/

If really that's a feature from now on, then we should be given a way to change the labels by hand, just like we can rename bookmarks for example.

Lukas Sabota (punkrockguy318) wrote :

Agreed, there is NO simple way to adjust labels, and NO way to adjust vfat labels.

Mathieu Pillard (diox) wrote :

FWIW, mlabel from the mtools package /should/ be able to adjust vfat labels. For other filesystems, you might want to have a look at xfs_admin, reiserfstune and e2label.

Martin Pitt (pitti) wrote :

Can you please upgrade to hal 0.5.7-1ubuntu5 (just uploaded), reboot, and try if that is any better?

I upgraded, but all the labels are still exactly the same. No changes/improvements whatsoever.

Forgot to add: in case my previous comment was ambiguous: yes, I did restart the computer as requested.

gusaweb (gusaweb) wrote :

The same problem for me. After upgrading, and rebooting, no change.

LKRaider (paul-eipper) wrote :

Just a small detail: mlabel for vfat partitions will only make uppercase names, which is quite ugly infact.

Some way to easily personalize the names would be good (taking the mountpoint names, or creating a file that works as a database of names, or whatever).

Martin Pitt (pitti) wrote :

The problem might be that nautilus shows the drive name, not the volume name. It should either show the latter, or both.

It really looks stupid that my old Breezy partition in /media/ubuntu/breezy shows up as "/" !!!

Today I had my very first confusing experience with this: I wanted to search for a file that is on my root filesystem in Dapper (mounted as / ). Well, I just went to Places > Search for Files... chose "/" as the directory to search and after hitting "Find" no results were returned....

Until I realised that "/" was searching on /media/ubuntu/breezy. In order to search within the Filesystem root, I had to choose "Filesystem" form the list! I know that is the usual behaviour, but it can be a bit confusing when device names show up as "/". So what happens if I've got a Breezy (/media/ubuntu/breezy) and a Hoary (/media/ubuntu/hoary) installation on different partitions? Will they both show up as "/" on the desktop and in nautilus?

Peter Shultz (pashultz) wrote :

Thanks, Mathieu. I just found this bugreport, and e2label worked great on my ext3 volumes.
"e2label /dev/sdb3 Video" (e.g.) was all it took, and it didn't even require root privileges (!?)

> and it didn't even require root privileges (!?)

Please give the output of
id
ls -l /dev/sdb3

This bug is related to this issue:

https://launchpad.net/bugs/38764

A fix has just been released whereby '/' volume labels are treated as a special case, so at least part of what has been discussed here seems to have been fixed already.

Daniel Holbach (dholbach) wrote :

Which problem is still 'open' in Edgy?

Changed in nautilus:
status: Confirmed → Needs Info
David Planella (dpm) wrote :

For my part, this bug was fixed when the other one I was mentioning on my last post was fixed.

In my case I've got:

/media/ubuntu/breezy -> ext3 partition
/media/debian/etch -> ext3 partition
/media/windows/C -> vfat partition with label WINXP
/media/windows/D -> vfat partition with label DATA

which show up in Nautilus' Places as follows:

ubuntu/breezy
debian/etch
WINXP
DATA

and I'm quite happy with this configuration.

I don't know about other people, though.

Just installer Edgy RC, and I found that the situation has improved, a bit, but there are still some incorrect labels.

The mount points are:

/media/Dapper_System
/media/Backup
/media/Windows
/media/Dapper_Home

The first 3 partitions show up properly in the side pane ("Places" view), but in the "Computer" view, they are preceded by a" xx.y GB Volume:" string.

The last partition ("Dapper_Home") unfortunately shows up as '/home' in the side pane, which is both confusing and incorrect.

I also have TWO icons for the floppy drive, in the "Places" view (Computer view is fine)

I attached a little screenshot to summarize it all

Allan Lewis (een4aml) wrote :

I found that selecting a partition in GParted and clicking "device > set disklabel" allows the user to change the label but apparently this results in the erasing of all data on the drive/partition. Stepping away from any particular OS for a moment, is it possible, theoretically, to change the official (presumably hardwired) "label" of a partition without erasing the partition?

Changed in nautilus:
status: Needs Info → Unconfirmed
Daniel Holbach (dholbach) wrote :

Do you still have the problem?

Changed in nautilus:
status: Unconfirmed → Needs Info

> Do you still have the problem?

Well, in Edgy it had improved a bit, but I am now testing Feisty, and.... oh my god !!!
Nautilus is displaying complete non sense, it's the end of the world...

1) In fstab, I added two partitions&mount points: Nautilus doesn't show any of them (but they are actually mounted, as expected, as I can browse them just fine in a terminal for example.)

2) Nautilus shows partitions that I have NOT mounted, and that I definitely don't want to be displayed as I don't want to use them hence they just pollute the "Places" view all the time, sitting there uselessly.

3) Not ALL unmounted partitions show up, it picked a few at random or something, no idea why some were chosen and others left out.

I think points 2 and 3 are due to a Feisty spec (?) I must have read somewhere on Launchpad, so l will have to file separate bugs for these.

Changed in nautilus:
status: Needs Info → Unconfirmed
Pedro Villavicencio (pedro) wrote :

Thanks for your report, may you please try to reproduce the same with latest Nautilus package available on Hardy and let us know how it goes? Thanks in Advance.

Changed in nautilus:
status: New → Incomplete
Peter Shultz (pashultz) wrote :

I'm using Hardy now. The e2label command now requires root privileges, but the labels don't seem to show up in Nautilus, nor can they be edited through the "Properties" dialog (see attachment).

:~$ mount | grep sda6
/dev/sda6 on /media/gutsy type ext3 (rw)
:~$ e2label /dev/sda6 TestLabel
e2label: Permission denied while trying to open /dev/sda6
Couldn't find valid filesystem superblock.
:~$ sudo e2label /dev/sda6 TestLabel
:~$

So I get no errors when using sudo. But even restarting the Gnome session, Nautilus still displays the drive as "6.9 GB Media" in Places and on the desktop. Strangely, my other drives DO get working labels: there's an ext3 partition called ShareData and an HFS partition called Untitled (it's my almost-totally-unused OSX partition, and OSX also calls it "Untitled").

The attached screenshot shows the error I get when trying to rename the partition from the "Properties" dialog in Nautilus (from right-clicking the icon in computer:/// view): "Operation not supported by backend" I suppose this is part of the transition to gvfs/gio?

LKRaider (paul-eipper) wrote :

I get the same error as the screenshot. This is what nautilus displays if run from the terminal and then trying to rename a partition:

** (nautilus:1144): WARNING **: Hit unhandled case g-io-error-quark:15 in fm_report_error_renaming_file

Okay, I have now installed Hardy. The problem got fixed in Gutsy (ie, Nautilus started again to display mount points as a label).
But I have upgraded to Hardy, and now the problem is back. Screenshot attached: all my local partitions show up as "XX.X GB Media" instead of the mount point directory.
That's useful/nice for an external, removeable media (USB keys or drives...) but for the numerous partitions of local hard drives, it's very inconvenient at best, and there is no way to rename them (if I press "F2" to change the label of a partition, it appears editable, but when I press enter to confirm the change.. it doesn't actually take the new name into consideration).

No idea what got changed from Gutsy to Hardy, but was definitely not a good move :-/

damon raphael (w7md) wrote :

I am happy to discover that this is a recognized bug. It has been driving me up a wall since I upgraded from Gutsy to Hardy.
I tried booting with a Gutsy LiveCD and the same "104.9 GB Media" Drive Partition Icon label was displayed on mounting an ntfs partition. The same was noted with a Kanotix Thorhammer LiveCD.
I went back to booting with a Gutsy LiveCD, created a directory in /media named /media/sda1
Then I manually mounted /dev/sda1

mount -t ntfs /dev/sda1 /media/sda1

The mounted partition icon appeared on the Desktop and was named "sda1". I was unable to do this in Hardy. In Hardy, the icon display name wants to be "104.9 GB Media"
I hope this can be "fixed" as I use various partitions for backups. Proper labelling will save time and help avoid user errors.

I am also very glad to see this is a reported bug. Instead of trying to chance the drive labels, I think we should focus on changing nautilus so it displays the volume/partition labels, like it used to.

Anyone have any insight at all (to what could have caused this problem to come back after it was fixed)?

Sebastien Bacher mentioned that nautilus uses hal, so I think this bug could be related.

https://bugs.launchpad.net/ubuntu/+source/hal/+bug/33794 ?

Changed in nautilus:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

this looks like bug http://bugzilla.gnome.org/show_bug.cgi?id=161038 which is known upstream.

Changed in nautilus:
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

could you please also try to reproduce this with intrepid? upstream said that should be better there, thanks.

Changed in nautilus:
status: Unknown → Incomplete
damon raphael (w7md) wrote :

Re: >>> could you please also try to reproduce this with intrepid?

I did a dual boot (with Windows XP-Media Edition) clean install of Intrepid for AMD64 - 64 bit version - on an HP computer with dual processors 2 weeks ago. The NTFS/HPFS Windows partition was correctly mounted and labeled.

I upgraded my Hardy i386 Desktop version to Intrepid yesterday by net install. Unfortunately, the previously noted bug persists in i386 Intrepid Ibex. I see a vertical stack of 5 identical dirive icons each labeled by drive storage capacity.

Bummer!!

mevans (mr-amiga500) wrote :

Why has it taken so long to fix this bug?? (3 1/2 years!)

I've got multiple drives mounted and because they have the same capacity, they have identical useless labels. I keep opening up the wrong drive because I can't tell which is which.

(Come on, my 1985 Amiga has no problem changing drive labels - why is this a problem on 2009 Linux?)

Sebastien Bacher (seb128) wrote :

(the amiga was probably one filesystem they wrote and not working on the number of format linux does now)

mevans (mr-amiga500) wrote :

"(the amiga was probably one filesystem they wrote and not working on the number of format linux does now)"

No, it works with any filesystem (and new filesystems can easily be added by simply dragging a file) and renaming the drive label is as simple as renaming a file... the way it [i]should[/i] be in Linux.

Changed in nautilus:
status: Incomplete → Confirmed
Changed in nautilus:
importance: Unknown → Medium
Changed in nautilus:
status: Confirmed → Expired
damon raphael (w7md) wrote :

This bug is still "alive and well"...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.