option to force refresh of the thumbnails

Bug #305850 reported by Vincent Tschanz on 2008-12-07
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Wishlist
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

I rip all my DVD's into MKV, so I have a huge movie collection in a folder. (X264 vide with vorbis audi in MKV container)

Ubuntu by default is not able to build thumbnails for my videos ; I have totem icon for each file.

I Install gstreamer plug-ins to handle x264, now nautilus is able to create my thumbnails, but he don't.
I have to move or to renames my movie files to force nautilus to rebuild the thumbnail.

It would be usefull to have en entry in the "display" menu called "refresh thumbnails".

Pedro Villavicencio (pedro) wrote :

thanks for the report, that's a quite old bug upstream, linking the report.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in nautilus:
status: Unknown → Confirmed
libi (liberatofiasca) wrote :

the refresh should be automatic for those files that not have a thumb yet.
changing the folder name that contain those files, infact, magically the thumbs appear. But renaming back the folder, everything is lost. Very annoying bug.

annunaki2k2 (russell-knighton) wrote :

This is definitely an annoying bug, and I agree that some sort of "Force thumbnails" option should be added to nautilus eventually.

However, as a work around in the mean time:
Open a terminal window
type:
    cd ~/.thumbnails
    rm -r /fail/*

hth

Thanks for the tip. It works fine.

Liberato

2009/6/3 annunaki2k2 <email address hidden>

> This is definitely an annoying bug, and I agree that some sort of "Force
> thumbnails" option should be added to nautilus eventually.
>
> However, as a work around in the mean time:
> Open a terminal window
> type:
> cd ~/.thumbnails
> rm -r /fail/*
>
> hth
>
> --
> option to force refresh of the thumbnails
> https://bugs.launchpad.net/bugs/305850
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Peter Frandsen (pfrandsen) wrote :

Just added this to hundredpapercuts.

Note to the User Experience and Design team: This should be automatic by default, but a force update would be nice too.

Sebastien Bacher (seb128) wrote :

the requests seem to be a request to add a visible workaround item which will make the context menu harder to use for any user just in case somebody hit a thumbnailing bug, the logic would rather to fix those issues than to polute the interface

Peter Frandsen (pfrandsen) wrote :

Hi Sebastien.

The comments in the bug suggest that the update should be automatic so I
added this bug instead of creating a new one. I agree that the major point
is getting the thumbnail to work correctly is the main issue - and I must
add that it is a major pain point for me.

Should I create a new bug that is just for fixing the thumbnail issue and
suggest that bug for hundredpapercuts?

Regards

/Peter

Sebastien Bacher (seb128) wrote :

> Should I create a new bug that is just for fixing the thumbnail issue and suggest that bug for hundredpapercuts?

You can open a new bug but since thumbnail works just fine for 95% of users that's not a hundredpapercut bug but just something not working correctly with your configuration or a corner case you are using

Lightbreeze (nedhoy-gmail) wrote :

This is not a 'paper cut' because it is not something a user is likely to encounter first day using Ubuntu.

Changed in hundredpapercuts:
status: New → Invalid
Konstantin Konev (skfd) wrote :

> This is not a 'paper cut' because it is not something a user is likely to
Well, I did. The way it works is this:
1. start downloading video files with Transmission
2. visit destination folder -- it fill force nautilus to fail to create thumbnails, because file are not yet downloaded.
3. opening destination after download is complete will still have unthumbed videos and reloading folder won't solve this.
4. I'm bleeding a little.

Changed in hundredpapercuts:
status: Invalid → New
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

-I'm not noticing this problem on Lucid. [or rather very rarely]
When torrent files change/update the thumbnail also updates. yes , there are times where the thumb-nailing fails initially , usually when the download has completed the new thumbnail is formed.
But there are times when the thumbnailing fails too , which is much rare and as mentioned earlier a corner case. Not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Changed in nautilus:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.