Place an Ubuntu icon/emblem on the system partition

Bug #301035 reported by Fred on 2008-11-22
92
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Breathe Icons
Wishlist
Unassigned
Humanity
Undecided
Unassigned
Nautilus
Fix Released
Wishlist
One Hundred Papercuts
Wishlist
Unassigned
gvfs
Fix Released
Medium
ubuntu-artwork
Fix Released
Wishlist
Unassigned
gnome-icon-theme-extras (Ubuntu)
Undecided
Unassigned
gvfs (Ubuntu)
Undecided
Unassigned
human-icon-theme (Ubuntu)
Wishlist
Unassigned
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

For usability reasons I propose that we attach a Ubuntu logo icon to the disk icon for the system partition.

http://img147.imageshack.us/img147/1363/ubuntulogokj8.png

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Mat Tomaszewski (mat.t.) wrote :

I like the idea, not sure what graphical symbol should be used. Any concepts?

Also, "Filesystem" is not a very good name, as it's not immediately obvious that it refers to the Ubuntu system partition.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed

Mat, did you see the screenshot? I think it's pretty convincing as is. Maybe we put OS emblems on your Ubuntu partition, and Windows/Mac OS partitions if we can detect them.

David Siegel wrote:
> Mat, did you see the screenshot? I think it's pretty convincing as is.
> Maybe we put OS emblems on your Ubuntu partition, and Windows/Mac OS
> partitions if we can detect them.
>
>
Sounds good, not sure about copyright issues for Win/Mac.

M.

Yes, look at the screenshot.
Just add an "Ubuntu" icon to the system partition.

Yes, we could also add Windows or Mac icon to other partitions if detected. I am not sure it is a copyright issue, but perhaps a trademark issue. But we could use similar own icons instead of the official ones.
Like for Windows we could have something with 4 colors, red, green, blue, yellow, but we can change the order of the colors, or use different gradients or shapes.

Changed in human-icon-theme (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged

I'm not sure how you set icons in Nautilus to use emblems by default, but adding an Ubuntu logo emblem to the Human icon theme is trivial.

A link needs to be created between /usr/share/icons/Human/scalable/places/start-here.svg and /usr/share/icons/Human/scalable/emblems/emblem-ubuntu.svg A emblem-ubuntu,icon file should also be created.

Just tested it here and was able to add the emblem.

Chris Coulson (chrisccoulson) wrote :

FWIW - the icon name is hardcoded in the gvfsd-computer backend to "drive-harddisk"

Fred wrote:
> Yes, look at the screenshot.
> Just add an "Ubuntu" icon to the system partition.
>
> Yes, we could also add Windows or Mac icon to other partitions if detected. I am not sure it is a copyright issue, but perhaps a trademark issue. But we could use similar own icons instead of the official ones.
> Like for Windows we could have something with 4 colors, red, green, blue, yellow, but we can change the order of the colors, or use different gradients or shapes.
>

If the icon is on that partition, we could use it from there ;-)

What about simply coloring the drives? Or labeling the top of the box symbols?
I think, for a Windows partition a "C:\" would be perfect, combined with a blue color. Comp
I will upload some examples in a day!

Sebastien Bacher (seb128) wrote :

Changing the filesystem icon and name should be easy, could the design team suggest an icon to use which is available in our icon theme or get one drawned and suggest a label?

Fred (eldmannen+launchpad) wrote :

Shuttleworth,
Good point. Clever.

Sebastien,
The icon on the image. http://img147.imageshack.us/img147/1363/ubuntulogokj8.png
/usr/share/icons/Human/scalable/places/distributor-logo.svg
Maybe could just move it to /usr/share/icons/Human/scalable/emblems/

A. Walton (awalton) wrote :

TBH, the bug is filed at the wrong part of the stack. Nautilus with GIO really wants this kind of data to come from the system (via HAL or I guess now DeviceKit-disks). We could hack it into Nautilus, but it really makes sense in DK-D/HAL, where other applications will get the same icon (file chooser, brasero, etc).

Not sure exactly how it should be handled, but we do have GEmblemedIcon for this kind of purpose though IIRC we don't support that in Nautilus yet.

And then there's the question of where do we get the icon... Need to have some standardized location for storing branding information like this. I think Scott Richie is working on this atm.

2 cents, etc.

Fred (eldmannen+launchpad) wrote :

I believe somewhere under /usr/share/icons/, ought to be a good place as a standardized location.

Changed in hundredpapercuts:
milestone: none → round-4
Mik3 (mc4100) wrote :

@Shuttleworth
Unless there's been updates with vista/7, getting any sort of usable icon from windows isn't going to happen. Here's a mockup with all the windows-related icons I could find on my xp partition and scaled down.
Another solution might be this: perfectska04 (gnome colors icons) had a window-ish icon which was replaced in his theme, with the one at the top of the page here http://code.google.com/p/gnome-colors/
That might be a way around legal issues, it's similar but not identical.

Nicolò Chieffo (yelo3) wrote :

I've built a simple patch to change ONLY the icon of the ubuntu partition to the ubuntu logo (no emblems).
I also forwarded it upstream here:
http://bugzilla.gnome.org/show_bug.cgi?id=586488

direct link to patches:
http://bugzilla.gnome.org/attachment.cgi?id=137087
http://bugzilla.gnome.org/attachment.cgi?id=137141

upstream commented only my first patch attempt, then nothing else.
I didn't use the emblem, because it is not distinguish-able in small icons (places menu, nautilus sidebar, gtk file chooser)

Nicolò, can you please attach some screenshots?

I'm sure you can do better than me. Especially I could not set the
icon in the location bar (too difficult)

And why not to change Filesystem to something like "My Ubuntu", "Ubuntu", "My System"? For new users it's more friendly, and it's even more friendly than in Windows.

I agree with Mark Shuttleworth and Mik3, gnome-colors "distributor-logo" is an awesome idea. No one could accuse of copyright violation, because, after all, they're all for simple squares with "4 random colors"...

superfly (superfly) wrote :

This is a great idea.

Vish (vish) wrote :

@Nicolo:
The patch you have submitted is actually a hack, dont get me wrong, you have worked with the icons we presently have.
Using the distributor logo is not the ideal way, the earlier mockups are a better way to implement this.
And in your upstream report the actual nautilus devs havent responded yet.And i highly doubt that they might accept the patch.

 *To have the Ubuntu icon displayed your patch is not required* .We can change the icon in the location bar , by simply editing the /devices/gnome-dev-harddisk. This allows the icon to be displayed also in the location bar.
 But if we change the icon gnome-dev-harddisk to an icon which has Ubuntu logo overlay, that would be used for non-Filesytem drives. [I think you know this already]

*But that would be a better way to do it than the patch* . It could just also mean that the drive is mounted by the Linux OS. ;)

I have attached the screen shot of my setup.[i use the tux logo]

I like the idea, but at present we dont have any provisions to fully implement it.

But the problem here is:
Right now , we use only 2 icons for Harddisk drives,
/devices/gnome-dev-harddisk -> icon for the mounted drives
/devices/gnome-dev-removable -> icon for unmounted drives

So the *location bar always uses the gnome-dev-harddisk icon* , for any mounted partition

But to do this properly and fully, we need:
1: 5 new icons[in all sizes], with new icon names > [1 for filesystem, 2 for windows drives, 2 for linux drives]
2: patches in nautilus and gvfs[to detect the type of the partition, to allow correct icon assign]

*This is actually not a papercut task*. It needs more effort to properly implement it.

C.Kontros (coryisatm) on 2009-07-26
Changed in breathe-icon-set:
status: New → Triaged
importance: Undecided → Wishlist
Vish (vish) on 2009-07-26
Changed in ubuntu-artwork:
status: New → Triaged
importance: Undecided → Wishlist

If we were to change "File System" to "Ubuntu", the use of an icon/emblem might look redundant.

Daniel Fore (danrabbit) wrote :

Can't currently fix this in Humanity, sorry :( The change will have to come in Nautilus first.

Changed in humanity:
status: New → Invalid
MadsRH (madsrh) wrote :

Daniel Rodrigues -> Sould new user mess with the file system? If I'm a new user coming to Ubuntu and I see something titled "Ubuntu", I wouldn't think of that as something not to mess with. But if I see something titled "File system" I really wouldn't want to mess with that.

Mik3 -> +1 that icon look really good.

Perhaps it can be combined with Nicolò Chieffo work, so small 16x16 icons will only show the Ubuntu logo, but larger icons will show the logo on top of the device like in Mik3's attachment.

summary: - Ubuntu icon on the system partition
+ Place an Ubuntu icon/emblem on the system partition
komputes (komputes) wrote :

I agree with this suggestion as it will help new users understand which partition they are working on. I also agree with what has built up from this request to detect other filesystems and perhaps the operating systems installed on them.

I think different ubuntu partitions (installations) should all have an ubuntu emblem. The one currently running, in other words "Filesystem" should have a *distinct* ubuntu symbol, symbolizing that it is the running system drive.

I like the icon proposed for windows drives/installations, but will this actually detect a system presence or will it simply put that icon on any NTFS/FAT partition?

Also, for people using a dual boot mac, perhaps we should put together an icon for when those drives or filesystems are detected.

I agree with putting a tux symbol on any other detected installed distros (or if using filesystem detection, ext2,3,4) than ubuntu.

Vikram Dhillon (dhillon-v10) wrote :

Yah this makes sense, it would look pleasing I am proposing these icons, please have a look at them and give your reviews

Vikram Dhillon (dhillon-v10) wrote :
Vikram Dhillon (dhillon-v10) wrote :

I propose these 3 icons...

Vish (vish) wrote :

Hmm... Just an idea, since there are concerns about copyright for using Windows or apple, colors or logo

While Ubuntu has its icon.
How about using just the name? "Windows" / "Apple" over the drive?
 or would that amount to copyright too!

komputes (komputes) wrote :

Ubuntu can't use the "official" registered Microsoft Windows and Apple logos because of copyright laws. What is possible is to make a logo that looks similar. Sun does this in virtualbox (showing a 4-colour butterfly icon for windows virtual machines). Mik3 has also proposed something like this in the bottom right of this file:

http://launchpadlibrarian.net/28408628/mockup-extractedwindowsicons.png

Attached is a mockup of what I think these icons could look like.

Zephyrcat (egyptianmua) wrote :

I can't believe I'm the first to suggest this, but we could take a page from Apple and poke a little fun at Microsoft (see attachment).

More seriously, I think the disk icon should stay in the background to indicate the actual partition and not confuse it with things like the applications menu. Adding an Ubuntu logo over the disk icon, however, is a great idea.

komputes (komputes) wrote :

Zephyrcat, very cute and funny, but it's small and illegible (unless you stretch out the icon). What did Apple do to poke fun at M$ (other than those commercials)?

Actually this is not a nautilus bug, it's gvfs.

In daemon/gvfsbackendcomputer.c around line 522 we have
  file->display_name = g_strdup (_("Filesystem"));
  file->icon = g_themed_icon_new ("drive-harddisk");
  file->root = g_file_new_for_path ("/");

I think just changing "drive-harddisk" to "drive-harddisk-dist" and providing an icon would do it.

Discussed with DanRabbit in #ayatana we suggest the naming would be drive-harddisk-root to be able to use the g_themed_icon_new_with_default_fallbacks () function.

Then I saw the progress in bug [1] that's using the "distributor-logo", "start-here", "drive-harddisk" order to get the icon. (And it's also more complete as it also got patches for nautilus)

However, DanRabbit created an icon in the humanity icon set and it's added to bzr in devices/48/drive-harddisk-root.

So, everything is ready to be packaged for karmic but we'll have to go with patches as upstream is in ui freeze.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=586488

Fred (eldmannen+launchpad) wrote :

Marcus,
I see you proposed drive-harddisk-root.
Is it a disk/drive or a partition?
SSD is a harddisk?

Hard disks are disappearing, they're getting replaced with solid-state disks. Perhaps a better name would be storage-device.
storage-device-system?

Vish (vish) wrote :

Marcus , the current patch upstream is not right , its a workaround. pls read comment #20.

The work needs to be done as you have described [new naming],
If it is absolutely essential to get this done in Karmic , it is easier to edit the gnome-dev-harddisk icon to have a logo than applying the current upstream patch!

Also, you havent added your patch upstream, Why ?
And does upstream have a provision for feature freeze exceptions? [like Ubuntu ;) ]

Fred, as I said I wanted that name to be able to use the g_themed_icon_new_with_default_fallbacks () function - if you would like to change how the icon looks like you just edit the icon. Actually the root filesystem can be a cdrom (live cd), nfs (network boot), zip disk (if you still got one), etc etc... My proposal doesn't break any existing themes and only themes that supplies the new icon -root, -filesystem or what we end up calling it will see the change.

DanRabbit used the gnome-removable as base for the icon and I think its good enough. See attached screenshot.

mac_v, I'll see if I can discuss this with nautilus devs and see what solution they would like to see. Yes, they can make exceptions but I don't think they sees this that important (but I did ask in the bug upstream).

Nicolò Chieffo (yelo3) wrote :

debdiff against nautilus_2.27.92-0ubuntu1

tested: works either if the theme has drive-harddisk-root icon or not
also submitted upstream

Nicolò Chieffo (yelo3) wrote :

gvfs patch (tested works)

OK. I like the idea of identifying them graphically. I had an idea though.

Instead of using a bitmap on top (like a stamp), why not use a pre-rendered drop shadow that uses a gradient that is representative of the operating system. Windows would be
Red Green
Blue Yellow

as such--just make gradients that act as drop shadows using the default palettes for the Mac and Windows logos. i dont have time to make an image of my idea right now, but if you need one, just ask me and I'll try later.

I agree with the idea of Mik3 (http://launchpadlibrarian.net/28408628/mockup-extractedwindowsicons.png), first because looks very nice and seconds makes sense to the new users, because they will know where it is located their Windows/Mac files on Ubuntu (believe me this was hard to me the first time I used a Linux distro).

And also the idea of Daniel Rodrigues to put a name under the disk such Ubuntu, Windows, Mac or My Ubuntu (windows/mac) is very easy to understand for a new user when it's looking for very important files in the other partition (let's say this MP3 that wants to play with Amarok or Banshee).

Changed in hundredpapercuts:
milestone: round-4 → lucid-round-3

If this gets impliemented, I'd strongly recommend making this change easily removable with its own package (or part of an existing Ubuntu branding package). That way downstream distros won't have to fork nautilus just to change the branding...

Fred (eldmannen+launchpad) wrote :

Also a icon could be played on a file system containing Windows.
The icon used could be the one from Wubi.

tags: added: emblem emblems icon icons
Changed in nautilus:
status: New → Invalid
Vish (vish) wrote :

Upstream comment:

I'd like to get some comments on why this is required. I see from the Launchpad
bug that the idea is to be able to have an icon schema which would identify
Windows and Mac partitions as well. Is that the central reasoning here?

Marking bug incomplete , could someone comment upstream as to why this is needed?

Changed in hundredpapercuts:
milestone: lucid-round-3 → none
status: Confirmed → Incomplete
Changed in nautilus (Ubuntu):
status: Triaged → Incomplete
Changed in nautilus:
status: Invalid → Unknown
tags: added: patch-forwarded-upstream
Fred (eldmannen+launchpad) wrote :

Vish,
I think it would increase usability to have the system partition have a distribution logo.
Having Windows and Mac icons would be cool too.
But this idea per se is about a distribution logo on the system partition.

Changed in nautilus:
status: Unknown → New
Changed in nautilus:
importance: Unknown → Wishlist

Re-confirming as a paper cut after comments requested in comment #45 were provided upstream.

Changed in hundredpapercuts:
status: Incomplete → Confirmed

Moving from Nautilus to GVfs as per comments here and upstream. A fix in Nautilus would just be a hack that would have to be reworked when a new release came out.

Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
Changed in hundredpapercuts:
importance: Low → Wishlist
Timothy Arceri (t-fridey) wrote :

The upstream does not say that a change to Nautilus would be a hack. It says that the patch to gvfs should be submitted in the gvfs bug tracker.

The change needs to be made it both projects in order to have a consitent icon. The current icon is hard coded in both projects and therefore should be changed in both.

I have opened a new bug upstream in gvfs here: https://bugzilla.gnome.org/show_bug.cgi?id=655692

Changed in gvfs (Ubuntu):
status: New → Confirmed
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
Changed in gvfs:
importance: Medium → Unknown
status: New → Unknown
Timothy Arceri (t-fridey) wrote :

Icon that needs to be updated is part of gnome-icon-theme-extras see: https://bugzilla.gnome.org/show_bug.cgi?id=620239
Marking breathe-icon-set as invalid

Changed in breathe-icon-set:
status: Triaged → Invalid
Timothy Arceri (t-fridey) wrote :

Icon that needs to be updated is part of gnome-icon-theme-extras see: https://bugzilla.gnome.org/show_bug.cgi?id=620239
Marking human-icon-theme as invalid

Changed in human-icon-theme (Ubuntu):
status: Triaged → Invalid
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
Timothy Arceri (t-fridey) wrote :

This is fixed in Nautilus 3.1.4, just gvfs to go

Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in nautilus:
status: New → Fix Released
Timothy Arceri (t-fridey) wrote :

All fixed have now been commited :-)

Changed in hundredpapercuts:
status: In Progress → Fix Committed
Timothy Arceri (t-fridey) wrote :

Gvfs fix commited upstream

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-artwork:
status: Triaged → Fix Released
Changed in gnome-icon-theme-extras (Ubuntu):
status: New → Fix Released
Changed in gvfs:
status: New → Fix Released
Timothy Arceri (t-fridey) wrote :

gvfs 1.9.4 has the final fix for this bug, is it to late to get it included in Oneiric??? The current Oneiric version is 1.9.3

komputes (komputes) wrote :

It us up to the Ubuntu Release team to decide if gvfs 1.9.4 fits into the Freeze Exception guidelines.

https://wiki.ubuntu.com/FreezeExceptionProcess

That being said, now that there is no more "My Computer" view of disks in nautilus this will have to apply to very small icons of the disks (and perhaps /media). Can anyone provide a screenshot if they have this running on oneiric?

Timothy Arceri (t-fridey) wrote :

"there is no more "My Computer" view of disks in nautilus" This is not true, the big computer button is gone but there is a menu item Go -> Computer as seen in my screenshot.

It would be nice if gvfs could be updated so that the icons are consistent.

Sebastien Bacher (seb128) wrote :

gvfs doesn't need a ffe since GNOME has a standing exception

Timothy Arceri (t-fridey) wrote :

Yeah 1.9 I just realised is a development release so it will be updated before the final Oneiric. 1.9.5 has just been added as a source package to oneiric so should be able to confirm this is fixed soon.

Timothy Arceri (t-fridey) wrote :

All looking good, I have attached a screenshot for those interested in what the final result looks like.

Making as fixed :-)

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Fred (eldmannen+launchpad) wrote :

Thanks!
I confirm this is fixed in 10.10 Oneiric.

Maybe it would be nice if file systems with Windows and Mac got icons too.
Maybe would be nice if it was expanded to give /cdrom, /home, and /tmp some icons too.

Timothy Arceri (t-fridey) wrote :

I Fred each of these would need there own bug reports filed.

Fred (eldmannen+launchpad) wrote :

Icon proposal for /

Timothy Arceri (t-fridey) wrote :

Hi fred, I think that looks really good. However can you please create a new bug report for this. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.