Ubuntu

Inconsistent spelling of "Filesystem" (vs. "File system")

Reported by Hernando Torque on 2008-11-13
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Undecided
Unassigned
One Hundred Papercuts
Undecided
Unassigned
gvfs
Fix Released
Medium
gvfs (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher

Bug Description

Binary package hint: gvfs

The names for the root partition in Nautilus' Places panel and main panel (Computer view) differ.

Screenshot: http://img.xrmb2.net/images/242451.png

Not sure this is gvfs related, though.

gvfs:
  Installed: 1.0.2-0ubuntu1
  Candidate: 1.0.2-0ubuntu1
  Version table:
 *** 1.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

nautilus:
  Installed: 1:2.24.1-0ubuntu1
  Candidate: 1:2.24.1-0ubuntu1
  Version table:
 *** 1:2.24.1-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Connor Imes (rocket2dmn) wrote :

Thank you for taking the time to report this bug. I think that it is more likely a nautilus problem, so I am setting the package to nautilus.
I can confirm that this bug also exists in Hardy. Since there is enough information here, I am marking this bug as Triaged so that a developer can have a look at it and begin work.

Changed in gvfs:
importance: Undecided → Low
status: New → Triaged
Connor Imes (rocket2dmn) wrote :

I think bug 53619 is worth mentioning here, as it complains that "filesystem" is a poor name choice for the root partition.

Changed in nautilus:
status: Unknown → New
Changed in nautilus:
status: New → Invalid
summary: - Inconsistent naming of root partition in Nautilus
+ non consistant filesystem spelling in GNOME
Changed in nautilus:
status: Invalid → New
Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)

Sebastien,
You misspelled "consistent" in the summary.

A. Walton (awalton) on 2009-06-16
summary: - non consistant filesystem spelling in GNOME
+ non consistent filesystem spelling in GNOME

We want to settle on a single name for this, and it may not be "Filesystem" or "File System".

Changed in hundredpapercuts:
status: New → Confirmed
summary: - non consistent filesystem spelling in GNOME
+ Inconsistent filesystem spelling in GNOME
summary: - Inconsistent filesystem spelling in GNOME
+ Inconsistent spelling of "Filesystem" (vs. "File system")
Nicolò Chieffo (yelo3) wrote :

Will you also accept a patch to attach the "distributor-logo" (ubuntu icon) to the filesystem folder?
currently the icon is missing in computer:/// since I couldn't find it where's in the code, can you help?

Nicolò Chieffo (yelo3) wrote :

in computer:/// "Filesystem" is taken from gvfs (daemon/gvfsbackendcomputer.c)

Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Hernando Torque (htorque) wrote :

If you decide not to call it "File System"/"Filesystem" you may want to change it in the filebrowser (or file browser ;)) plugin in Gedit too (plugins/filebrowser/gedit-file-bookmarks-store.c, end of function init_special_directories).

Changed in hundredpapercuts:
milestone: none → round-7
Bryce Harrington (bryce) wrote :

Well, someone needs to make the decision about what to name it, but here's a patch to change gvfs to "File System" if that's the decision.

Changed in gvfs (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Bryce Harrington (bryceharrington)
status: Triaged → In Progress
Marat (marat-hotmail) wrote :

In my german Ubuntu I have 1 translation.

Hernando Torque (htorque) wrote :

Sure, because "Datei System" would be an orthographic mistake ("Deppenleerzeichen"). ;-)

"Filesystem" and "File System" are used interchangeably from what the dictionary tells me. I think we all realize that both are pretty bad names, but for the sake of consistency, let's agree on Bryce's suggestion go with "File System" across the board. We should open another bug to suggest a better name.

Bryce, is this ok?

On Thu, Aug 20, 2009 at 08:30:11PM -0000, David Siegel wrote:
> "Filesystem" and "File System" are used interchangeably from what the
> dictionary tells me. I think we all realize that both are pretty bad
> names, but for the sake of consistency, let's agree on Bryce's
> suggestion go with "File System" across the board. We should open
> another bug to suggest a better name.
>
> Bryce, is this ok?

Sure, sounds good to me.

komputes (komputes) wrote :

Changing the name of Filesystem was proposed in this papercut as well:
https://bugs.edge.launchpad.net/ubuntu/+source/nautilus/+bug/301035/comments/18

Changed in hundredpapercuts:
status: Confirmed → In Progress
dael99 (dael99) wrote :

Why not name this just Linux...

so, new users will know that everything related to the system is Linux.

The Kernel, the files, everything is the filesystem... so, everything is Linux.

We, the geeks, know that linux if more than a cople of files, but introduce the Linux concept to new users is really hard.
They first need to know about kernel, aboud desktop, about distribution and lot of things!!.

So, peter, a new linux user will see 'Linux' click it and see a lot of files related to the system. So, from today, peter will know that linux is his system. He already knows that his good frien dael has installed on his PC a copy of Ubuntu, so he knows he runs Ubuntu, but from today he will know that his Ubuntu has something related to the system called Linux.

Nice, isn't it?

Changed in hundredpapercuts:
milestone: round-7 → r1
Changed in hundredpapercuts:
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

Discussed and disputed upstream, and we will not do such string changes at the distro level.

Changed in hundredpapercuts:
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in gvfs (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
status: In Progress → Triaged
Sebastien Bacher (seb128) wrote :

unsubscribing the sponsors as stated by pitti before that's not something we will change in ubuntu specifically

Sebastien Bacher (seb128) wrote :

I just pinged upstream on IRC and he said to commit the change, it will be in the next lucid version

Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

it's not a nautilus bug

Changed in nautilus (Ubuntu):
status: Triaged → Invalid
Vish (vish) on 2009-12-16
Changed in hundredpapercuts:
status: In Progress → Fix Committed

Reassigning ti match the upstream product.

Changed in nautilus:
importance: Unknown → Undecided
status: New → Invalid
Sebastien Bacher (seb128) wrote :

the change is in lucid for some time now

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
status: Fix Released → In Progress
Sebastien Bacher (seb128) wrote :

closing hundredpapercuts tasks

Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
Changed in gvfs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.