nautilus thumbnails files on a mounted NFS share

Bug #293311 reported by Bert Vermeulen on 2008-11-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
New
Low
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

In the nautilus file browser, Edit -> Preferences -> Preview, thumbnailing is set to "Local Files Only". However, nautilus will still try to thumbnails video files on an NFS share.

Seeing this on ubuntu 8.10, package version 1:2.24.1-0ubuntu1

Sebastien Bacher (seb128) wrote :

thank you for your bug report, nfs shares are usually local one and fast and not slow access over internet, that's an upstream choice to consider those as local and not a bug

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
Changed in nautilus (Ubuntu):
status: Invalid → Confirmed
Dennis Sheil (dennis-sheil) wrote :

"nfs shares are usually local"

We have a lot of ambiguity with the word local here, which is the entire problem. I'm not sure what local means in "nfs shares are usually local" - on the local host? On the same subnet? In the same location? In the same organization? In the same city? Furthermore, on what basis are these assumptions being made, I've seen plenty of NFS shares from machines in say, Tokyo or London to machines in New York. The basis for making this bug invalid is ambiguous, and where it is not ambiguous I don't know on what basis someone would say NFS shares are usually local. And even if NFS shares were local 75% of the time, whatever local means, what would that have to do with the failure rate the other 25% of the time.

I assume local in this specific context means whatever GIO/GVFS for Nautilus considers local.

Upstream did implement it this way, but I think they should be alerted to this ambiguity. I had the same problem myself today before I came across this bug report.

Even if they do choose to let it remain, I think there should be thought into changing this locally. Isn't the entire point of the Ubuntu desktop, as opposed to say Debian or Gentoo or whatever, to be user-friendly? I've been a professional Unix systems administrator since the mid-1990s, and I can't make heads or tails by what Nautilus means by local, even looking over the code and documentation. So what hope has the average Ubuntu user?

I will be reporting this upstream.

Changed in nautilus:
importance: Unknown → Low
status: Unknown → New
Lenin (gagarin) wrote :

I wouldn't have thought nfs shares being local... and I'm having big user experience problems with many users that now switched to Natty... although turning off all the local previews in nautilus still doesn't solve the problems.

"nfs shares are usually local": this is completely counter-intuitive. NFS = Network File System. I think most would agree than a "network" file system is definitely not a local one (and would rightly so, when considering the differences in terms of access latencies).
Even on a high-bandwidth LAN (with 10GbE and 500+ Gb/s core switching capacity), having Nautilus preview feature enabled by default on NFS shares just throws our filers down, thanks to thumbnailing kicking in when users browse their 20'000+ (scientific research) videos folder.

cotillion (tobias-schwan) wrote :

I agree with Cedric. This freezes nautilus everytime I access folders with pictures or videos in it. Most times only for a few seconds, but when there are several video files in the folder nautilus can freeze for minutes until it has produced a thumbnail for every single video.

At least an option for excluding nfs from thumbnailing would help.

Sebastien Bacher (seb128) wrote :

Could you try if that's still an issue in newer versions?

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Incomplete
David Rosky (drosky) wrote :

Please do not remove thumbnails from NFS mounted folders. I have 1.5TB of photos stored on a local NAS (local = same LAN) connected over a 1Gb/s ethernet connection. I access these through NFS and I am absolutely dependent on having thumbnails available for those images. With any modern local area network, wired or WiFi, access is plenty fast to allow thumbnails with only minimal delay compared to files on the same physical machine.

I don't mind if an option is added to opt out of thumbnails over NFS, but if it is completely removed with no option, I will need to either abandon nautilus, which I don't want to do, or allow thumbnailing on ALL remote connections, which will be an absolute mess on slower connections such as Google Drive.

Same would apply for SMB. NFS and SMB are used primarily on fast LANs 99% of the time. Please don't remove thumbnailing from NFS/SMB folders and put the 1% use case above the 99% use case.

Thanks.

David Rosky (drosky) wrote :

A real solution to this problem would be for Nautilus to have an Auto mode for thumbnailing, where the actual bandwidth of the connection is tested, and thumbnailing is turned on or off automatically depending on the actual connection speed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.