Ellipsize long folder names in the location bar

Bug #272792 reported by David Prieto on 2008-09-21
This bug report is a duplicate of:  Bug #27064: Nautilus location bar disappears. Edit Remove
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
One Hundred Papercuts
Low
Ted M Lin
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: nautilus

If you create a folder with a really long name it will somehow mess with the pathbar buttons, so nothing will be shown. Try to create a folder and call it "a folder with a really really long name that does not actually fit the address bar as it should". Open it and see what happens: the pathbar buttons, as well as the view and zoom buttons, disappear from the nautilus window.

Even if the name is not so long and it actually fits the address bar, it may be the case that there is only place for it in the bar. Try creating a folder and call it "a folder with a really really long name that even so still fits the address bar". Then open it and see what happens.

Parent folders are not shown. This defeats the whole purpose of the bar as a navigational element, and is therefore not efficient.

What I'm proposing is, ellipsize folder names that exceed a certain size in the path bar. Show the whole name on the window title, maybe on a tooltip if you keep the cursor hovering over the button, but keep pathbar buttons under a certain size.

Ahmad Tarek (ahmadtarek) wrote :

I confirm it.

Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
Changed in nautilus:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

There's a bug upstream describing issues with the location bar also and saying also that ellipsize should be used there, the bug is here: http://bugzilla.gnome.org/show_bug.cgi?id=550215 ; linking the report, thanks for reporting.

Changed in nautilus:
status: Confirmed → Triaged
Changed in nautilus:
status: New → Invalid
A. Walton (awalton) on 2008-12-17
Changed in nautilus:
status: Invalid → Unknown
Changed in nautilus:
status: Unknown → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
summary: - ellipsize long folder names in the address bar
+ Ellipsize long folder names in the location bar
Changed in hundredpapercuts:
milestone: none → round-7
milestone: round-7 → round-8
Ted M Lin (kitlaan) wrote :

Here's a possible patch to allow ellipsis into the pathbar button labels by forcing a maximum label width (and a tooltip to show the entire label). The solution provided in this patch isn't great (it forcibly limits the width of the button), it's a step in the right direction. (The patch has also been attached to the upstream bug.)

The patch could be improved to eliminate the hardcoded width (200px), to allow the label to be as wide as possible without the pathbar vanishing entirely, but I'm not quite sure how to approach that yet.

komputes (komputes) wrote :

Wow, this is a bad bug. Good catch!

I think it should truncate the long folder name to the first few characters followed by "..."

So "a folder with a really really long name that does not actually fit the address bar as it should" would become:
"a folder with..."

To make it more usable, when putting the cursor over that part of the location bar, we could display the complete folder name in a tooltip.

Changed in hundredpapercuts:
assignee: nobody → Ted M Lin (kitlaan)
status: Confirmed → In Progress
Changed in hundredpapercuts:
milestone: round-8 → r1
Changed in hundredpapercuts:
assignee: Ted M Lin (kitlaan) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2009-12-01
Changed in hundredpapercuts:
assignee: Canonical Desktop Team (canonical-desktop-team) → Ted M Lin (kitlaan)
Sebastien Bacher (seb128) wrote :

unsubscrbing sponsors for now there, thank you for your work but that's something which should better reviewed upstream since it's somewhat a hack in the current way, I've giving them a ping on IRC now let's see how it works

Vish (vish) on 2010-02-13
Changed in hundredpapercuts:
importance: Undecided → Low
Xhacker Liu (xhacker) wrote :

Any progress?

Ted M Lin (kitlaan) wrote :

The patch is a bit of a hack, and should be improved upon. There has been no recent comments from upstream about it. My last discussion (December?) with some upstream devs wasn't conclusive.

If anyone wants to take a poke and try something else, other ideas are welcome!

Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: lucid-round-1 → maverick-round-1-file-management
status: In Progress → Triaged
Vish (vish) on 2010-07-01
tags: added: patch-forwarded-upstream
Changed in nautilus:
importance: Unknown → Medium
Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-1-file-management → nt4-nautilus
entonjackson (aj-mysc) wrote :

I was just experiencing the same bug here.
to me this bug is critical and should be fixed asap.

Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.