"Browse network" removed from "Connect to server", and is now inconsistent with printing

Bug #252904 reported by Colin Watson on 2008-07-29
6
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Low
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

http://www.arsgeek.org/2008/05/31/six-annoyances-in-hardy-heron-ubuntu/ observes that the "Browse network" button was removed from nautilus-connect-server:

"It used to be that if you click Places->Connect to Server and selected a Windows share, you saw a “Browse Network” button. Now that button is gone for me. I guess you need to know the exact name of the Samba or Windows share that you want to connect to? If so, that’s pretty annoying. It’s also inconsistent, because when I tried to add a printer on a remote machine, I could browse the network from the printer dialog box."

For the sake of fairness, there is a contrary opinion in http://bugzilla.gnome.org/show_bug.cgi?id=171218, and I added a link to the commit that removed this button. The revision log for that commit simply says "Remove the Browse button, which isn't really needed there".

I'm not sure I feel strongly about the button itself, although it does seem like it's useful if you don't know the exact name. However, as stated, it's definitely inconsistent with adding a printer, so we should look at making this consistent.

Sebastien Bacher (seb128) wrote :

thanks for the bug Colin but as the comment points that's an upstream decision, do you suggest going against upstream and adding the button back in the dialog? the printing point doesn't really stand there since nautilus doesn't let you add printers anyway, system-config-printer should rather have this browsing option

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Incomplete
Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
status: Incomplete → Triaged
Changed in nautilus:
status: Confirmed → Invalid
Changed in nautilus:
importance: Unknown → Low
status: Invalid → Expired
David (dwoodcock1) wrote :

ubuntu 16.04

Please give me back "browse network" we use it many times in a day it's important to us

If you have moved it...please where to ?

Keep up the good work

David

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.