Can't copy to disk mounted under a Samba share if space doesn't exist in the share

Bug #243431 reported by Ashley Kyd on 2008-06-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I've got a directory on my server with several mount points inside, shared using Samba. Using Nautilus, I can't copy files to the mounted disks inside the share, unless ample space exists on the parent disk.

The space exists on the mounted disks, but Nautilus doesn't recognise that there is indeed more space available and refuses to copy. The only workaround is to use each disk as its own share, and mount them all on the client.

Hypothetical:
 * I have a server with a samba share /home/foo with 5 meg free space.
 * I have a mount under this directory /home/foo/disk with 10 meg free space.
 * Mounting the foo share on my Ubuntu desktop is no problem, but when I want to copy a 10 meg file to foo/disk, Nautilus refuses telling me I only have 5 meg free.

Ashley Kyd (ashkyd) on 2008-06-27
description: updated
Parthan SR (parth-technofreak) wrote :

Thank you for taking your time to file this bug and help make Ubuntu better. As far as I have enquired, when you mount a remote file system on your local machine using your samba share, may be on a different partition, still it's size is only the size of the source file system and not of the local filesystem. Hence a 5MB remote FS mounted on a 10MB local FS is still 5MB only, as the remote FS can't take anything more than 5MB. Thus, what you are reporting is most probably not a bug at all but an existing constraint rather. If nobody else can confirm this as wrong, we should be closing this bug.

Ashley Kyd (ashkyd) wrote :

Sorry, I mightn't have been clear here. The 10MB file system is mounted to a directory inside the 5MB file system on the remote server.

When I mount the share on my client I see 5MB of free space, and the directory/mount where the 10MB filesystem is mounted.

I can write to either file system, but can not write more than 5MB regardless of which file system I put it on.

I hope this clears things up.

Ashley Kyd (ashkyd) wrote :

Additionally, I have verified that Samba is writing to both devices, and not writing to the original file system underneath the mount.

To be clear, I believe there is a bug in the way Nautilus calculates free disk space in this circumstance.

I've attached a screenshot of what Nautilus says, and the output of df -h on the server. I've helpfully scribbled over it to hopefully make things clearer.

Parthan SR (parth-technofreak) wrote :

To put it better, a samba shared FS on a local system is still representing a remote FS and the operation you want to do on it are nothing but what you want to be done on the remote FS. Thus, when the remote FS has only 5MB size it wouldn't be allowing any operation running out of space, like copying an 8MB file to it. When this remote FS is mounted on a local FS, it still needs to reflect the same character or else it doesn't fit as an ideal sharing of a remote FS locally. Hence, it shouldn't allow you to copy a file to the locally mounted shared FS, when the file is bigger than the space available in remote FS. If it allows you to copy it to locally mounted+shared FS, it doesn't make sense as it still can't be reflected on the remote server due to non-availability of space.

Thus it is not a bug, but rather the most logical response not to allow copying a 8MB file over a remote shared FS of max size available=5MB, but locally mounted on an FS which has max avail size=10MB(as a local FS, but not when it represents the remote FS). If you can prove otherwise, please feel free to reopen this bug. Thanks.

Changed in nautilus:
status: New → Invalid
Parthan SR (parth-technofreak) wrote :

Am afraid both of us were commenting at the same time, and hence there is a confusion. Opening it again as your screenshot makes some sense.

Changed in nautilus:
status: Invalid → New
Parthan SR (parth-technofreak) wrote :

Can you put your case more clearly?

* What's the size of space available in the source FS
* What's the size of the partition you are trying to mount the samba share on? (looks like /home/ash/Backups is your target for mount)
* What's the size of the file you are trying to copy to the source FS, through the mounted partition?
* The screenshot states /home on /dev/hda7 to be 14Gigs and /home/ash/Backups on /dev/hdb2 to be 284Gigs. Where are these hda7 and hdb2 located? Where is your mounted shared FS present - hda7 or hdb2?

Thanks in advance.

Changed in nautilus:
status: New → Incomplete
Parthan SR (parth-technofreak) wrote :

So what you are accessing through Samba share is actually a 5MB partition by itself? And this 5MB partition is actually a mount point of 10MB partition? This seems to be a scenario which needs testing and confirmation. But still, as you are accessing a FS which is of size Y MB through Samba, the locally mounted share of the remote FS might allow only 5MB. So, is this a bug on nautilus or on samba?

Parthan SR (parth-technofreak) wrote :

And, which distribution/OS are you running in the remote machine?

Ashley Kyd (ashkyd) wrote :

In this case I've shared /home/ash on the server, and mounted it on my client. I'm trying to copy to the subdirectory "Backups" which as you can see is mounted with 284 gig free on the server, but Nautilus doesn't recognise that there's more space in Backups than on the rest of the share and won't let me copy anything larger than the 13.8 gig.

 * I'm using Ubuntu, 8.04 Hardy Heron on my desktop.
 * The server is still running 7.10 I believe; the kernel is 2.6.22-15-generic, and "apt-cache show samba" reports I'm using 3.0.26a-1ubuntu2.

Sebastien Bacher (seb128) wrote :

the issue seems to be an upstream one, could anybody having it open a bug on bugzilla.gnome.org?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Parthan SR (parth-technofreak) wrote :

Have reported the bug upstream at bugzilla.gnome.org and linked the upstream bug to this bug as well. Thank you.

Sebastien Bacher (seb128) wrote :

thank you for sending the bug report to GNOME

Changed in nautilus:
status: Incomplete → Triaged
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
importance: Unknown → Medium
Changed in nautilus:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.