Mousing over an audio file on the desktop should not preview it.

Bug #237975 reported by Evan
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

I was working on one desktop when I suddenly heard music playing. Thinking it was a Flash video somewhere in Firefox, I switched desktops using the keyboard and it stopped playing. I switched back and it started playing again. After a minute of this back and forth I noticed that my mouse was hovering over an mp3 file on the desktop.

While the audio preview is a useful feature in nautilus windows, I'm not sure it makes sense for the desktop.

Changed in nautilus:
status: New → Confirmed
Revision history for this message
A. Walton (awalton) wrote :

Thanks for your bug. You may track its progress upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=537905

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
importance: Wishlist → Low
Revision history for this message
Scott Ritchie (scottritchie) wrote :

So, upstream does NOT want to fix this, according to the bug report, so we should have a discussion about disabling it on our end. I did a quick sampling of about 10 9.04 beta testers and found that 0 of them used the audio preview productively while 2 of them (plus myself) were at least partially confused by it.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Not sure that's an hundredpapercut since that's basically a design decision from upstream, let's see if the canonical design team has a different opinion there though

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Not a paper cut, as Sebastian points out.

Changed in hundredpapercuts:
status: New → Invalid
Revision history for this message
Tom Wright (twright-tdw) wrote :

Would a better solution be to look at the underlying UI (or lack thereof) functionality behind audio preview ranther than just selectively disabling it? The upstream bug here discusses it: http://bugzilla.gnome.org/show_bug.cgi?id=533153 - I think that a play button on the icons dispayed on hover sounds best.

Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
importance: Unknown → Medium
Changed in nautilus:
status: Confirmed → Expired
Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your bug report, the issue is fixed in Oneiric where the audio preview feature has been dropped

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released
Revision history for this message
Ngassam Nkwenga (cyrildz) wrote :

sorry but I'm really against this Fix.
audio file previewing is one of our habits and it is a great feature to test a song without having to open Banshee or any other audio software.
At least , we should have an option to turn it ON or OFF. We should review this bug

Revision history for this message
Tom Wright (twright-tdw) wrote :

@cyrildz but would a better solution not simply to be to preview the audio file on clicking a play button displayed on the icon? That way it is still easy to access but less likely to be triggered accidentally.

Revision history for this message
Florent Delayen (tnedel) wrote :

I love this -- feature -- ! It's not a bug but something really interesting when searching a song for example, I use it really often and before we have another solution (yes, click on it should be a good one), you've just drop the feature !

I think, before drop something, we should have a solution and replace existing solution that have problems by another, but not delete it...

Wrong way...

Revision history for this message
Ngassam Nkwenga (cyrildz) wrote :

Tom : any solution yet to enable the preview of audio file is welcome.
Just because people misused it or activate it randomly and causing trouble for them is not an argument to simply drop it .
when Unity came, Ubuntu dev have still provide a way to have the old Shell as well as Gnome-shell , the same thing should be done here. disable but provide a way to activate it again when a user want it. deleting this option is not the best way.

Revision history for this message
stiss (slouveau) wrote :

Why? remove the ability to view its audio files? Please, think of those on ubuntu for years! does not take away all!

Revision history for this message
Opiwa (nicotiane-launchpad) wrote :

It's a easy way to preview audio files. Please, get us back this facility

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.