Ubuntu

nautilus cannot handle

Reported by FerNalGas on 2008-05-22
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

When I go to Places>Computer this message comes up:
Nautilus cannot handle computer: locations.

When I go to Places>CD/DVD Creator this message comes up:
Nautilus cannot handle burn: locations.

For both errors the heading is:
Couldn't Display "computer" or DVD creator.

I am using Ubuntu Hardy Heron.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, does using gvfs-ls on those is working correctly?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Ben Bailes (eurobob) wrote :

I can confirm I have the same problem. Not sure what using gvfs-ls is exactly, but I can browse folders other than computer, networking, etc.

My USB stick no longer mounts automatically (but definitely works as tested on other machines) nor does my mp3 player, and oddly i get the following message when accessing a CD Rom in Nautilus:

"mount: block device /dev/scd0 is write-protected, mounting read-only
mount: /dev/scd0 already mounted or /media/cdrom0 busy
mount: according to mtab, /dev/scd0 is already mounted on /media/cdrom0"

yet I can access files as normal. not seen this message before.

Have also noticed that there is now only 1 service type option in "connect to server" which is "custom location".

All this has occured at some point in the last week so I have reason to believe it is related.

Please this is a serious issue and the importance is surely high? When looking around for other people who have the same problem there is a significant amount who have reported it in the last couple of weeks.

Thanks,
Ben

Hardy Heron, Nautilus 2.22.2

bankanidhi (bankanidhi) wrote :

HI all,
   I also get the same problem.

Jeff Bronks (jeffb-dsl) wrote :

Me too. It started today. Places / Computer doesn't work. All drives are now listed under "Removable Media" even if they aren't removable. And USB flash drives don't work.

Help!

OS: Hardy Heron 8.04

T-Lo (ausserirdischer) wrote :

I got the same problems too.
Nautilus won't open Computer, Network and the trash anymore.
Usb sticks are not mounted automatically by nautilus and the trash symbol disappered in the panel :/

Ben Ruyl (benruyl) wrote :

I'm having the same problems. I'm using Ubuntu 8.04.

Started happening to me when I upgraded to Hardy Heron.

Abandon nautilus for PCmanFM until it's fixed.

My NTFS partitions and external harddrives stopped automounting. To fix that I put in my .bashrc (all one line):

alias fixfuse='sudo mv /usr/local/lib/libfuse.so.2 /usr/local/lib/libfuse.so.2.old ; sudo ln -s /lib/libfuse.so.2.7.2 /usr/local/lib/libfuse.so.2'

Everytime I use "Update manager" this breaks. When it does, in a terminal I execute:

fixfuse

... And my NTFS filesystems again automount.

Has this worked for everyone???

Jeff Bronks (jeffb-dsl) wrote :

Yes and no.

Adding the line to .bashrc made no difference. The Gnome 'Places > Computer' link still doesn't work, nor does automounting, and all the fixed drives are still listed under 'Removable Drives'.

However, PCmanFM does work much better than Naughty Loss. Thanks, Artships, for that suggestion.

If I switch on the side pane, it displays all my drives by their correct labels (Nautilus had lost these, displaying just 'sda1' etc.) PCmanFM also displays my flash drive, although it won't mount it. I have to do 'Tools > Open as Root' to get the flash drive to mount, which is a pain but better than nothing.

Jan Andersson (jan-lynga) wrote :

Same problem for me, computer, network and no trash. OS 8.04

Jeff Bronks (jeffb-dsl) wrote :

I reinstalled 8.04 and the problem went away. I know this isn't as satisfying as finding and fixing the problem, but it's really nice to have everything working again. My home directory survived the reinstall, so I reloaded various apps including Thunderbird and GnuCash, and they were able to find their files and carry on working as if nothing had happened. Result!

My guess is that my system was damaged when I upgraded it from Gutsy to Hardy. There may be a bug in the upgrade process.

epictetus (scottlsteele) wrote :

Largely same here. Nautilus pops up that error message for Computer and Network, and I can't access my Trash. I've been using Hardy for months. The problem happened concurrently with Appearance Settings no longer being able to find any of the main themes (i.e. human et al) as well as the system losing svg support. I fixed the svg problem (see http://ubuntuforums.org/showthread.php?p=5717668) but am still having the issues with Nautilus and my themes.

All of the three issues occurred while I was installing a number of packages required to install Anjuta 2.4.2. I was having to install so many, that I wasn't paying attention to the names, but looking at /usr/include/, these were some of the folders modified around the time that the error must have occurred. (I don't know if listing them is useful, but they say to give more rather than less information.)
gnome-build-1.0, libxslt, libesxlt, libgdl-1.0, vte, libgnomeui-2.0, libbonoboui-2.0, libgnomecanvas-2.0, libart-2.0, gail-1.0, selinux, libgnome-2.0, gnome-vfs-module-2.0, gnome-vfs-2.0, sepol, lzo, gutls, gconf, libbonobo-2.0, bonobo-activation-2.0, avahi-glib, avahi-common, avahi-client, libxml2, libglade-2.0, gtk-unix-print-2.0, gtk-2.0, orbit-2.0, libIDL-2.0

epictetus (scottlsteele) wrote :

Didn't realize usb thumb drives won't mount until I tried, today. My usb wireless still works.

And yes, is there a way that the importance of this could be higher? I can't use external usb drives or access my trash, which are somewhat crippling issues.

(Hardy 8.04)

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in intrepid?

Ardock (ardock) wrote :

I had the same problem and I think that i know where is the problem.

I installed glib-2.18.1 while I was trying to compile mono 2.0 and the same problem appeared.
I uninstalled it and no more problem (after reboot).
Then i installed glib-2.18.2 and another time without trash and Nautilus cannot handle x locations (after reboot).
I uninstalled it and all ok another time (after reboot).

Another guy solved the same problem uninstalling a list of packets and glib was one of them.
spanish link: http://www.ubuntu-es.org/index.php?q=node/98685

i'm using ubuntu 8.04.1 up to date.

Good luck.

Ardock (ardock) wrote :

Now i think that was not a bug... I see that i already had another version of this paquet installed: libglib2.0-0 (synaptic, v 2.16.6, hardy updates) at the same time.

I also have this bug, but only if I run Nautilus as root. The error occurs too with Places>Trash. It occurs with Hardy and Intrepid (don't remember before).

goto (gotolaunchpad) wrote :

Same problem here. It happened on 2 computers after updating from 7.1 to 8.04.

Any known way to fix thist?

goto (gotolaunchpad) wrote :

Same problem here. It happened on 2 computers after updating from 7.1 to 8.04.

Any known way to fix this?

Ole Hansen (enquiry) wrote :

I'm experiencing the bug in Intrepid. Upgrading to gvfs-0.99.8 fixes the issues described in the first post, however external drives are no longer auto mounted and I believe this problem might be related.

Jason Ribeiro (jrib) wrote :

I just finished helping someone with this issue. It turned out to be caused by an install of glib and gvfs in /usr/local . For everyone having this problem, see if it still happens after 'sudo mv /usr/local /usr/local.old && sudo mkdir /usr/local'.

Ole Hansen (enquiry) wrote :

Thanks Jason, I believe that did the trick! Now my external drives auto mounts again. It also resolved issues I experienced when trying to mount a samba share.

Sebastien Bacher (seb128) wrote :

the issue there was due to local installs and not an ubuntu bug

Changed in nautilus:
status: Incomplete → Invalid
Rodrigo Rodríguez (nomada) wrote :

Well, I had the same problema until a few minutes...

I did everything you all say here. I unistalled libglib2.0-dev. I couldn't unistall libglib2.0 because allmost all packages depends on it. Later I move /usr/local just as Jason sugested, but nothing happened. The only difference is that when I make that process is that I can see my USB, but in Nautilus as a root.

The packages I uninstalled are: libglib2.0-dev, libatk1.0-dev, libgtk2.0-dev, libpango1.0-dev, libqt4-dev y libqt4-opengl-dev, gettext, ardour, debhelper, denemo, intltool-debian, po-debconf y sweep

In some point, this generate some problem with de OpenOffice and I had to install it again. This time is in english (I had it on spanish).

Here is the link to my solution in the maillist of Ubuntu-ni: https://lists.ubuntu.com/archives/ubuntu-ni/2009-May/010528.html and the next message.

Well, I reboot the system in recovery mode, according to the recommendation of Guillermo Belli and I checked the file system (fsck). Then I started in normal mode, and voilá: It works perfectly everything. My USB mounts automaticaly, I can go to /computer and /network and my Trash reappeared.

Here is the other link of the solution proposed by Guillermo Belli at the same list: https://lists.ubuntu.com/archives/ubuntu-ni/2009-May/010480.html

All links are in spanish.

martshal (martshal-yahoo) wrote :

Wooooaaaa there....

"I just finished helping someone with this issue. It turned out to be caused by an install of glib and gvfs in /usr/local . For everyone having this problem, see if it still happens after 'sudo mv /usr/local /usr/local.old && sudo mkdir /usr/local'."--Jason Ribeiro

"the issue there was due to local installs and not an ubuntu bug"--Sebastien Bacher

Maybe I'm misinterpreting these responses, I hope you don't mind me asking questions to clarify. The simplest questions first.
Are you saying this happens because someone manually installed applications to /usr/local?
Are you saying that this happened because someone modified a library in /usr/local?

Sebastien Bacher (seb128) wrote :

Either of those, the local installation takes over the ubuntu version and can bet outdated or not have required change

Joel (grandpajam) wrote :

I am still learning Ubuntu. I installed glib from source to install MPD from source. I'm assuming I did something wrong so the glib I installed conflicted with the glib already installed by Ubuntu. I did the command Jason said to do and after a ctrl+alt+backspace everything seems to work. I'm using Ubuntu 9.10.

I had this problem in Ubuntu 10.10 . The problem seems to arise after you install glib. It's inconvenient, because not only do I not get a nautilus session from Places>Computer, but various drives - especially usb sticks - fail to auto-mount. I don't of course know the real cause, but here's a work-around that gets rid of the problem. The culprits are /usr/local/lib/libgio-2.0.so.0 & libgio-2.0.so.0.2899.0 . The 1st of these is a symbolic link to the 2nd. Create a folder /usr/local/lib/preventNautilusCrash and put these two files there along with a README explaining why. Who knows: maybe they are needed, so don't destroy them. Anyway, this fixed the nautilus problem for me.

"(...) 'sudo mv /usr/local /usr/local.old && sudo mkdir /usr/local'."--Jason Ribeiro

Worked for me. Thanks.

Completely destroy your /usr/local hardly sounds like a solution to me...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments