doesn't display a warning when trying to add a bookmark and there is disk space

Bug #222957 reported by Walter on 2008-04-27
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Critical
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

1)
Description: Ubuntu 8.04
Release: 8.04

2)
nautilus:
  Installed: 1:2.22.2-0ubuntu4
  Candidate: 1:2.22.2-0ubuntu4
  Version table:
 *** 1:2.22.2-0ubuntu4 0
        500 http://nl.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

3)
The bookmark should have been added to the bookmarks list in the sidebar.
"Edit bookmarks" should show the added bookmark.

4)
In nautilus, click "add bookmark" from the menu or press Ctrl-D. The bookmark briefly appears in the bookmark sidebar, but then disappears again.
"Edit bookmarks" shows the dialog but says "No bookmarks defined".

Also, the bookmarks I had prior to upgrading to hardy are gone.

ProblemType: Bug
Architecture: i386
Date: Sun Apr 27 10:52:54 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.22.2-0ubuntu4
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=/home/username/bin:/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=C
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.24.3 i686

Walter (walter74) wrote :
Walter (walter74) wrote :

hmpf, my filesystem is full, nautilus doesn't display an error message about this

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you describe steps to trigger the issue? Do you get the issue after doing some space on your drive?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Walter (walter74) wrote :

Trigger the issue:
Make sure the homefilesystem is full.
In nautilus, click "add bookmark" from the menu or press Ctrl-D. The bookmark briefly appears in the bookmark sidebar, but then disappears again.
"Edit bookmarks" shows the dialog but says "No bookmarks defined".

The issue is gone after freeing up enough space.

Sebastien Bacher (seb128) wrote :

could be considered as a bug, though there is no way to get thing working correctly when there is no disk space, could also be considered as an user error

Changed in nautilus:
status: Incomplete → New

Which is Nautilus's version that you use?

I'm reproducing your bug but I don't have problems.

Thanks...

Sebastien Bacher (seb128) wrote :
Changed in nautilus:
status: New → Triaged
Changed in nautilus:
status: Unknown → New
glass.dimly (jmjohn) wrote :

For a workaround, does anybody know a way to restore deleted bookmarks if you have a backup of your home directory? Where are bookmarks stored on disk?

thanks,
glass.dimly

A. Walton (awalton) wrote :

$HOME/.gtk-bookmarks

The file should consist of URIs separated by single newlines.

sebastian-s (sebastian-s) wrote :

you can check, there might be a .gtk-bookmarks~

I had this issue several times in the past couple of month and it annoys me so!

Changed in nautilus:
status: New → Invalid

Upstream bug has been marked as duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=561309

Changed in nautilus:
status: Invalid → Unknown
Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.