Nautilus not showing the desktop icons & wallpaper on login

Bug #218070 reported by Andrew Mitchell on 2008-04-16
90
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Fedora)
Won't Fix
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

After an upgrade to hardy, nautilus is often not showing the desktop icons & wallpaper, although the process itself is still running. Attaching strace to it shows it continually trying to read from a socket:

restart_syscall(<... resuming interrupted call ...>) = 0
gettimeofday({1208331785, 315126}, NULL) = 0
stat64("/home/ajmitch/.recently-used.xbel", {st_mode=S_IFREG|0644, st_size=118622, ...}) = 0
read(3, 0x819489c, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1208331785, 316371}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=11, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN}, {fd=19, events=POLLIN|POLLPRI}, {fd=18, events=POLLIN|POLLPRI}, {fd=10, events=POLLIN|POLLPRI}, {fd=26, events=POLLIN}, {fd=31, events=POLLIN}, {fd=16, events=POLLIN}, {fd=21, events=POLLIN}, {fd=17, events=POLLIN}, {fd=20, events=POLLIN, revents=POLLIN}], 16, 4997) = 1
read(20, "l\4\1\1\254\0\0\0\202\6\0\0\255\0\0\0\1\1o\0?\0\0\0/or"..., 2048) = 364
read(20, 0xb5b51008, 2048) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0x819489c, 4096) = -1 EAGAIN (Resource temporarily unavailable)

ProblemType: Bug
Architecture: i386
Date: Wed Apr 16 19:38:06 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.22.2-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.24-16-generic i686

Andrew Mitchell (ajmitch) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your report, is this still an issue for you? Can you attach your ~/.xsession-errors? Does the same happens with another new user created on your machine? thanks in advance.

Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in nautilus:
importance: Undecided → Low
status: Incomplete → Invalid

I encounter the same problem.

A new user on my machine is not affected.

The problem with my account just started a few days after the upgrade (I was playing with deskop effects and the proprietray ATI drivers as well with gconf-editor for the panel settings). Before that, it worked fine. I tried deleting my .nautilus, .gconf, .gconfd, .gnome, .gnome2pivate and .gnome. Didn't have any effect.

Find my .xsession-errors attatched. Let me know if yo need further information.

Thank you!

I forgot to mention that my panels show up - only the wallpaper and the desktop icons are invisible. Using gTwealUI-Nautilus can bring my desktop back (through unticking "Use nautilus to draw desktop" and then re-ticking it).

Changed in nautilus:
status: Invalid → Incomplete
Sebastien Bacher (seb128) wrote :

could you try to look what setting is creating the issue?

I would like to, but I don't know where to start. It's not the 3D effects.

What could I examine in greater detail? Any suggestions?

Sebastien Bacher (seb128) wrote :

do you get the issue using an another user on the same configuration?

No, a new user is not affected by the problem.

Another remark: the last updates changed the situation a bit - my wallpaper is now drawn, but I still miss the icons on my desktop. The procedure with gTweakUI brings them still back.

Another issue (maybe related?): Nautilus ignores my delay settings for the auto-hide and auto-unhide times for the panels (edited via the confihuration editor). As I know, Nautilus is in charge of the panels.

If you need more information, let me know!

Thanks!

Sebastien Bacher (seb128) wrote :

nautilus seems to not handle your background, could you attach your .xsession-errors after the login? nautilus doesn't handle the gnome-panel no
otherwise could you try to move .gnome2/session somewhere else and see if that makes a difference?

I don't have a file or directory "session" inside ~/.gnome2.

I attatched my .xsession-errors another time.

Sebastien Bacher (seb128) wrote :

you have some preloader warning, is there something you installed?

Nothing special beside Texmaker 1.7 (newer version than in the repositories) and the proprietary ATI drivers (installed through envy). The rest of my system shoulb be "standard".

What can I try?

miq (miqster) wrote :

I have exactly the same problem since yesterday (16.05.08). My System is pretty standard and I have an Nvidia card, which should rule out the graphics driver entirely. Background is drawn, no icons though....

Installing parts of Ubuntu Studio solved the problem for me.

However, I still consider this as a bug.

Description of problem:

After system logon no file manager is started and desktop does not display any
icons. An attachment shows the bug. This happens not always, but roughly 1/3
times the system starts. Also no greeting sound is played (but the sound system
works OK in other applications), tray applets mixed and loose their usual
positions. Sometimes network connection tooltip appears in the middle of screen,
not in the right lower corner as usual.

Created attachment 306027
Screenshot

Oliver (lobohacks) wrote :

Hi,
I know several people who encounter the same problem (all after dist upgrade) on various hardware.
Randomly the wallpaper is drawn, but no icons ...
"killall nautilus" helps, but this can not be the final solution.
A Fix would be nice since the "several people" are mostly linux beginners who can not handle problems like that by themselves and bug me with this. ;)

regards Oliver

Stephen Kendall (spkendall) wrote :

I am also having the problem after upgrading to Hardy. It doesn't happen every time; it happens about 3 times out of 4.

I've attached my .xsession-errors file. It's from the session I'm currently in, which IS experiencing the problem (no icons, but after I pkill nautilus I will have all my icons, windows open in previous session, etc.)

kulturschock2000 (dschoenen) wrote :

Absolutly the same problem since 11th of june. I have no updated ubuntu, but a fresh one. When compiz is disabled, the problem doesn't appear. I added a script to my autostart, which starts nautilus, so that the desktop, the icons and the right-click-menu appears. (Has already been mentioned, that the right-click-menu of the desktop does not function anymore?)

kulturschock2000 (dschoenen) wrote :

I have renamed the directory ~/.metacity and it seems, that the problem does not occur anymore. I have restarted the computer 5 times since renaming.

Ansus (neptunia) wrote :

Confirming. Also saw this bug under Fedora 9.

Changed in nautilus:
status: Incomplete → Confirmed
Ansus (neptunia) wrote :

Can anybody say if this bug still observed if to disable autologin and entering the password with a pause of 10-15 seconds?

kulturschock2000 (dschoenen) wrote :

Oh, I have said, that I have a no upgraded ubuntu. That's right, but I have a seperate home-partition. Maybe a problem between old configuration files an new version (of gnome)? As I said in my last posting: deleting .metacity still solved the problem.

Ansus (neptunia) wrote :

I think this is because timings during startup: not all gconf setting have enough time to load properly. This is also related to the known keyboard layout settings and some others.

pcm (pmunk-deactivatedaccount) wrote :

I had the same problem also after an upgrade to hardy.
I think I fixed it, I've done 2 thinks and I don't know which one made if finally...

1. ~/.metacity/sessions created a file named default0.ms containing following lines:

<metacity_session id="default">
</metacity_session>

I've done this because of following line in the .xsession-errors:
Fenstermanager-Warnung:Gespeicherte Sitzungsdatei ~/.metacity/sessions/default0.ms konnte nicht gelesen werden: Failed to open file '~/.metacity/sessions/default0.ms': Datei oder Verzeichnis nicht gefunden

2. renamed the ~/.nautilus/metafiles/x-nautilus-desktop:%2F%2F%2F.xml so nautilus had to create a new one...
I had to rearrange some icons, but this doesn't care I guess :)

I haven't had the problem since 2 log-offs and 2 full reboots. Hope it works in future.

Michael R. Head (burner) wrote :

doing rm -rf .gconf/apps/nautilus removes this problem for me, but when I go into the nautilus preferences and change the default icon size from 100% to 150%, the problem comes back (nautilus insatiably chews up CPU and memory). If I try switching the default icon size back, nautilus remains in the bad state. Attaching strace to nautilus shows that it's spinning with poll on an EAGAIN (as shown in the original report). After logging out and logging back in with default icon size set to 100%, everything is OK again.

I'm seeing this on PPC-based mac hardware.

Sebastien Bacher (seb128) wrote :

The bug has been sent upstream on http://bugzilla.gnome.org/show_bug.cgi?id=545481

Changed in nautilus:
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
status: Unknown → Confirmed

Probably an upstream bug:

http://bugzilla.gnome.org/show_bug.cgi?id=545481
https://bugs.launchpad.net/fedora/+source/nautilus/+bug/218070

I see this issue on my dual-core2 Fedora 9 desktop from time to time. Running "killall nautilus" forces Nautilus to restart, which always fixes it.

same on my system, dell optiplex gx280. i corroborate prior poster, "killall nautilus" fixes it every time.

BlackSir (blacksir) wrote :

This bug never affected me on Hardy, but now on Intrepid I can't see my desktop icons after boot most of the time. 'killall nautilus' helps, but that's ugly. Is there any other workarounds?

TonyGould (tony-gould) wrote :

on hardy I added the following to /etc/rc.local, which did the trick. Replace <USERNAME> with your user name. Be warned it's possible it might delete some settings that you like so take a copy of .nautilus first!

find ~<USERNAME>/.nautilus -type f ! -name 'file:%2F%2F%2Fhome%2F<USERNAME>%2FDesktop.xml' | xargs rm

BlackSir (blacksir) wrote :

2TonyGould:
Works for me too. Thanks!

Manni (ubuntu-lxxi) wrote :

Cleaning the ~/.nautilus directory doesn't work for me. However, I always get to see desktop icons again when I start nautilus which doesn't seem to be running after I log in.

doc_471 (the-analist-3d) wrote :

I can confirm this bug, but in a different situation:
Running the Jaunty CD Live Session environment

I tracked some info from Syslog, kern.log and Messages, including other logs. They have this line (regardless of some changes between logs) while trying to open a folder:

May 12 14:02:24 ubuntu kernel: [ 2156.203902] nautilus[6622]: segfault at 87bf008 ip b62487dd sp b6236fc0 error 4 in libbrasero-media.so.0.1.1[b6238000+1e000] ___ This is from "Messages"

May 12 14:03:55 ubuntu kernel: [ 2247.933433] nautilus[6642]: segfault at 9958000 ip b61f37dd sp b61e1fc0 error 4 in libbrasero-media.so.0.1.1[b61e3000+1e000] ___ This is from "kern.log"

May 12 14:04:20 ubuntu kernel: [ 2272.297441] nautilus[6648]: segfault at 8349000 ip b634f7dd sp b6168fc0 error 4 in libbrasero-media.so.0.1.1[b633f000+1e000] ___ This is from Syslog

And yes, I can't view the wallpaper or the icons. Even open a folder is marked with the errors listed before.
The apport.log shows something like this:

apport (pid 6968) Tue May 12 14:14:27 2009: called for pid 6965, signal 11
apport (pid 6968) Tue May 12 14:14:27 2009: executable: /usr/bin/nautilus (command line "nautilus --no-desktop computer:")
apport (pid 6968) Tue May 12 14:14:27 2009: this executable already crashed 2 times, ignoring

I'm going to attach the logs. Just give me 3 minutes...

doc_471 (the-analist-3d) wrote :

The attachments:

doc_471 (the-analist-3d) wrote :

The attachments: Messages

doc_471 (the-analist-3d) wrote :

The attachments: Syslog

doc_471 (the-analist-3d) wrote :

The attachments: Apport log

Obtained while running Jaunty 9.04 stable release. Live Session environment (NOT installed something yet). HP Compaq desktop dc7100 SFF, 1.5 GiB RAM, 80 GiB HD, Pentium 4 HT 3 GHz. and all stuff. Nothing has touched or installed.

doc_471 (the-analist-3d) wrote :

And this file shows more info:

xsession-errors

Spyros S. (spystath) wrote :

I have the same problem too. Background draws normally but right-click does not show up the menu and icons disappeared. Starting nautilus manually seems to work but it's obviously not the right way. Is there at least a way to start nautilus without a window?

BlackSir (blacksir) wrote :

In Hardy I used to use TonyGould's workaround to make Nautilus work after boot, but in Jaunty I've removed workaround and everything works well.

This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 9 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora please change the 'version' of this
bug to the applicable version. If you are unable to change the version,
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Changed in nautilus (Fedora):
status: Confirmed → Won't Fix
jdackle (jdalinux) wrote :

I have had this issue in Jaunty:
Desktop background OK.
Showing icons and right-click on desktop menu FAILED.

Duplication:

I'm not sure how this happened - I installed quite a few things (in a hurry) and only later did I notice I had no desktop right-click menu nor icons.
However, I would find it more likely that using desktop-switcher was what caused this as it also completely messed the content of my panels (as well as *permanently* removing the bottom panel).

Workarounds:

Using tweakui as mentioned in #5 on 2008-05-12 by AlexE worked. But after session restart, the problem came back.
Deleting the ~/.compiz and ~/.gconf/compiz directories (instead of the, in my system, non-existing ~/.metacity) as mentioned in #19 on 2008-06-22 by kulturschock2000, and *then* using AlexE's trick seems to have solved the problem definitely.

hanspr (hanspr) wrote :

Had same problem, no right click on desktop, no icons showing.
Ubuntu 9.10 Karmic
I erased ~/.compiz and ~/.gconf/app/compiz
Did not fixed.
I'm not sure if deleting those directories helped fix the problem.
But procedure after doing that, did.

gtweakui Nautilus: Deactivate an activate "Use nautilus to draw desktop"

Open Gnome Config Editor (gconf-editor)
app/gnome-session/options
Set : auto_save_session

Closed session, log in again and now desktop shows correctly, I deactivated the auto_save_session after
and still works, so I guess it can be set all the time or not after the session has been saved with the correct values.

tags: added: nautilus-desktop-icons
Changed in nautilus:
importance: Unknown → Medium

May be the solution is here

http://<email address hidden>/msg375353.html

if /home partition is full gnome cannot write to /~/.local/share/gvfs-metadata/home

this file will be 0 bytes in problem systems.

remove
/~/.local/share/gvfs-metadata/home

and reboot
this should recreate a proper /~/.local/share/gvfs-metadata/home file and all icaons will be shown up to desktop.

Changed in nautilus:
status: New → Expired
Changed in nautilus (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.