Ubuntu

No icon displayed in the right click mouse button

Reported by COLIN Stéphane on 2008-04-02
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

No icon displayed for actions defined in nautilus actions manager when I right click on objects selection under hardy.

Icons are properly defined and displayed in the nautilus actions manager in gutsy and hardy.

More than many words, i add some pictures of comparison between actual gutsy behavior and actual hardy behavior.

nautilus actions manager - gutsy (OK) :

http://bigbob.chez-alice.fr/nautilus-actions-manager-gutsy.png

nautilus actions manager - hardy (OK) :

http://bigbob.chez-alice.fr/nautilus-actions-manager-hardy.png

nautilus actions right mouse button menu - gutsy (OK) :

http://bigbob.chez-alice.fr/nautilus-actions-right-mouse-button-menu-gutsy.png

nautilus actions right mouse button menu - hardy no icon (BAD) :

http://bigbob.chez-alice.fr/nautilus-actions-right-mouse-button-menu-hardy.png

Hope it help ...

A++

Robert Mens (robert-0xdeadbeef) wrote :

I'd like to confirm this bug.

I can't get an icon to show in Ubuntu 8.04 while I had one in Ubuntu 7.10

COLIN Stéphane (bigbob-fun) wrote :

Someone interrested to work on this bug ?

A++

Isak Frants (isakfrants) wrote :

Yep confirming on Hardy clean install i386.
But the icons you can select from the dropdown menu work as they should! It's only icons which are manually pointed out that don't behave as they are supposed to.

Changed in nautilus-actions:
status: New → Confirmed
freddy3980 (freddy3980) wrote :

i can confirm this as well, using Hardy i386. I tried adding a *.png or *.xpm icon of Audacious and no luck showing on the right click menu...

schlehmil (mail-schlehmil) wrote :

This bug affects Intrepid Ibex i386 too.

COLIN Stéphane (bigbob-fun) wrote :

Then so ... ???

Any developer interested to fix this or does bug reporting is here just to masturbate ???

A++

Same issue for me. Using Intrepid Ibex i386, icons from drop-down menu work, but custom icons do not.

This claims it has a workaround, but it doesn't work for me: http://ubuntuforums.org/showpost.php?p=6192873&postcount=3

Does this work for anyone?

Johannes (kakemphaton) wrote :

Also affects Intrepid Ibex 64 bits.

@Jackson Williams: Workaround doesn't work for me neither.

John Doe (webmastir) wrote :

Same here. Can't add custom icons no matter what size 16x16 (*.ico or *.png) .. that "possible workaround" didn't help either
Ubuntu Hardy 32bit (2.6.24-24)

freddy3980 (freddy3980) wrote :

Nautilus-actions v 1.10.1 is out, changelog: http://www.nautilus-actions.org/?q=node/363

Isak Frants (isakfrants) wrote :

Fixed upstream as of 2009-11-25! Patch is in SVN and available also here: http://bugzilla.gnome.org/show_bug.cgi?id=525845

Isak Frants (isakfrants) wrote :

Hm. I was wrong. The bug is in Nautilus and fixed in both master and 2.28 branch. Patch is confirmed to work on both.

affects: nautilus-actions (Ubuntu) → nautilus (Ubuntu)

Linking the upstream bug here. This should be fixed in Ubuntu 10.04. Thanks for reporting.

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
Isak Frants (isakfrants) wrote :

Thanks for commenting. But why mark Nautilus (Ubuntu) as Fixed Released? Shouldn't Nautilus (Ubuntu) be Confirmed and upstream Nautilus Fixed Released? The bug watch is btw a bit sad and claims Gnome bug 525845 doesn't exist..

There are currently some problems keeping the bugwatches in sync with large bugtracker like GNOME or Debian. This should get better in the future. "Fix Released" for nautilus in Ubuntu is correct, since nautilus in Ubuntu 10.04 has the version 2.28.4, in which the bug is fixed.

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.