Skipping previous view doesn't let performance degrade

Bug #1839610 reported by klfyt on 2019-08-09
48
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
X.Org X server
New
Undecided
Unassigned
Xfwm4
New
Undecided
Unassigned
nautilus (Fedora)
Confirmed
Undecided
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Something is wrong with previous view
killing performance and responsiveness, etc.
The only obvious fix seems to be to skip it.

:))

# for example if you skip to previous
# a > b (previous) fix it with
# b > c > b

Edit:
if you skip to previous view with Shift key performance
doesn't degrade
https://bugs.launchpad.net/xfwm4/+bug/1837783

It's ignored at the moment, however it looks to be
significant performance, at least in terms
of idle power.

klfyt (klfyt) on 2019-08-09
summary: - You can improve performance if each you revisit history (recent files)
+ You can improve performance if you revisit history (recent files)

Thank you for your bug report, could you provide some details?

- what Ubuntu/nautilus version are you using?
- what sort of performance improvement are you speaking about (and how slow is it by default for you/with what content)
- could you maybe also report it upstream on network-manager:upstream

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
klfyt (klfyt) wrote :

> what sort of performance improvement are you speaking about

Like you started on a 1st page.
I believe window history is broken, I don't know how.

Just revisit history. :))

klfyt (klfyt) on 2019-08-10
Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
klfyt (klfyt) on 2019-08-11
summary: - You can improve performance if you revisit history (recent files)
+ If you travel BACK directly it kills visible scrolling performance
klfyt (klfyt) on 2019-08-11
description: updated
Changed in nautilus (Ubuntu):
status: Invalid → New

Description of problem:
Anywhere where you need to travel to previous view
performance drops visibly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. go to previous view
2.
3.

Actual results:
Performance starts to degrade.

Expected results:
Performance is like before. :))

Additional info:
Documents
Documents/a
Documents < performance degrades (workaround go anywhere else besides
                                       Documents or Documents/.. and only
                                       then go to Documents)

*** Bug 1729681 has been marked as a duplicate of this bug. ***

Just skip previous directly seems the rule, dunno what it is. :))

Think the only obvious so-called workaround is avoiding
getting into previous through whatever means possible.

This way you can keep it on the level. :-)

Simple rule is:
previous view ? skip to something else :))

>:]

klfyt (klfyt) on 2019-08-14
summary: - If you travel BACK directly it kills visible scrolling performance
+ Skipping previous view doesn't let performance degrade
description: updated
klfyt (klfyt) on 2019-08-14
no longer affects: nautilus
affects: xfwm4 → ubuntu

*** Bug 1670504 has been marked as a duplicate of this bug. ***

klfyt (klfyt) on 2019-08-15
no longer affects: ubuntu
klfyt (klfyt) wrote :

Maybe previous view contains recursive function that keeps fighting for resources?

:))

klfyt (klfyt) on 2019-08-16
description: updated

(In reply to klfyt from comment #2)
> Think the only obvious so-called workaround is avoiding
> getting into previous through whatever means possible.
>
> This way you can keep it on the level. :-)
>
> Simple rule is:
> previous view ? skip to something else :))
>
> >:]

a > b

b == previous?

b > c > b

klfyt (klfyt) on 2019-08-20
description: updated
Chris Guiver (guiverc) wrote :

No answer yet to seb128's prior question.

Changed in nautilus (Ubuntu):
status: New → Incomplete

Fastest xfmw

alt tab > shift alt tab > alt tab

Fastest browser (Firefox, Chromium)

shift ctrl tab > ctrl tab

Fastest text :-)

navigate left -1 letter keep typing.

For example:

Good m|f
Good morning|f

Good morning.

*** Bug 1744930 has been marked as a duplicate of this bug. ***

*** Bug 1724029 has been marked as a duplicate of this bug. ***

*** Bug 1677161 has been marked as a duplicate of this bug. ***

*** Bug 1674486 has been marked as a duplicate of this bug. ***

*** Bug 1733819 has been marked as a duplicate of this bug. ***

*** Bug 1729666 has been marked as a duplicate of this bug. ***

*** Bug 1727998 has been marked as a duplicate of this bug. ***

*** Bug 1740646 has been marked as a duplicate of this bug. ***

*** Bug 1731759 has been marked as a duplicate of this bug. ***

*** Bug 1730272 has been marked as a duplicate of this bug. ***

*** Bug 1726250 has been marked as a duplicate of this bug. ***

*** Bug 1725831 has been marked as a duplicate of this bug. ***

*** Bug 1697062 has been marked as a duplicate of this bug. ***

*** Bug 1738604 has been marked as a duplicate of this bug. ***

*** Bug 1670504 has been marked as a duplicate of this bug. ***

*** Bug 1677547 has been marked as a duplicate of this bug. ***

*** Bug 1683074 has been marked as a duplicate of this bug. ***

*** Bug 1684757 has been marked as a duplicate of this bug. ***

*** Bug 1725310 has been marked as a duplicate of this bug. ***

*** Bug 1693960 has been marked as a duplicate of this bug. ***

*** Bug 1726553 has been marked as a duplicate of this bug. ***

Magic combo is previous + next for a view. Affected: Firefox, Chromium, Thunar >:].

  :))

Changed in nautilus (Fedora):
importance: Unknown → Undecided
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.