nautilus crashed with SIGSEGV in NAUTILUS_VIEW_GET_IFACE()

Bug #1819757 reported by Alan on 2019-03-12
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Unknown
nautilus (Ubuntu)
High
Andrea Azzarone

Bug Description

Crash while display content trash

ProblemType: Crash
DistroRelease: Ubuntu 19.04
Package: nautilus 1:3.31.90-1ubuntu2
ProcVersionSignature: Ubuntu 5.0.0-7.8-generic 5.0.0
Uname: Linux 5.0.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Tue Mar 12 15:55:24 2019
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'sidebar-width' b'208'
 b'org.gnome.nautilus.window-state' b'maximized' b'true'
InstallationDate: Installed on 2019-02-10 (30 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
ProcCmdline: /usr/bin/nautilus --gapplication-service
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANGUAGE=es_UY:es
 LANG=es_UY.UTF-8
SegvAnalysis:
 Segfault happened at: 0x56397cd040d9 <nautilus_view_get_selection+9>: mov (%rbx),%rdi
 PC (0x56397cd040d9) ok
 source "(%rbx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 nautilus_view_get_selection ()
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in nautilus_view_get_selection()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
separator:

usr_lib_nautilus:

Alan (alanjas) wrote :

StacktraceTop:
 NAUTILUS_VIEW_GET_IFACE (ptr=0x0) at ../src/nautilus-view.h:40
 nautilus_view_get_selection (view=0x0) at ../src/nautilus-view.c:256
 selection_changed_cb (view=0x0, bar=0x56397ecf4f20) at ../src/nautilus-view.h:40
 object_set_property (nqueue=0x56397eb6fa50, value=<optimized out>, pspec=0x7fec5c008e20, object=0x56397ecf4f20) at ../../../gobject/gobject.c:1447
 g_object_new_internal (class=class@entry=0x56397ef919b0, params=params@entry=0x7ffeea534d50, n_params=n_params@entry=2) at ../../../gobject/gobject.c:1839

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in nautilus_view_get_selection()
+ nautilus crashed with SIGSEGV in NAUTILUS_VIEW_GET_IFACE()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Medium → High
information type: Private → Public
Changed in nautilus:
status: Unknown → New
Andrea Azzarone (azzar1) on 2019-03-14
Changed in nautilus (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: Confirmed → In Progress
Changed in nautilus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.32.0-0ubuntu1

---------------
nautilus (1:3.32.0-0ubuntu1) disco; urgency=medium

  * New upstream version (lp: #1820683)
  * debian/control.in:
    - build-depends on libgstreamer-plugins-base1.0-dev, the audio/video
      properties code has been moved from totem to nautilu
    - updated the glib requirement
  * debian/patches/git_init_segfault.patch:
    - include a patch from Andrea to fix a segfault (lp: #1819757)

 -- Sebastien Bacher <email address hidden> Tue, 19 Mar 2019 17:11:27 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in nautilus:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.