[18.04] [3.26.3-0ubuntu4] .desktop extension is duplicated when renaming a .desktop file

Bug #1774094 reported by Michael Aaron Murphy on 2018-05-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

When attempting to rename a .desktop file in Ubuntu 18.04, .desktop is automatically appended. This causes the .desktop extension to get duplicated, where renaming `app.desktop` to `app2.desktop` will actually rename it to `app2.desktop.desktop`.

The included patch will check if the new name already has the `.desktop` suffix, and appends the extension only if it is missing.

The attachment ".desktop rename patch for Nautilus" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
description: updated
description: updated
summary: - [Patch Included] 3.26.3-0ubuntu4 .desktop extension is duplicated when
- renaming a .desktop file
+ [18.04] [3.26.3-0ubuntu4] .desktop extension is duplicated when renaming
+ a .desktop file

Submitted PR upstream to Nautilus' 3.26 branch: https://gitlab.gnome.org/GNOME/nautilus/merge_requests/241/diffs

GNOME merged the changes for their 3.26 branch, so it's now up to Ubuntu to make their move for 18.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The issue should be fixed with 3.30 in disco, so closing the bug. It doesn't seem to have got much user reporting so far so is probably not worth SRUing to the LTS at this point. Thanks for the report and patch though!

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released

@seb128 I guess that means we'll have to keep carrying the patch ourselves for bionic in our repos.

Personally, I think you should reconsider it if the desktop is part of your "Long Term Support".

Sebastien Bacher (seb128) wrote :

@Michael, who is 'we'? Also how common is it that users rename a .desktop, that's the only report we got about that problem on launchpad and there is no activity on it outside of the submitter. It's fine to include it in the next SRU but it doesn't seem like an important or frequent issue

Sebastien Bacher (seb128) wrote :

Well, it looks like the fix is also in 3.26.4 which has been SRU to bionic, did that try that version?
https://launchpad.net/ubuntu/+source/nautilus/1:3.26.4-0~ubuntu18.04.3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers