[needs-packaging] package filemanager-actions missing

Bug #1768597 reported by grn on 2018-05-02
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
filemanager-actions (Debian)
Fix Released
Unknown
filemanager-actions (Ubuntu)
Wishlist
Unassigned
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

nautilus-actions was deprecated in favour of filemanager-actions (see https://github.com/GNOME/nautilus-actions ).

But 18.04 repositories do not have either of the packages.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1768597/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → nautilus (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2018-05-03
tags: added: artful bionic
removed: bot-comment
description: updated
Daniel (daniel-marynicz) wrote :

You can use this as base package https://github.com/Daniel-Marynicz/filemanager-actions-debian-packging

For debian/ubuntu packing.

Changed in nautilus-actions (Ubuntu):
status: New → Confirmed
tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - package filemanager-actions missing
+ [needs-packaging] package filemanager-actions missing
Changed in nautilus-actions (Ubuntu):
importance: Undecided → Wishlist
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist

Come on Guys, its 5 months since deprecation note on https://github.com/GNOME/nautilus-actions
Cant you take a favour of @daniel-marynicz hard work and take his package and use it in proposed updates as a starter ?

Tom (tom-lorinthe) wrote :

I have a whole list of actions and cant use it anymore. Filemanger Actions stopped working for some reason...

flo schneider (0penartist) wrote :

You can use this ppa meanwhile

ppa:tomtomtom/filemanager-actions

https://launchpad.net/~tomtomtom/+archive/ubuntu/filemanager-actions

thus, proper debian source packaging already exists, so putting into repository should be rather easy ;-)

but as debian upstream also does not have the package, and ubuntu is largely dependend on this, I would file a bug at debian to include fma, as it then gets into ubuntu repos anyways.

Lenin (gagarin) wrote :

@Tom (#7), are your actions online somewhere to view?

abssorb (abssorb) wrote :

Any update?

I'd rather not fill our systems with random 3rd party repos.

Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

The package is waiting sponsoring in Debian, https://mentors.debian.net/package/filemanager-actions

Sebastien Bacher (seb128) wrote :

(Jeremy B. said he would have a look to review/sponsor)

Changed in nautilus (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) wrote :

filemanager-actions will be available in Ubuntu 19.04 which will be released in April.

affects: nautilus (Debian) → filemanager-actions (Debian)
affects: nautilus-actions (Ubuntu) → filemanager-actions (Ubuntu)
Changed in filemanager-actions (Ubuntu):
status: Confirmed → Fix Released
Changed in filemanager-actions (Debian):
status: New → Fix Released
abssorb (abssorb) wrote :

Great that it's in 19.04. Would be good to have available in current LTS release: 18.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.