restore type-ahead find, again

Bug #1767431 reported by Kaijia Feng on 2018-04-27
258
This bug affects 57 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

The dropping of the type-ahead find patch in 17.10 might deeply affect non-technical users, as pointed out, this is possibly a bad HCI design. As there is a patch exists from the Arch community[1], and the at least some people managed to patch it in 17.10[2], might it be possible to add such patch back before 18.04.1 so that it won't affect people upgraded from 16.04?

[1]: https://aur.archlinux.org/nautilus-typeahead.git
[2]: https://askubuntu.com/a/1002521

Sebastien Bacher (seb128) wrote :

Thank you fo your bug report, the patch url you gave doesn't seem valid though?

Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Kaijia Feng (fengkaijia) wrote :

@seb128, that URL is for git clone, the HTML page for the repo is at [1]. Also, to compile nautilus with the patch, there needs another small patch after applying the Arch patch, to remove a naming conflict introduced in an Ubuntu patch in 18.04. I attached my patch.

I have been using the patched nautilus for two days without any problem. The HCI experience after the patch aligns experience in 16.04 and earlier, i.e., type to jump to the location of the first file and press Ctrl+F to search.

[1]: https://aur.archlinux.org/packages/nautilus-typeahead/

Kaijia Feng (fengkaijia) on 2018-05-01
information type: Public → Public Security
information type: Public Security → Public
tags: added: patch

The attachment "The second patch for 18.04 after applying the Arch patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Norbert (nrbrtx) on 2018-08-13
tags: added: bionic cosmic
Bart (misterbart) wrote :

This issue is much broader and was already earlier mentioned than the first provided link to askubuntu, see https://askubuntu.com/q/275883/854911 And given the amount of upvotes for that question and for the answers I think it is fair to reconsider this 'feature'.

voidstarstar (voidstarstar) wrote :

I don't think this should be marked as a duplicate of bug #1164016. That bug was successfully fixed, but this one is a new regression that requires a different patch. Since #1164016 is marked as Fix Released, a new bug should be opened for this new regression.

Are any Ubuntu devs looking into this? A working and maintained patch has been out for a year, but it has not yet been merged yet. What needs to be done to get this merged?

Jay Tuckey (jay-tuckey) wrote :

This is super annoying, and very unexpected behaviour change particularly for users coming from Windows. There is a patch to change the behaviour back here: https://launchpad.net/~lubomir-brindza/+archive/ubuntu/nautilus-typeahead

At the very least this should be a setting in nautilus, if it isn't made the default behaviour.

Ondrej Pokorny (ondrejpokorny) wrote :

It just doesn't make sense to have a search as soon as you start typing, that's what the search button and Ctrl+F are for. It hinders workflow when wanting to get to files/folders quickly by typing initial letters of it.

Benjamin Bach (benjaoming) wrote :

Issue has a patch, so wondering: What are the decision criteria for bringing the patch into 18.04, perhaps backports? Does it have to happen upstream (through persuasion of Gnome devs)?

OzzyFrank (ubuntu-ozzyfrank) wrote :

Hi. I finally upgraded to 18.04 and Nautilus without type-ahead find is extremely limiting when it comes to file/folder navigation. I can't even fathom why it would be dropped. But if search is now the default action for when one starts typing, there should be a way to disable that, or enable type-ahead find, if not in an easily-found, user-friendly way, then at least as an option in Preferences. I know there is a patched version available, but I'd rather not have upgrade headaches which can arise from having patched versions of major system apps, so am just adding my voice to the countless others on the web begging for action on this.

Rich Smith (rls-h) wrote :

This is really annoying, counter-intuitive behaviour. At the very least the old behaviour should be restorable by a setting.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers