Search current folder only in nautilus doesn't work (Ubuntu 18.04)

Bug #1767027 reported by Chris Billington on 2018-04-26
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Marco Trevisan (Treviño)
Bionic
High
Marco Trevisan (Treviño)

Bug Description

[ Description ]

I upgraded to Ubuntu 18.04 prerelease from Ubuntu 17.10 and am finding that Nautilus searches all subfolders when I start typing, not just the present folder, even though I have the "search only current folder" option selected in its preferences, and "Only searching the current folder" does appear in the GUI as I am searching. Nonetheless results appear from subfolders (which I wouldn't mind, but which I turn off due to its poor performance compared to current-folder-only).

[ Test case ]

1. Start nautilus, form app settings force nautilus to search only in current folder
2. Search for any content you know is available in a subfolder of the current one
3. No results should be shown for any of the subfolders

And also:

1. Open gnome-shell activities (hit super)
2. Search for a file you have in a subfolder of your home (not hidden, backup or anything)
3. The files should be shown on the overview.
4. Hitting nautilus icon in overview, results from any subfolder of your $HOME should be
   presented.

[ Regression potential ]

Searches from gnome-shell activities does not contain all the results. Or normal searches from nautilus might not list results from subfolders.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Marco could you have a look to that?

Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed

What version of nautilus are you using?

That was a bug before 1:3.26.3-0ubuntu2, but it was fixed in that revision

Changed in nautilus (Ubuntu):
status: Confirmed → Incomplete
Chris Billington (cjbil1) wrote :

I'm using 1:3.26.3-0ubuntu4

Attached is a screenshot demonstrating the problem

In what directory are you searching?

And what's the path of the files that should not be there?
Could you post an anonymized list of them (using find results in case)?

Chris Billington (cjbil1) wrote :

That example was my home directory, and all the files were either in my home directory or a subfolder.

Attached is another example from within the root directory a python project 'zprocess', searching for 'py'.

Here is the result of the find command (excluding hidden files and folders):

zprocess $ find . -not -path '*/\.*' -name '*py*' | sort
./doc/conf.py
./run_tests.py
./setup.py
./tests/output_redirection.py
./tests/tests.py
./zprocess/clientserver.py
./zprocess/examples/example_client.py
./zprocess/examples/example_server.py
./zprocess/examples/processclass_example.py
./zprocess/__init__.py
./zprocess/locking/__init__.py
./zprocess/locking/__main__.py
./zprocess/process_class_wrapper.py
./zprocess/process_tree.py
./zprocess/remote/__main__.py
./zprocess/security.py
./zprocess/utils.py
./zprocess/zlog/__init__.py
./zprocess/zlog/__main__.py

As far as I can tell, it is performing search as if 'search in subfolders' option was set to 'On this computer only', even though the preferences interface shows it set to 'never'.

If I search a remote location it appears to correctly limit search to the current directory.

Chris Billington (cjbil1) wrote :

Attached is a screenshot of the preferences dialog with my current settings.

Changed in nautilus (Ubuntu):
status: Incomplete → New
Changed in nautilus (Ubuntu):
importance: Low → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → In Progress
summary: - Search current folder only in nautilus 3.26.3 doesn't work (Ubuntu
- 18.04)
+ Search current folder only in nautilus doesn't work (Ubuntu 18.04)
Changed in nautilus (Ubuntu Bionic):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nautilus (Ubuntu):
milestone: none → ubuntu-18.04.1
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.26.4-0ubuntu1

---------------
nautilus (1:3.26.4-0ubuntu1) cosmic; urgency=medium

  * New upstream release: 3.26.4 (LP: #1782681, LP: #1765776)
  * debian/patches/query-add-recursive-flags-and-use-it-in-search-engines.patch,
    debian/patches/0016-search-engine-add-a-recent-search-engine-listing-Gtk.patch,
    debian/patches/0018-search-engine-add-locate-based-search-engine.patch:
    - Follow nautilus settings to search only in current folder (LP: #1767027).
      This doesn't apply to gnome-shell search provider for indexed searches.
  * debian/patches/0017-recent-add-function-to-update-manager-on-file-rename.patch:
    - Updated to respect upstream requested changes
  * debian/patches/nautilusgtkplacesview-show-error-if-volume-is-not-mounted.patch:
    - don't crash if selecting a volume that is not mounted (LP: #1764779)
  * debian/patches/Revert-Revert-files-view-Remove-new-empty-folder-name-sug.patch,
    debian/patches/Revert-Revert-nautilus-file-Don-t-show-thumbnails-for-the.patch:
    - Reverts the reverts introduced in 2.26.3.1 as they are in ubuntu already
  * debian/patches/clear_pending_selection.patch,
    debian/patches/git_middle_tab.patch,
    debian/patches/server_list_segfault.patch,
    debian/patches/nautilusgtkplacesview-show-error-if-volume-is-not-mounted.patch:
    - Patches removed as they are already applied upstream

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 20 Jul 2018 04:52:45 +0200

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu Bionic):
status: New → Confirmed

Hello Chris, or anyone else affected,

Accepted nautilus into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.26.4-0~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
Chris Billington (cjbil1) wrote :

I tested with nautilus 1:3.26.4-0~ubuntu18.04.1 and the issue is fixed for me.

Thank you! :)

tags: added: verification-done-bionic
removed: verification-needed-bionic
Marc Peña (pachulo) wrote :

Installed the package and now the option to "search only current folder" is honoured.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers