Nautilus crashed open Windows-partition [assertion failed: (location != NULL)]

Bug #1764779 reported by Lukas knäble on 2018-04-17
70
This bug affects 5 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
nautilus (Ubuntu)
High
Marco Trevisan (Treviño)
Bionic
Undecided
Unassigned

Bug Description

[ Description ]

if I open a new partition from the Hard-drive (Windows in this case)
Nautilus crash, report him self and after reopen it, the partition is
normal available as nothing would be

https://errors.ubuntu.com/problem/f49deb51a98d691e3e040d7f7334ad08d1e0e54c
https://errors.ubuntu.com/problem/868bb572668dceedfb0e3acd9b17197ca0208938
https://errors.ubuntu.com/problem/00db9958203affb0a98a2842bb2bd91547e6bd5a
https://errors.ubuntu.com/problem/818d3ad2d9fe9f9f64f32fcb5f10da4126d3827d

[ Test case ]

* Open nautilus and select an external hd that is not mounted from the sidebar
* Nautilus sould not crash (in case showing an error message)

[ Regression potential ]

Partitions that have been actually mounted, are not shown or an error is prompted.

-------------

Issue from the log:

Apr 17 16:45:29 hostname udisksd[1014]: Failed to setup systemd-based mount point cleanup: Process reported exit code 5: Failed to start <email address hidden>: Unit media-username-12F6CC77F6CC5D1B.mount not found.
Apr 17 16:45:29 hostname nautilus[11486]: g_mount_get_default_location: assertion 'G_IS_MOUNT (mount)' failed
Apr 17 16:45:29 hostname org.gnome.Nautilus[2775]: **
Apr 17 16:45:29 hostname org.gnome.Nautilus[2775]: ERROR:../src/nautilus-file.c:721:nautilus_file_get_internal: assertion failed: (location != NULL)

-------------

ProblemType: CrashDistroRelease: Ubuntu 18.04
Package: nautilus 1:3.26.3-0ubuntu3
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu5
Architecture: amd64
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Tue Apr 17 16:45:30 2018
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 b'org.gnome.nautilus.preferences' b'show-move-to-trash-shortcut-changed-dialog' b'false'
 b'org.gnome.nautilus.window-state' b'sidebar-width' b'223'
 b'org.gnome.nautilus.window-state' b'geometry' b"'927x1011+926+27'"
InstallationDate: Installed on 2018-03-16 (32 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180315)
ProcCmdline: /usr/bin/nautilus --gapplication-service
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=de_DE.UTF-8Signal: 6SourcePackage: nautilus
StacktraceTop:
 g_assertion_message () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
Title: nautilus crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_nautilus:

Related branches

Lukas knäble (dark-lights) wrote :

StacktraceTop:
 g_assertion_message (domain=domain@entry=0x0, file=file@entry=0x56249a5de143 "../src/nautilus-file.c", line=line@entry=721, func=func@entry=0x56249a5e09e0 <__func__.68725> "nautilus_file_get_internal", message=message@entry=0x56249aebe230 "assertion failed: (location != NULL)") at ../../../../glib/gtestutils.c:2532
 g_assertion_message_expr (domain=domain@entry=0x0, file=file@entry=0x56249a5de143 "../src/nautilus-file.c", line=line@entry=721, func=func@entry=0x56249a5e09e0 <__func__.68725> "nautilus_file_get_internal", expr=expr@entry=0x56249a5f4633 "location != NULL") at ../../../../glib/gtestutils.c:2555
 nautilus_file_get_internal (location=location@entry=0x0, create=create@entry=1) at ../src/nautilus-file.c:721
 nautilus_file_get (location=location@entry=0x0) at ../src/nautilus-file.c:788
 open_location_cb (view=0x56249b221950, location=0x0, open_flags=(GTK_PLACES_OPEN_NORMAL | GTK_PLACES_OPEN_NEW_TAB | GTK_PLACES_OPEN_NEW_WINDOW)) at ../src/nautilus-places-view.c:96

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Thank you for your bug report, what do you mean by "open a new partition from the Hard-drive"? What do you do exactly?

Changed in nautilus (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Could you have a look to this one Marco?

The issue is not Ubuntu specific, see https://retrace.fedoraproject.org/faf/reports/1743420/
Could be fixed in 3.28 through refactoring, there has not been reports from the new versions in fedora/gnome bugtrackers

information type: Private → Public
Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed

Yeah, I've noticed this crash and I've been tracking this down a bit.

There's some change I also did upstream which might have helped, not sure if I cherry-picked yet.
In my radar, though.

tags: added: cosmic
description: updated
Changed in nautilus (Ubuntu):
milestone: none → ubuntu-18.04.1
status: Confirmed → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.26.4-0ubuntu1

---------------
nautilus (1:3.26.4-0ubuntu1) cosmic; urgency=medium

  * New upstream release: 3.26.4 (LP: #1782681, LP: #1765776)
  * debian/patches/query-add-recursive-flags-and-use-it-in-search-engines.patch,
    debian/patches/0016-search-engine-add-a-recent-search-engine-listing-Gtk.patch,
    debian/patches/0018-search-engine-add-locate-based-search-engine.patch:
    - Follow nautilus settings to search only in current folder (LP: #1767027).
      This doesn't apply to gnome-shell search provider for indexed searches.
  * debian/patches/0017-recent-add-function-to-update-manager-on-file-rename.patch:
    - Updated to respect upstream requested changes
  * debian/patches/nautilusgtkplacesview-show-error-if-volume-is-not-mounted.patch:
    - don't crash if selecting a volume that is not mounted (LP: #1764779)
  * debian/patches/Revert-Revert-files-view-Remove-new-empty-folder-name-sug.patch,
    debian/patches/Revert-Revert-nautilus-file-Don-t-show-thumbnails-for-the.patch:
    - Reverts the reverts introduced in 2.26.3.1 as they are in ubuntu already
  * debian/patches/clear_pending_selection.patch,
    debian/patches/git_middle_tab.patch,
    debian/patches/server_list_segfault.patch,
    debian/patches/nautilusgtkplacesview-show-error-if-volume-is-not-mounted.patch:
    - Patches removed as they are already applied upstream

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 20 Jul 2018 04:52:45 +0200

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Changed in nautilus (Ubuntu):
status: Fix Released → In Progress

While we're mitigating this error at nautilus level, and while this should also probably be fixed in gtk (same patch, just changing file names), I'm quite sure this is due to some lower level problem.

So for now I've also submitted the issue upstream at GLib level:
  -https://gitlab.gnome.org/GNOME/glib/issues/1458

Changed in glib (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.26.4-0ubuntu2

---------------
nautilus (1:3.26.4-0ubuntu2) cosmic; urgency=medium

  * debian/patches/nautilusgtkplacesview-show-error-if-volume-is-not-mo.patch:
    - don't crash if selecting a volume that is not mounted (LP: #1764779)
    + patch re-added after gbp deleted on importing new upstream release
  * debian/patches/file-view-Always-unset-pending_selection-after-freeing-it.patch:
    - don't crash when try to select a file multiple times in a single run
      (LP: #1713581)
  * debian/patches/query-add-recursive-flags-and-use-it-in-search-engines.patch:
    - Apply the upstream version of it (with 3.26 changes)
  * debian/patches/0015-tracker-search-engine-don-t-start-it-if-not-availabl.patch,
    debian/patches/0018-search-engine-add-locate-based-search-engine.patch,
    debian/patches/file-view-Always-unset-pending_selection-after-freeing-it.patch,
    - Refresh as per recursive-query patch update
  * 0016-search-engine-add-a-recent-search-engine-listing-Gtk.patch:
    - Refresh with upstream merged-description

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 01 Aug 2018 20:58:52 +0200

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
affects: glib (Ubuntu) → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
status: Triaged → In Progress

Hello Lukas, or anyone else affected,

Accepted glib2.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glib2.0/2.56.2-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glib2.0 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

No need to perform full verification as per GNOME exception (https://wiki.ubuntu.com/StableReleaseUpdates/GNOME)

And this bug is fixed in an upstream commit.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
description: updated
description: updated
summary: - Nautilus crashed open Windows-partition
+ Nautilus crashed open Windows-partition [assertion failed: (location !=
+ NULL)]
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.56.2-0ubuntu0.18.04.1

---------------
glib2.0 (2.56.2-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1789472, LP: #1764779)
  * Refreshed patches
  * d/p/tests-network-monitor-Always-use-the-dummy-proxy-res.patch:
    - Removed (aplied upstream)

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 28 Aug 2018 13:25:36 -0500

Changed in glib2.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for glib2.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Lukas, or anyone else affected,

Accepted nautilus into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.26.4-0~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done verification-done-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers