nautilus crash on double clicking on a file

Bug #1754564 reported by cubells on 2018-03-09
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

On double click on a file like as test.txt, nautilus is closed suddenly and file is not open.

$ G_DEBUG="all" NAUTILUS_DEBUG="All" nautilus
Gdk-Message: 06:47:01.176: Error 71 (Error de protocol) dispatching to Wayland display.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Bionic Beaver (development branch)
Release: 18.04
Codename: bionic

cubells (cubells) on 2018-03-09
affects: evince (Ubuntu) → nautilus (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
cubells (cubells) on 2018-03-09
summary: - nautilus crash on double click on a file
+ nautilus crash on double clicking on a file
Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and help make Ubuntu better.

This bug has already been reported as bug 1754169. Therefore, I'm marking this a duplicate.

Francoise (ross-minet) wrote :

I don't think it is a duplicate of the gedit bug. Or maybe I have a different and undeclared bug.

On Wayland (not X11), gnome or ubuntu, Nautilus crashes when clicking on ANY file (mp3, avi, pdf, txt etc.), nautilus closes suddenly. Replicated on two different instances of Bionic on the same PC. Both with nvidia (nouveau driver).

Nemo works well.
It seems to be a problem with a recent version of Nautilus, since I have been testing Bionic on Wayland for at least a month without noticing this quite obvious problem.

My Bionic version was installed on March 8 (daily build iso with updates).

geez (geez) wrote :

Agreed with Francoise, I see the same behaviour.

cubells (cubells) wrote :

@jeremy Can you reopen this bug?

Indeed, what Francoise is saying is true. If I click on any file in my nautilus, nautilus crash.

This is not problem of gedit.

Michael Gratton (mjog) wrote :

Francoise, geez, cubells: This is happening with a lot of GTK+ apps, not just Nautilus. Notice the linked bug is assigned to mutter, not gedit. That's why it's a duplicate.

cubells (cubells) wrote :

Michael: I'll wait for mutter update and test if bug is solved or not.

cubells (cubells) wrote :

I can confirm that bug is solved with mutter patch.

$ apt-cache policy mutter
mutter:
  Instal·lat: 3.28.0-1
  Candidat: 3.28.0-1
  Taula de versió:
 *** 3.28.0-1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

Thank you very much!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers