nautilus crashed with SIGSEGV in gtk_stack_set_visible_child_name()

Bug #1720685 reported by John Clemens on 2017-10-01
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Was simply trying to attach to a remote server over SSH using the UI when nautilus crashed.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: nautilus 1:3.26.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Oct 1 16:41:40 2017
ExecutablePath: /usr/bin/nautilus
InstallationDate: Installed on 2016-07-06 (452 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcCmdline: /usr/bin/nautilus --gapplication-service
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f9f5bf562c7 <gtk_stack_set_visible_child_name+7>: mov 0x30(%rdi,%rax,1),%edx
 PC (0x7f9f5bf562c7) ok
 source "0x30(%rdi,%rax,1)" (0xfffffffffffffe80) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 gtk_stack_set_visible_child_name () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? ()
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 g_cclosure_marshal_generic_va () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in gtk_stack_set_visible_child_name()
UpgradeStatus: Upgraded to artful on 2017-10-01 (0 days ago)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo

John Clemens (clemej) wrote :

StacktraceTop:
 gtk_stack_set_visible_child_name (stack=0x0, name=name@entry=0x558e9b478ea1 "list") at ././gtk/gtkstack.c:1839
 populate_servers (view=0x558e9d448f60) at ../src/gtk/nautilusgtkplacesview.c:534
 ffi_call_unix64 () at ../src/x86/unix64.S:76
 ffi_call (cif=cif@entry=0x7ffedc34a520, fn=fn@entry=0x558e9b441d60 <server_file_changed_cb>, rvalue=<optimized out>, avalue=avalue@entry=0x7ffedc34a3f0) at ../src/x86/ffi64.c:525
 g_cclosure_marshal_generic_va (closure=0x558e9d42ab80, return_value=0x0, instance=<optimized out>, args_list=<optimized out>, marshal_data=<optimized out>, n_params=3, param_types=0x558e9d1a2e50) at ../../../../gobject/gclosure.c:1604

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

information type: Private → Public
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
Matt Zilmer (mzilmer) wrote :

Similar to earlier-reported. The server went down while this client was using it, which may be a different circumstance.

z

Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in nautilus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.26.3-0ubuntu4

---------------
nautilus (1:3.26.3-0ubuntu4) bionic; urgency=medium

  * debian/patches/server_list_segfault.patch,
    debian/patches/clear_pending_selection.patch:
    - don't segfault in the remote server UI, thanks Marco (lp: #1720685)

 -- Sebastien Bacher <email address hidden> Fri, 20 Apr 2018 17:39:11 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.