nautilus crashed with SIGSEGV in g_type_check_instance_is_fundamentally_a()

Bug #1713581 reported by Horst Iglesias on 2017-08-28
106
This bug affects 11 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Marco Trevisan (Treviño)
Bionic
High
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

Nautilus crashes when trying to open a folder selecting a file, when another has already been selected before and the current folder didn't finish loading.

[ Test case ]

It's not easy to verify this without hacking the code to change the scenario, but an example could be launching quickly:
  nautilus /usr/bin/true &
  nautilus /usr/bin/false

At the second command nautilus could crash.

[ Regression potential ]

Calling nautilus with a file argument might not select that file

--

Upstream bug: https://gitlab.gnome.org/GNOME/nautilus/issues/295
Upstream MR: https://gitlab.gnome.org/GNOME/nautilus/merge_requests/277

---

https://errors.ubuntu.com/problem/ef1ce30f6325c683b207fd96a3be93eda5384054
Fixed in https://gitlab.gnome.org/GNOME/nautilus/commit/b6691821b86460bf9d4caa6391666ae506a743c5

no idea,sorry

ProblemType: CrashDistroRelease: Ubuntu 17.10
Package: nautilus 1:3.25.90-0ubuntu1
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.6-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Aug 29 00:07:44 2017
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/nautilus
InstallationDate: Installed on 2017-08-09 (19 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170807)
ProcCmdline: /usr/bin/nautilus --gapplication-service
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f8b19a60d27 <g_type_check_instance_is_fundamentally_a+7>: mov (%rdi),%rdx
 PC (0x7f8b19a60d27) ok
 source "(%rdi)" (0x00000002) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMASignal: 11SourcePackage: nautilus
StacktraceTop:
 g_type_check_instance_is_fundamentally_a () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_ref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_list_copy_deep () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
Title: nautilus crashed with SIGSEGV in g_type_check_instance_is_fundamentally_a()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dip lpadmin netdev plugdev sambashare scanner sudo

Related branches

Horst Iglesias (horst-iglesias) wrote :

StacktraceTop:
 g_type_check_instance_is_fundamentally_a (type_instance=type_instance@entry=0x2, fundamental_type=fundamental_type@entry=80) at ../../../../gobject/gtype.c:4023
 g_object_ref (_object=0x2) at ../../../../gobject/gobject.c:3180
 g_list_copy_deep (list=list@entry=0x4d3191700, func=0x7f8b19a3f9a0 <g_object_ref>, user_data=user_data@entry=0x0) at ../../../../glib/glist.c:680
 nautilus_files_view_set_selection (nautilus_files_view=<optimized out>, selection=0x4d3191700) at ../src/nautilus-files-view.c:3083
 load_new_location (self=<optimized out>, location=0x4d31868e0, selection=0x4d3191700, file_to_activate=0x0, tell_current_content_view=<optimized out>, tell_new_content_view=<optimized out>) at ../src/nautilus-window-slot.c:1860

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

information type: Private → Public
tags: added: bionic
description: updated
Changed in nautilus (Ubuntu):
importance: Medium → High
Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
description: updated

This should be actually fixed by nautilus 1:3.26.3-0ubuntu1

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

@Marco, that's still an issue in 1:3.26.3-0ubuntu4 according to e.u.c

Yeah, I've noticed it... Mh, I'm a bit out of ideas at this point.
I'll see if I can find a way to reproduce it.

Changed in nautilus (Ubuntu):
status: Fix Released → Triaged
Changed in nautilus (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.26.4-0ubuntu2

---------------
nautilus (1:3.26.4-0ubuntu2) cosmic; urgency=medium

  * debian/patches/nautilusgtkplacesview-show-error-if-volume-is-not-mo.patch:
    - don't crash if selecting a volume that is not mounted (LP: #1764779)
    + patch re-added after gbp deleted on importing new upstream release
  * debian/patches/file-view-Always-unset-pending_selection-after-freeing-it.patch:
    - don't crash when try to select a file multiple times in a single run
      (LP: #1713581)
  * debian/patches/query-add-recursive-flags-and-use-it-in-search-engines.patch:
    - Apply the upstream version of it (with 3.26 changes)
  * debian/patches/0015-tracker-search-engine-don-t-start-it-if-not-availabl.patch,
    debian/patches/0018-search-engine-add-locate-based-search-engine.patch,
    debian/patches/file-view-Always-unset-pending_selection-after-freeing-it.patch,
    - Refresh as per recursive-query patch update
  * 0016-search-engine-add-a-recent-search-engine-listing-Gtk.patch:
    - Refresh with upstream merged-description

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 01 Aug 2018 20:58:52 +0200

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Changed in nautilus (Ubuntu Bionic):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → Triaged

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

description: updated

Hello Horst, or anyone else affected,

Accepted nautilus into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.26.4-0~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers