Ubuntu

file manager hangs when mounted nfs drive is no longer accessible

Reported by Mehul J. Rajput on 2007-11-20
118
This bug affects 22 people
Affects Status Importance Assigned to Milestone
dolphin
Incomplete
High
thunar
Unknown
Unknown
thunar-vfs
Confirmed
Unknown
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
nfs-utils (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nautilus

I am using ubuntu 7.10, Gutsy 386 version.

I am using a laptop which I use to in home and office. At home I am having network drive which mounted through nfs in home.

I normally put my laptop to suspend and then bring over the same to work. When I access nautilus in this case, it just simply hangs it does not open any folder neither from Places or directly typing command nautilus.

This is very annoying as I have to reboot the computer just for nautilus hanging.

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete

I have tried taking a back trace but since nautilus does not start
itself it is not giving any kind of back trace using the procedure given
above.
-
Regards,
Mehul

- Powered by Ubuntu, Driven by Linux

-----Original Message-----
From: Pedro Villavicencio <email address hidden>
Reply-To: Bug 164120 <email address hidden>
To: <email address hidden>
Subject: [Bug 164120] Re: nautilus hangs when mounted nfs drive is no
longer accessible
Date: Tue, 20 Nov 2007 17:06:55 -0000

Thanks for your bug report. Please try to obtain a backtrace
http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the
bug report. This will greatly help us in tracking down your problem.

** Changed in: nautilus (Ubuntu)
   Importance: Undecided => Medium
     Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
       Status: New => Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in nautilus:
status: Incomplete → Invalid
Mehul J. Rajput (mehulrajput) wrote :

I am still getting this error and it is forcing me to shutdown my ubuntu every day. I have found that issue is probably in gnome-mount extension. Nautilus simply hangs and it does not do anything after printing line

Initializing gnome-mount extension.

I have tried generating the stack trace, I followed the guide at https://wiki.ubuntu.com/Backtrace?highlight=%28back%29%7C%28trace%29

but since nautilus is hanging it never reaches the states where I can type the command

(gdb) backtrace full

please let me know if I can provide more information in some other way.

Changed in nautilus:
status: Invalid → New
dmizer (dmizer) wrote :

This problem is quite easily reproduced.

configure an nfs server and client according to this howto
http://www.ubuntuforums.org/showthread.php?t=249889
configure the client to connect to the nfs server on boot with the mount in /media/mount-point.
disconnect the nfs server from the network.
on the client, open /media/mount-point in nautilus.

nautilus hangs and takes the desktop with it. restarting x does not solve the problem. open windows are responsive and usable. terminal takes input, but the only way to restore the desktop is to reboot.

this problem does NOT appear to be a nautilus bug, as the same thing happens to xubuntu's thunar.

Mehul J. Rajput (mehulrajput) wrote :

Yes I too think the problem is with gnome-mount extension. hope it gets fixed soon as it is quite pain to restart the laptop. Is it possible to restart gnome-mount anyway?

dmizer (dmizer) wrote :

this is not a nautilus bug.

nfs-common does not detect that the server has disconnected, and causes desktop loss. this happens with both nautilus and thunar. i have not tested kde.

Mehul J. Rajput (mehulrajput) wrote :

i have tested in kde. konqueror wheel keeps rotating, but it does not hang konqueror. i can go to other folder. but the same does not happen in gnome. desktop hangs and so does nautilus. kde has its own separate application for desktop i think it is kdesktop and hence it does not hang the desktop.

Changed in nfs-utils:
assignee: desktop-bugs → nobody
Sebastien Bacher (seb128) wrote :

Do you still get the issue? Could have been similar to bug #202861 which is fixed in hardy now

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

no reply to the previous comment and nautilus works correctly in an asynchronous way for other users so closing as fixed, feel free to reopen if you still get the issue though

Changed in nautilus:
status: Incomplete → Fix Released
Mehul J. Rajput (mehulrajput) wrote :

Yes I still face this error. Nautilus hangs when the nfs share is not available. I got this hanging effect today itself.

Mehul J. Rajput (mehulrajput) wrote :

Seems there is some issue in nautilus as it hangs when nfs share goes down and also it brings down the menu of application/places and I cannot access or click it.

Changed in nautilus:
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

don't reopen a closed bug because you have a similar issue, you should open a new bug rather

Changed in nautilus:
status: New → Fix Released
Mehul J. Rajput (mehulrajput) wrote :

I reopened the issue as the issue was not fixed. If the bug is not fixed it has to be reopened and not a new bug should not be created. It will unnecessarily increase the number of bugs.

Sebastien Bacher (seb128) wrote :

nautilus is asynchronous so it should not be due to it, is only nautilus hanging? what other nautilus- did you install?

Mehul J. Rajput (mehulrajput) wrote :

Nautilus hangs and so does the main menu. I have konqueror. It does not hang.

Sebastien Bacher (seb128) wrote :

could you get nautilus and gvfs stacktraces when it's hanging?

Mal (mal-gamble) wrote :

I am seeing this problem with the updated nfs-common package in Hardy. As shown below, I get about a 38 second hang when attempting to mount an export from an off-line server. The same thing on Gutsy produces a "No route to host" message and returns in about 3 seconds.

me@client:~$ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

me@client:~$ uname -a
Linux client 2.6.24-16-386 #1 Thu Apr 10 12:50:06 UTC 2008 i686 GNU/Linux

me@client:~$ dpkg -l | grep nfs-common
ii nfs-common 1:1.1.2-2ubuntu2.1 NFS support files common to client and serve

me@client:~$ time sudo mount.nfs server:/media/share /media/test
[sudo] password for me:
mount.nfs: internal error

real 0m38.489s
user 0m0.032s
sys 0m0.000s
me@client:~$

Same problem here: Under Hardy, when turning off my home network server (running the Hardy server edition), autofs-mounted shares will stall nautilus. The last few lines of an "strace nautilus --no-desktop" read:

socket(PF_FILE, SOCK_STREAM, 0) = 20
fcntl(20, F_SETFL, O_RDONLY|O_NONBLOCK) = 0
fcntl(20, F_SETFD, FD_CLOEXEC) = 0
connect(20, {sa_family=AF_FILE, path="/tmp/orbit-franz/linc-20cf-0-32e16af5e90ec"}, 49) = 0
writev(20, [{"GIOP\1\2\1\0v\0\0\0", 12}, {"\350O#\210\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0y\210h\250\347"..., 118}], 2) = 130
poll(

The final "poll(" will seemingly hang forever. The mount points are bookmarked in nautilus, and doing the same under a diffferent user who has *not* bookmarked the NFS shares (e.g. as root) will bring up nautilus instantly. This leads to the conclusion that it might be a nautilus bug.

dmizer (dmizer) wrote :

This is not a nautilus bug. I have the same problem in Hardy XUBUNTU which uses Thunar rather than Nautilus. But, it does use the gvfs as far as I know. Whereas, KUBUNTU does not make use of gvfs and is not afflicted with this problem.

This might be a different behaviour then.

After some testing I can confirm that my nautilus stalling issue is related to bookmarking NFS/autofs-mounted shares.
After manually removing those bookmarks from ~/.gtk-bookmarks, nautilus starts up immediately.

Doing some tests with "strace nautilus --no-desktop" reveals that nautilus issues numerous access()-calls to each bookmarked folder, yielding ENOENT for those NFS/autofs-shares after a timeout of some seconds for each call. Since nautilus does *lots* of those calls even before showing its initial window, startup takes endlessly in this case.

Interestingly, these access() calls appear only for the first instance of nautilus, any subsequently started nautilus instances already "know", that those folders are not available (probably via CORBA/orbit?), they don't even load ~/.gtk-bookmarks.

Manually removing bookmarked NFS/autofs folders from ~/.gtk-bookmarks solved that issue at least in my case.

kindofabuzz (kindofabuzz) wrote :

Same problem here. Bring down server and nautilus hangs on client. Looked into the bookmarks fix, I don't even have bookmarks for NFS folders.
Ubuntu 8.04.1

kindofabuzz (kindofabuzz) wrote :

This problem has been going on for awhile. Probably as long as NFS has been around. Here's a thread from 2003: http://markmail.org/message/sxxoq6jbylipwuju
I don't think this will ever be "fixed". it's not a bug, just a design flaw.

Mal (mal-gamble) wrote :

Actually, I think this bug is related to problem with mount.nfs trying to mount an export on a non-existent server. See https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/234480.

This problem has appeared in Ubuntu Hardy but not in Gutsy.

By the way, I don't see why a design flaw couldn't be a bug. (I think Microsoft would call a design flaw a "feature") :-)

well i meant design flaw in NFS, not Ubuntu.

On Thu, Aug 7, 2008 at 6:27 AM, Mal Gamble <email address hidden> wrote:

> Actually, I think this bug is related to problem with mount.nfs trying
> to mount an export on a non-existent server. See
> https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/234480.
>
> This problem has appeared in Ubuntu Hardy but not in Gutsy.
>
> By the way, I don't see why a design flaw couldn't be a bug. (I think
> Microsoft would call a design flaw a "feature") :-)
>
> --
> nautilus hangs when mounted nfs drive is no longer accessible
> https://bugs.launchpad.net/bugs/164120
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I also have the same problem, folks, Ubuntu Hardy, fully upgraded. When I don't have the NFS in my network, because I move away from that network, then, when I start Gnome, it hangs very quickly.

I have manually deleted NFS directory (which is mounted with autofs) from .gtk-bookmarks, everything goes fine now. If I try to examine that directory from Nautilus, I have to wait, but I'm able to stop it.

I have observed that the problem is that things occur at the background, with no other choice for the user but to wait until autofs tells the user that it is impossible to mount the NFS volume. This thing, apparently, never happens. And so, this task should just be threaded at the background, thus allowing Gnome-mounter (or the application which accesses that directory) continue with the job without interrupting all the system.

It's definitely not a flaw in NFS, since it is not possible to tell that the server is down, except if you wait for a long amount of time, which is not acceptable in this case. The only solution is to do this task asynchronously from within Gnome itself, as KDE obviously does.

Maybe some versions of NFS and autofs wait for a bit shorter doing this task, but this may be wrong in other situations, and anyways, you still have to wait that period of time, which is clearly not the correct thing.

Antoine Pairet (b-ly) wrote :

The hang problems are not related to a particular program. Indeed they are observed on all programs that try to access a nfs server which is down. I can confirm that the following programs hang:
 * nautilus
 * firefox (through FireFTP extension)
 * Filezilla

I think the title and the description of this bug report should be reformulated

dmizer (dmizer) wrote :

I believe this is expected NFS behavior, and can be fixed by specifying a soft mount. Hard mount is default due to possible instability issues with soft mounting. Using the soft option fixes the problem for me on all of my machines from Hardy to Jaunty (Ubuntu, Xubuntu, and Kubuntu). The file system remains responsive (though slow) even after the server is disconnected, and a simple "sudo umount /mountpoint" returns the file system to a normal state. For more information, see man nfs "soft / hard".

Soft or hard mounted, still does the same thing.

On Wed, May 27, 2009 at 9:12 PM, dmizer <email address hidden> wrote:

> I believe this is expected NFS behavior, and can be fixed by specifying
> a soft mount. Hard mount is default due to possible instability issues
> with soft mounting. Using the soft option fixes the problem for me on
> all of my machines from Hardy to Jaunty (Ubuntu, Xubuntu, and Kubuntu).
> The file system remains responsive (though slow) even after the server
> is disconnected, and a simple "sudo umount /mountpoint" returns the file
> system to a normal state. For more information, see man nfs "soft /
> hard".
>
> --
> nautilus hangs when mounted nfs drive is no longer accessible
> https://bugs.launchpad.net/bugs/164120
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I have just retested. I am positive that adding "soft" to the /etc/fstab mount options fixes this problem. Nautilus DOES hang, but only for a minute until NFS times out. Then you get an I/O error and Nautilus starts working as expected again. In the mean time, everything else works perfectly fine, the desktop is not lost, and the rest of the system remains responsive. I have tried this solution with Nautilus, Thunar, and ROX.

drub (drub) wrote :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

Same behavior.

Laptop. Set up mounts to a server. Move the laptop away from the server. FS operations freeze.

Behavior is demonstrated using ls().

I will try the soft mount to determine if that can change the behavior.

Cheers!

bbauto (berglund-bengt) wrote :

I can confirm this behavior on my notebook with ubuntu 9.04, and my old stationary P3 with ubuntu 8.04.2. The problems occured in the last week(s).
Workaround:
Killing "bonobo-activation-server" seems to fix the problem temporarily.

Steve Langasek (vorlon) wrote :

Problems with mount.nfs being slow in hardy are unrelated to the bug reported by this submitter; closing the nfs-utils task as invalid.

Changed in nfs-utils (Ubuntu):
status: New → Invalid
whoop (tiredandnumb) wrote :

So..... I still get this bug... In 9.10 and 10.04 (also with soft mount).
Should I open this bug or create a new one, as I get the idea people here keep closing it (could be wrong).

I have been chatting with the nfs folks for a while:
http://thread.gmane.org/gmane.linux.nfs/30482
We did not solve this bugger yet, I somewhat get the idea that this is not caused by either nautilus or nfs (as it is stateless).

Anyhow, current state is that the performance/health of client machines are totally dependent of a single server machine (even if the server is serving non-trivial files to a non-trivial client-directory).

Changed in nfs-utils (Ubuntu):
status: Invalid → New
Steve Langasek (vorlon) wrote :

Please read the explanation given when I closed this task.

Changed in nfs-utils (Ubuntu):
status: New → Invalid
Mehul J. Rajput (mehulrajput) wrote :

@Steve your explanation is not correct.

I have upgraded to latest ubuntu 9.04. Now all my file browsers hangs (nautilus, dolphin, konqueror) when nfs server is not available. As I have stated when I logged the bug, nfs when disconnected hangs everything.

Interestingly though running the script umountnfs.sh in /etc/init.d resolves the problem, which means unmounting solves the problem. I do not know who has to fix this as a user I feel it is ubuntu bug.

If you feel it is not nfs issue, please include the package which you think is the issue.

I do not think nautilus, konqueror or dolphin are the issue as problem would not occur in all three when nfs mount i not available.

Based on this marking this bug as new again

Changed in nfs-utils (Ubuntu):
status: Invalid → New
whoop (tiredandnumb) wrote :

@Steve Langasek:
Nautilus is hanging or not even starting at all, totem and vlc are stuttering at set intervals when playing video files stored on local disk, even the terminal is unresponsive at times, when I lock the screen I have to wait two minutes after entering my password before I get to my desktop again... All of this with a soft mount (from disconnected nfs server) onto a directory I haven't even accessed in that session.
This is not comparable with something being "slow", I was referring to the title of the bug "Nautilus hangs.....etc."

Steve Langasek (vorlon) wrote :

> @Steve your explanation is not correct.

Yes, it is. Do not reopen this task.

Changed in nfs-utils (Ubuntu):
status: New → Invalid
Steve Langasek (vorlon) wrote :

If nautilus is still behaving inappropriately, please reopen the nautilus task instead.

whoop (tiredandnumb) on 2010-01-27
Changed in nautilus (Ubuntu):
status: Fix Released → New
Mehul J. Rajput (mehulrajput) wrote :

> @Steve your explanation is not correct.

> Yes, it is. Do not reopen this task.

I do not think it is related to nautilus. I have tried dolphin, konqueror and even thunar. All of them behave in consistent manner. They do not respond, give blank screen till they are killed or terminated. If it were related to nautilus libraries don't you think it would have disappeared in dolphin, thunar, konqueror. Unless they are relying on some common place.

As I said earlier they would start behaving normally as soon as umountnfs.sh is run from /etc/init.d. So, I feel there is a problem in which nfs mount is behaving. Hence I feel it is related to nfs and not nautilus.

As per your explanation, nfs being slow is not related to the nfs-util. Either nfs time out is not set properly.

I still feel it is related to nfs-util. I would like you to reconsider the explanation I gave above. If you still feel it is not related to nfs-util. Kindly please close the issue. I would open bugs on thunar, dolphin and konqueror too.

Changed in nfs-utils (Ubuntu):
status: Invalid → New
Steve Langasek (vorlon) wrote :

Yes, you should open bugs on each of those pieces of software. I am telling you as a developer that nfs-utils is not involved.

Changed in nfs-utils (Ubuntu):
status: New → Invalid

Version: (using KDE 4.3.4)
OS: Linux
Installed from: Ubuntu Packages

I am using a laptop which I use to in home and office. At home I am having network drive which mounted through nfs in home.

I normally put my laptop to suspend and then bring over the same to work. When I access dolphin in this case, it just simply hangs it does not open any folder neither from quickview or folder view. Even plasma-desktop hangs. the only option is to reboot even terminating the app does not work.

This is very annoying as I have to reboot the computer just for dolphin hanging.

This is similar to bug I created for nautilus too here in ubuntu bug tracker.

https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/164120

Changed in dolphin:
status: Unknown → New
whoop (tiredandnumb) wrote :

I agree that it is not very likely that this problem lies in nfs, but I also don't think it lies in nautilus, thunar, dolphin etc. I am also experiencing hangs in vlc, totem, terminal even the login screen (after I locked the screen). Basically any application that requires (additional) disk access (which is just about every application) has issues when nfs server is disconnected. It could be that file managers are behaving especially bad as they read entire directories (or even directory structures), not just a single file.
I tend to think it has something to do with the mounting process itself or with vfs, but I have not been able to find concrete evidence.

summary: - nautilus hangs when mounted nfs drive is no longer accessible
+ file manager hangs when mounted nfs drive is no longer accessible

The the Xubuntu / Thunar issue -

Thank you for your bug report. This bug has been reported to the developers of Thunar. You can track it at: http://bugzilla.xfce.org/show_bug.cgi?id=6185

Changed in thunar:
status: New → Confirmed
importance: Undecided → Low
whoop (tiredandnumb) wrote :

I have nfs soft mounted to /remote/nfsshare, I shut down the nfs server. Now when I try to launch "Places-->Home Folder" nothing happens accept the cursor is in hour glass mode for some time.
So I tried to launch it from the terminal and got this:
whoop@whoop-desktop:~$ nautilus /home/whoop/

(nautilus:2039): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nautilus:2039): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
whoop@whoop-desktop:~$

Why does displaying /home/whoop need access to /remote/nfsshare?

Sense Egbert Hofstede (sense) wrote :

I'm closing this task because this issue has already been reported upstream to XFCE in Thunar, making this task is redundant.

Changed in thunar:
status: Confirmed → Invalid
Changed in nautilus (Ubuntu):
status: New → Fix Released
status: Fix Released → New
Changed in thunar-vfs:
status: Unknown → Confirmed

Thanks for the report. Does this issue still occur with a more recent KDE version in your environment? (e. g. 4.4 or 4.5)

Changed in dolphin:
status: New → Unknown
Mal (mal-gamble) wrote :

If it's any help, I think this bug actually arises from a change in kernel behavior introduced after version 2.6.22 and fixed in kernels from 2.6.33. See my posts 17 and 18 in this bug: https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/234480.

Changed in dolphin:
importance: Unknown → High
status: Unknown → Incomplete
Ben (bnordin) wrote :

I do not believe this is a NFS issue because I receive the same issue using smbfs mounted in /media/remotedrive. Nautilus fails to respond when the network becomes unavailable.

 I have a workaround thats annoying, but works. Execute the following commands in the Alt+F2 prompt.
1. gksudo umount /media/remotedrive
2. killall nautilus

Steps to reproduce
1. Create a samba share on a remote computer
2. Install the smbfs package
3. Add an entry in fstab to mount your remote share
//remoteserver/export /media/remotedrive smbfs rw,noauto,user,async,uid=1000,gid=1000,credentials=secretfile 0 0
4. Remove the computer from the network (physically)
At this point, Nautilus stops responding.

uname -a
Linux xxxxxxxx 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:29 UTC 2011 i686 GNU/Linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) wrote :

Hello, guys!
I still get this error on Natty 11.04.
If mounted NFS share gone away I can't start new nautilus windows and apps dependent on Nautlius (for example, FreeFileSync).

tags: added: natty
cotillion (tobias-schwan) wrote :

Hi,
also having this problem and I would like to give further information if needed.

Yes, this bug still occurs in KDE4.9. (Why wouldn't it? It's not like bugs magically disappear, except perhaps in fantasy land).

The solution is really simple; run the lstat calls to nfs mounted locations in a separate lightweight thread/green thread.

This has been a problem for 9(!) years now.

Does Dolphin still have any maintainers/developers?

TimGS (timspe) on 2013-08-14
Changed in thunar:
importance: Low → Unknown
status: Invalid → Unknown
TimGS (timspe) wrote :

I see this issue in Thunar on Xubuntu 12.04.

I confirm this happens in 12.04 and Thunar, which is not capable of storing shortcuts to nfs folders on the sidebar.

Craig (craig-st) wrote :

In Ubuntu 12.04, after installing autofs and setting up nfs autofs mounts, my nautilus temporarily hangs (window greys, freezes, becomes unresponsive) when navigating local directories, if the server exporting the autofs nfs mounts is offline. This is observed even when navigating local directories that do not contain any of the autofs mount points, i.e. navigating somewhere under /home, with autofs nfs mount points that are somewhere under /var. Although the hang is temporary, it's a looooong temporary. I noticed a previous comment suggesting that using separate threads could fix this problem in nautilus, even if the problem could technically be attributed to nfs or autofs. Sounds sensible.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.