Can't rename files in nautilus

Bug #16212 reported by David Jensen on 2005-04-18
14
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Whenever I try to rename a file in nautilus the text flashes back instantly from
editing mode.

This only happens in list mode and on one of my harddrives.
The partition is ext3 and I have the right permissions. Even setting them to 777
doesn't work.

Im using Hoary with nautilus-2.10.0-ubuntu9

Richard Bach (bachus) wrote :

http://www.ubuntuforums.org/showthread.php?p=155732 covers this problem, too.
For me it seems entirely random whether you can rename or not, but I haven't
really conducted any scientific tests to find a pattern. It seems to happen
most often on my large (350GB+) reiserfs partition, but that could simply be
because I don't rename things in other partitions as often.

Sebastien Bacher (seb128) wrote :

do you use the icon or the list mode? are you downloading some when you get this
issue?

David Jensen (david-lgj) wrote :

(In reply to comment #2)
> do you use the icon or the list mode? are you downloading some when you get this
> issue?

The problem occurs only in list mode, if I switch to icon mode it works fine.
For me it's consistent on that partition, it happens whether I download or not.
I can never rename in list mode on that particular partition.

Richard Bach (bachus) wrote :

At least for me, it appears that the problem only appears in list view when
you're renaming something under a directory under /mnt. For example, I can
rename things in my home directory without incident, but not in /mnt/data. If I
create a symlink from my home directory to /mnt/data and use that (so the path
in Nautilus' location bar is /home/username/data) I can rename files. However,
being located under the user's home directory isn't the only way to rename
files. I have a symlink going from /usr/local/games to a subdirectory on
/mnt/data and that, too, works fine.

David Jensen (david-lgj) wrote :

I also tried symlinking into /mnt from both root and my home directory. Both
worked! I hadn't tried that before.

Beniamino Caputo (benjamin) wrote :

I notice thath the problem appear also with a symlink in home to the /mnt/data
when in the partition mounted there are some process that write to a file.
IMHO it appear related to some write activities in the partition.

Pedro Côrte-Real (pedrocr) wrote :

I can also reproduce this bug consistently in hoary. The only strange thing I am
doing is using a 2.6.13 kernel rolled by me. Maybe we all have that in common?

Sebastien Bacher (seb128) wrote :

do you still have this issue?

Pedro Côrte-Real (pedrocr) wrote :

Because of this:

https://bugzilla.ubuntu.com/show_bug.cgi?id=16495

I can't actually open the volume to try this. If I go to /media/VolumeName I can
rename stuff there just fine.

Daniel Holbach (dholbach) wrote :

I wonder, can anybody reproduce this with Dapper? I can't.

Changed in nautilus:
assignee: seb128 → desktop-bugs
Carthik Sharma (carthik) wrote :

I certainly can't reproduce this with the latest version of Nautilus on Dapper.

Since there has been no response to Sebastien's request for info for over 4 months, I am closing this bug as "Rejected". Should any of the original reporters (or anyone else) still have this issue with the latest version of Nautilus in Dapper, please reopen this bug, providing instructions to reproduce.

Thanks a lot for reporting this bug. Good day.

Changed in nautilus:
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.