Install icon overlaps Examples icon in "Try Ubuntu" desktop

Bug #1611955 reported by Jeremy Bicha on 2016-08-10
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
High
nautilus (Ubuntu)
High
Iain Lane
Yakkety
High
Iain Lane

Bug Description

This is perhaps a duplicate of the very old bug 838714.

I tried out today's Ubuntu live yakkety image in VirtualBox on yakkety. The Install Ubuntu 16.10 icon overlaps the Examples icon on the desktop. I am attaching a screenshot.

This was also duplicated today by another user as seen in his screenshot at https://github.com/shimmerproject/Greybird/issues/127#issuecomment-238980774

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: nautilus 1:3.20.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-33.52-generic 4.4.15
Uname: Linux 4.4.0-33-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.3-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Aug 10 16:10:13 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-04-09 (122 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Beta amd64 (20160408)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu Yakkety):
importance: Undecided → High
Jeremy Bicha (jbicha) on 2016-10-04
tags: added: rls-y-incoming
Iain Lane (laney) wrote :

Phew, that was a hard one.

I think I got it though, with thanks to csoriano @ upstream.

Uploaded - this should be on the ISO imho, since it mostly affects the live session.

Changed in nautilus (Ubuntu Yakkety):
status: Confirmed → Fix Committed
assignee: nobody → Iain Lane (laney)
Changed in nautilus:
importance: Unknown → High
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.20.3-1ubuntu3

---------------
nautilus (1:3.20.3-1ubuntu3) yakkety; urgency=medium

  * d/p/0003-nautilus-canvas-Don-t-lay-down-desktop-icons-if-we-h.patch:
    Cherry-pick patch from upstream. Delay laying out the desktop's icons
    until we know the size of the desktop window. Should fix overlapping
    icons, such as those we see in live environments currently. (LP: #1611955)

 -- Iain Lane <email address hidden> Fri, 07 Oct 2016 18:44:55 +0100

Changed in nautilus (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.