~/.thumbnails should be placed in ~/.cache

Bug #160727 reported by Sebastian Breier on 2007-11-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Wishlist
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: nautilus

According to
http://standards.freedesktop.org/basedir-spec/basedir-spec-0.6.html
(FreeDesktop base directory specification):
"$XDG_CACHE_HOME defines the base directory relative to which user specific
non-essential data files should be stored. If $XDG_CACHE_HOME is either not set
or empty, a default equal to $HOME/.cache should be used."

To make things like backups easier, nautilus' gnome-video-thumbnailer should
place its thumbnails somewhere in ~/.cache. This would also ease the
development of automatic cleanup tools (see related blueprints).

description: updated
description: updated
Pedro Villavicencio (pedro) wrote :

Thanks for your report!

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

upstream closed the bug using this comment

"There is a separate freedesktop spec for thumbnailing, and it very clearly
specifies ~/.thumbnails as the shared thumbnail location:

http://people.freedesktop.org/~vuntz/thumbnail-spec-cache/directory.html

You would need to convince people to change the thumbnailing spec, which seems
unlikely."

doing the same on the ubuntu task there

Changed in nautilus:
status: Triaged → Invalid
Changed in nautilus:
importance: Unknown → Wishlist
Jakob Unterwurzacher (jakobunt) wrote :

http://specifications.freedesktop.org/thumbnail-spec/thumbnail-spec-latest.html#HISTORY
May 2012, Version 0.8.0
Modified to respect the XDG Base Directory Specification

Changed in nautilus (Ubuntu):
status: Invalid → New
Changed in nautilus (Ubuntu):
status: New → Triaged
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Sebastien Bacher (seb128) wrote :

the issue is fixed with nautilus 3.6 in raring

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.