nautilus crashes on non-X11 systems Wayland and Mir, with SIGSEGV trying to call XInternAtom() from gdk_x11_atom_to_xatom_for_display()

Bug #1602863 reported by Cristian Aravena Romero on 2016-07-13
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Medium
nautilus (Ubuntu)
High
Unassigned

Bug Description

Crash nautilus.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: nautilus 1:3.18.4.is.3.14.3-0ubuntu4
Uname: Linux 4.7.0-040700rc7-lowlatency x86_64
ApportVersion: 2.20.2-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jul 13 17:03:08 2016
ExecutablePath: /usr/bin/nautilus
InstallationDate: Installed on 2015-07-26 (353 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150723)
ProcCmdline: nautilus -n
SegvAnalysis:
 Segfault happened at: 0x1a7fa20: add (%rax),%eax
 PC (0x01a7fa20) in non-executable VMA region: 0x01a3f000-0x01eb7000 rw-p [heap]
 source "(%rax)" (0x01a7bf00) ok
 destination "%eax" ok
SegvReason: executing writable VMA [heap]
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 XInternAtom () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 gdk_x11_atom_to_xatom_for_display () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in XInternAtom()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 ?? ()
 XInternAtom (dpy=0x1a7f160, name=name@entry=0x1e96f90 "_NET_DESKTOP_MANAGER_S0", onlyIfExists=onlyIfExists@entry=0) at ../../src/IntAtom.c:174
 gdk_x11_atom_to_xatom_for_display (display=display@entry=0x1ac0000, atom=atom@entry=0x53) at /build/gtk+3.0-hEt8eK/gtk+3.0-3.18.9/./gdk/x11/gdkproperty-x11.c:115
 nautilus_desktop_window_init_selection (window=0x1d2e330) at nautilus-desktop-window.c:136
 nautilus_desktop_window_constructed (obj=<optimized out>) at nautilus-desktop-window.c:191

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed

Hi, are you using Unity7/X11 or Unity8, or other?

I just found a similar crash in bug 1603923

Hi, gnome-shell

Daniel van Vugt (vanvugt) wrote :

Gnome Shell on X11 (default) or on Wayland?

Daniel, Wayland

Daniel van Vugt (vanvugt) wrote :

Awesome, thanks. Then my Mir crash is the same bug as this. Nautilus on any non-X11 platform will hit it.

summary: - nautilus crashed with SIGSEGV in XInternAtom()
+ nautilus crashes on non-X11 systems Wayland and Mir, with SIGSEGV trying
+ to call XInternAtom() from gdk_x11_atom_to_xatom_for_display()
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I fixed a similar crash a while back in a different app. It might be the same issue...
https://bugs.launchpad.net/ubuntu/+source/remmina/+bug/1444132/comments/1

tags: added: gtk-mir
Changed in nautilus (Ubuntu):
importance: Medium → High
Sebastien Bacher (seb128) wrote :

Does it work if you make it no display the background (using --no-desktop or changing the gsettings key)?

It might be fixed with https://git.gnome.org/browse/nautilus/commit/?id=c8f45f2 if somebody wants to try that patch, unsure if it would need updating for our older nautilus version though

Changed in nautilus (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

It still crashes in the same place even with nautilus --no-desktop

I'm still guessing it's a simple fix like in comment #12.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

@Daniel, your backtrace looks different from the one on this bug though ... anyway, to debug by somebody who has a machine without x11 working well enough to be able to start nautilus

Changed in nautilus:
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

Oh I see... this was already fixed upstream in nautilus 3.16 but Ubuntu has version "3.18.4.is.3.14.3-0ubuntu4" which is actually quite old.

Daniel van Vugt (vanvugt) wrote :

Yes, comments on the upstream bug are that this was already resolved by:

https://git.gnome.org/browse/nautilus/commit/?id=c8f45f2

We just need that patch in Ubuntu.

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

Ubuntu 16.10 yakkety has been updated with the latest Gnome packages and it works now.

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.