Nautilus does not start on 16.04

Bug #1569970 reported by lotuspsychje on 2016-04-13
230
This bug affects 54 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Critical
Unassigned

Bug Description

when opening nautilus i get the following errors:

lotuspsychje@R00TBOOK:~$ nautilus

(nautilus:9475): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:9475): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
Kon de toepassing niet registreren: Tijd is verlopen

(nautilus:9475): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:9475): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:9475): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

gksu nautilus opens nautilus, but also with an error:

lotuspsychje@R00TBOOK:~$ gksu nautilus

(nautilus:10257): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nautilus 1:3.18.4.is.3.14.3-0ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 13 17:22:53 2016
GsettingsChanges:
 b'org.gnome.nautilus.preferences' b'confirm-trash' b'false'
 b'org.gnome.nautilus.preferences' b'click-policy' b"'single'"
 b'org.gnome.nautilus.preferences' b'enable-delete' b'true'
 b'org.gnome.nautilus.window-state' b'geometry' b"'890x550+0+24'"
 b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'date_modified', 'date_accessed', 'owner', 'group', 'permissions', 'mime_type', 'where']"
InstallationDate: Installed on 2016-04-04 (8 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.xdg.autostart.nautilus.autostart.desktop: 2016-04-05T06:03:34.591882

lotuspsychje (lotuspsychje) wrote :
Thomas Ward (teward) wrote :

Using stock Nautilus after a dist-upgrade from the latest Daily, I am unable to replicate this. The same error output indicated by the original post of the bug shows, but Nautilus pops up without issue.

The only difference between what is filed in this bug and the 'default' I have is that in the .desktop file at `/etc/xdg/autostart/nautilus-autostart.desktop`, I have `display=true` where the OP has `display=false`.

Try editing `/etc/xdg/autostart/nautilus-autostart.desktop` to have `display=true` just to test the 'default' setup, and see if it works then?

Thomas Ward (teward) wrote :

Correction, I have 'NoDisplay=true' in the default, not 'display=true'. However, the default install "just works", so I'm not able to do any confirmation on the issue. (Marking Incomplete though as it needs more information or people to test to confirm)

Changed in nautilus (Ubuntu):
status: New → Incomplete
lotuspsychje (lotuspsychje) wrote :

sudo apt-get update && sudo apt-get upgrade and a reboot fixxed the issue, nautilus back in action...

Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
benny genish (bennygenish) wrote :

Temporarily fix it by Restart or by:
sudo killall nautilus && setsid nautilus

Changed in nautilus (Ubuntu):
status: Invalid → Confirmed
Narcissus (narcissus) wrote :

I am experiencing the same issue on an up-to-date Ubuntu 16.04 install.

It seems to happen randomly. Nautilus doesn't launch and gives the error previously reported if launched via command line. A restart fixes it temporarily.

GNOME nautilus 3.14.3
Linux 4.4.0-45-generic

(nautilus:18396): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:18396): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
Could not register the application: Timeout was reached

(nautilus:18396): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:18396): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:18396): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

I tried killing/ending the nautilus process and the whole X/unity session froze.

Richard Andreu (randreu) wrote :

Fixed for me after sudo apt-get update && sudo apt-get upgrade and a reboot

If you are experiencing this bug after upgrading the package, please set status back to "confirmed".

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
Richard Andreu (randreu) wrote :

Ups. It just happened again after the upgrade. So it's not solved by the upgrade

Daniele Laudani (dslul) wrote :

It still happens from time to time, and my system is up to date.

Vic (v-ubuntuone-slagter) wrote :

Happens to me too (Ubuntu 16.10, updated from 16.04 whit worked fine. System is up to date).
I can use nautilus on my local PC but cannot acces my network devices/shares.
nautils just 'hangs' (= keeps showing the spinning mouse pointer)

After closing nautilus is saw the nautilus process is still running

ps -aux |grep nautilus shows:
<user> 9446 6.2 0.4 1193092 75000 ? Sl 02:22 0:06 /usr/bin/nautilus --gapplication-service

now starting nautilus in the terminal shows:
(nautilus:9576): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:9576): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(yep, twice)

killing nautilus and starting from the terminal gives:
(nautilus:9639): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist

I do not know if that is related.

Vic (v-ubuntuone-slagter) wrote :

My nautilus version is:
nautilus:
  Installed: 1:3.20.3-1ubuntu3.1

Vej (vej) wrote :

Resetting to "Confirmed", because Richard and Daniele stated to get this issue with updated systems.

Vej (vej) wrote :

Just found out, that I am lacking the rights to do so. Sorry.

Thomas Mayer (thomas303) wrote :

I'm using up-to-date ubuntu 16.04

I've seen this issue for the first time, after upgrading to 4.8 HWE kernel, including xorg-xserver hwe. Kernel is 4.8.0-36-generic

Syslog says:

Feb 18 05:03:35 lat61 gnome-session[2876]: (nautilus:3580): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
Feb 18 05:03:35 lat61 gnome-session[2876]: (nautilus:3580): GLib-GObject-WARNING **: invalid (NULL) pointer instance
Feb 18 05:03:35 lat61 gnome-session[2876]: (nautilus:3580): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

Nicolas Merieux (hollowbrain) wrote :

Bug still present after applying said fix.

Narcissus (narcissus) wrote :

Still happening randomly on an up-to-date Ubuntu 16.04.

Now killing the nautilus process solves the issue temporarily, but it takes some time for nautilus to start again even after killing the process.

Changed in nautilus (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → Critical
teo1978 (teo8976) on 2017-04-03
Changed in nautilus (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
O. Farid (farid-o) on 2017-06-02
Changed in nautilus (Ubuntu):
assignee: nobody → O. Farid (farid-o)
assignee: O. Farid (farid-o) → nobody
Vic (v-ubuntuone-slagter) wrote :

I am running 17.04 for a few month and do not have this problem anymore.
My current version is: nautilus (1:3.20.4-0ubuntu2)

Yovan ZJW (jiabanster) wrote :

Bug exist on Ubuntu 16.04 (fully updated as at 21 July 2017),

File Manager opens fine but shows bug in terminal after running : gksu nautilus

Bug message is same as above:

(nautilus:20752): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

Juris Sitcs (juris-brivs) wrote :

Bug exists on Ubuntu 16.04:

(nautilus:3909): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:3909): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:3909): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(nautilus:3909): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(nautilus:3909): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

nautilus --version
GNOME nautilus 3.14.3
nautilus is already the newest version (1:3.18.4.is.3.14.3-0ubuntu6).

summary: - Nautilus does not start
+ Nautilus does not start on 16.04
yash saxena (yshs) wrote :

Using updated ubuntu 16.04

When using nautilus /media/user_name/drive_name
to access drive_name I get

(nautilus:3029): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:3029): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:3029): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:3029): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:3029): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

Version: GNOME nautilus 3.14.3

photon (photonxp) wrote :

Just checked my `/etc/xdg/autostart/nautilus-autostart.desktop`
The default and current value for NoDisplay is:
NoDisplay=true

However with the same problem, still trying to figure out the possible causes.

Stanley (stanleyf) wrote :

This bug also affects

lsb_release -a
    LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
    Distributor ID: Ubuntu
    Description: Ubuntu 16.04.5 LTS
    Release: 16.04
    Codename: xenial

apt policy nautilus
    nautilus:
      Installed: 1:3.18.4.is.3.14.3-0ubuntu6
      Candidate: 1:3.18.4.is.3.14.3-0ubuntu6

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers