Ubuntu

Searching within Nautilus doesn't work at all

Reported by loomy on 2007-10-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

If I click Search in Nautilus (or Ctrl+F), it doesn't find anything I search for. For instance I'm in /bin and I ctrl+f for Bash and nothing comes up. At first I thought Nautilus search was stupid and would only search the current directory (rather than recursively), but even that doesn't seem to be the case.

Meanwhile if I click Search from the Places menu, the search works fine.

Something is definitely broken, but it may be related to this bug: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/150379

I had Tracker installed on 7.04 for months. Then I upgraded to 7.10 several hours ago. If Ubuntu is searching with different search tools in different places, it shouldn't be. If Ubuntu is using a search that doesn't work all the time, it shouldn't be. If Nautilus doesn't fall back to a search that works if it is using a search that doesn't work, it should.

pt123 (pt123) wrote :

It is using Tracker's results when it shouldn't be.
There needs to be an option to let Nautilus not use tracker

If I navigate to a folder and then do a search all I want is results within the folder.

This is annoying before you could navigate to the /usr/share/icons folder

and search for "contact-new.png" and you will get all the varieties of it in thumbnails.

With this Tracker search you can't expect us to index our root folder.

Also if you search for a general term like you .jpg you will get a zillion results. While with the old search it was specific to a folder.

pt123 (pt123) wrote :

There is a some what of a work around,
An application called nautilus-search-tool

http://saettaz.altervista.org/softwa...arch_tool.html

Deb
http://www.getdeb.net/app.php?name=nautilus-search-tool

That lets your right click on folder and search in it. It brings the search dialog found under places, it sets the folder for you so you don't have to browse to it.

Nick Demou (ndemou) wrote :

maybe dupe bug #148701

Ari (ari-reads) wrote :

I run into the same problem. I didn't know Nautilus relied on tracker, and one of the first things I did when installing gutsy was disabling tracker daemon in System>Preferences>sessions.

I don't search that often, but obviously searches never worked in nautilus, I was using search -name in a terminal.

I should have got a warning by nautilus that searches don't work if tracker deamon is off.

Also I second the option to have nautilus optionally not to depend on tracker. I don't want any PC-wide index in my desktop. I doesn't make any sense for me (a search across 20000 files in my home desktop takes 3 seconds) plus it can have security implications.

Thanks for hinting tat Places > Search still works, I hadn't noticed it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers