Nautilus background handling screwed when changing scaling factor.

Bug #1480217 reported by Shih-Yuan Lee on 2015-07-31
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
Trusty
Undecided
Unassigned
nautilus (Ubuntu)
High
Lars Karlitski
Trusty
High
Unassigned

Bug Description

* Impact
with some scale factor configurations nautilus might not handle all the background surface correctly

* Test case

1. Login to Unity desktop environment.
2. Change the scale factor to 2 in Displays of System Settings.
3. Logout and login again
3. Change the scale factor to 1 in Displays of System Settings.

Expected Result:
The background will work normally.

Actual Result:
The background becomes a mess.

* Regression potential

Check that the background image is correctly rendered

Related branches

Shih-Yuan Lee (fourdollars) wrote :
tags: added: trusty vivid wily
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
summary: - Nautilus transparent background becomes a mess when changing scaling
- factor.
+ Nautilus background handling screwed when changing scaling factor.
tags: added: rls-w-incoming
Will Cooke (willcooke) on 2015-10-29
Changed in nautilus (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
Lars Karlitski (larsu) on 2015-10-30
Changed in nautilus (Ubuntu):
status: Triaged → In Progress
Changed in nautilus (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
description: updated
tags: added: rls-x-incoming
removed: rls-w-incoming
Iain Lane (laney) wrote :

Uploaded to xenial and trusty-proposed

Please clear the current SRU out to updates before accepting this one though

Changed in nautilus (Ubuntu):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) wrote :

I've built a package for vivid to test a crasher in the intel X driver, and looks like this update doesn't trigger that anymore. But I'm also still seeing corruption in bottom and right edge of the screen, maybe 2 pixels wide on this 3200x1800 screen..

Timo Aaltonen (tjaalton) wrote :

just to avoid confusion, #5 doesn't mean that this update causes a crasher, on the contrary it seems to work around it at least on vivid

Hello Shih-Yuan, or anyone else affected,

Accepted nautilus into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.10.1-0ubuntu9.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Shih-Yuan Lee (fourdollars) wrote :

I have verified nautilus/1:3.10.1-0ubuntu9.11 and it works.

tags: added: verification-done
removed: verification-needed
Changed in oem-priority:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.14.2-0ubuntu14

---------------
nautilus (1:3.14.2-0ubuntu14) xenial; urgency=medium

  * debian/patches/ubuntu_revert_no_wallpaper.patch:
    - update to listen to scale factor changes (lp: #1480217)

 -- Lars Uebernickel <email address hidden> Mon, 02 Nov 2015 14:22:11 +0000

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
tags: added: verification-done-trusty
removed: verification-done
Ara Pulido (ara) on 2015-11-11
tags: added: verification-done
removed: verification-done-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu9.11

---------------
nautilus (1:3.10.1-0ubuntu9.11) trusty; urgency=medium

  [ Lars Uebernickel ]
  * debian/patches/ubuntu_revert_no_wallpaper.patch:
    - update to listen to scale factor changes (lp: #1480217)

  [ Iain Lane ]
  * Fix patch name in previous changelog entry.

 -- Lars Uebernickel <email address hidden> Mon, 02 Nov 2015 15:18:03 +0000

Changed in nautilus (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nautilus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments