nautilus crashed with SIGSEGV in action_quit()

Bug #1442861 reported by Aneesh Neelam on 2015-04-11
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Crashed when mounting external drive

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: nautilus 1:3.14.2-0ubuntu8
ProcVersionSignature: Ubuntu 3.19.0-12.12-generic 3.19.3
Uname: Linux 3.19.0-12-generic x86_64
ApportVersion: 2.17-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Apr 11 12:22:10 2015
ExecutablePath: /usr/bin/nautilus
GsettingsChanges: b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'date_modified', 'date_accessed', 'owner', 'group', 'permissions', 'mime_type', 'where']"
InstallationDate: Installed on 2015-01-09 (91 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
ProcCmdline: nautilus -n
SegvAnalysis:
 Segfault happened at: 0x42e088: mov (%rbx),%rbp
 PC (0x0042e088) ok
 source "(%rbx)" (0x00000033) not located in a known VMA region (needed readable region)!
 destination "%rbp" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kvm libvirtd lpadmin plugdev sambashare sudo

Aneesh Neelam (aneesh-neelam) wrote :
information type: Private → Public

StacktraceTop:
 action_quit (action=<optimized out>, parameter=<optimized out>, user_data=<optimized out>) at nautilus-application-actions.c:193
 g_closure_invoke (closure=0x1f9af90, return_value=0x0, n_param_values=2, param_values=0x7ffe7375d330, invocation_hint=0x7ffe7375d2d0) at /build/buildd/glib2.0-2.44.0/./gobject/gclosure.c:768
 signal_emit_unlocked_R (node=node@entry=0x220d900, detail=detail@entry=0, instance=instance@entry=0x240ded0, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7ffe7375d330) at /build/buildd/glib2.0-2.44.0/./gobject/gsignal.c:3549
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7ffe7375d4c0) at /build/buildd/glib2.0-2.44.0/./gobject/gsignal.c:3305
 g_signal_emit (instance=instance@entry=0x240ded0, signal_id=<optimized out>, detail=detail@entry=0) at /build/buildd/glib2.0-2.44.0/./gobject/gsignal.c:3361

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in g_closure_invoke()
+ nautilus crashed with SIGSEGV in action_quit()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.14.2-0ubuntu12

---------------
nautilus (1:3.14.2-0ubuntu12) wily; urgency=medium

  * debian/patches/git_file_dnd.patch:
    - nautilus-view-dnd: fix unwanted refresh when dnd over archiver file
  * debian/patches/git_sidebar_selection.patch:
    - window: set places sidebar to the previous location on error
  * debian/patches/git_open_dir_with.patch:
    - restore working "open with" action for directories
      (lp: #1183390)
  * debian/patches/git_unmount_seg.patch:
    - don't segfault on unmounting (lp: #1438216)
  * debian/patches/git_wrap_label.patch:
    - correctly wrap labels in dialogs so they have a reasonable width
  * debian/patches/git_valid_list.patch:
    - use valid window list should fix a segfault (lp: #1442861)
  * debian/patches/git_nomodel_segfault.patch:
    - view: don't crash on view destroy if no model

 -- Sebastien Bacher <email address hidden> Fri, 09 Oct 2015 17:43:01 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers