nautilus crashed with SIGABRT in g_assertion_message()

Bug #1438216 reported by wgroiss on 2015-03-30
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
High
Unassigned

Bug Description

I had an VPN-connection to my company (Cisco-Any-Connect) and had opened a file in a folder. After Closing the file i unmounted the folder to my company-network (with triangel within nautilus filesystem) an changed to another local folder.
Than i disconnected VPN and some hours later i connected again. After click in nautilus on the company folder (via bookmark) nautilus crashed with this bug.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: nautilus 1:3.14.2-0ubuntu6
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 30 15:34:28 2015
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:

InstallationDate: Installed on 2015-01-18 (71 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150117)
ProcCmdline: nautilus -n
Signal: 6
SourcePackage: nautilus
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

wgroiss (wolfgang-groiss-gmx) wrote :
Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed

Crash is reproducible fairly often with a simple Ubuntu Utopic samba file server and crash on Ubuntu VIvid client.

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
importance: Medium → High
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → Confirmed
tags: added: wily
tags: added: cherry-pick
Changed in nautilus:
status: Confirmed → Fix Released
information type: Private → Public
Changed in nautilus (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.14.2-0ubuntu12

---------------
nautilus (1:3.14.2-0ubuntu12) wily; urgency=medium

  * debian/patches/git_file_dnd.patch:
    - nautilus-view-dnd: fix unwanted refresh when dnd over archiver file
  * debian/patches/git_sidebar_selection.patch:
    - window: set places sidebar to the previous location on error
  * debian/patches/git_open_dir_with.patch:
    - restore working "open with" action for directories
      (lp: #1183390)
  * debian/patches/git_unmount_seg.patch:
    - don't segfault on unmounting (lp: #1438216)
  * debian/patches/git_wrap_label.patch:
    - correctly wrap labels in dialogs so they have a reasonable width
  * debian/patches/git_valid_list.patch:
    - use valid window list should fix a segfault (lp: #1442861)
  * debian/patches/git_nomodel_segfault.patch:
    - view: don't crash on view destroy if no model

 -- Sebastien Bacher <email address hidden> Fri, 09 Oct 2015 17:43:01 +0200

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.