nautilus_menu_provider_get_background_items: assertion 'NAUTILUS_IS_MENU_PROVIDER (provider)' failed

Bug #1429535 reported by dino99 on 2015-03-08
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Get that error from journalctl

org.gnome.Nautilus[1518]: ** (nautilus:3572): CRITICAL **: nautilus_menu_provider_get_background_items: assertion 'NAUTILUS_IS_MENU_PROVIDER (provider)' failed

https://developer.gnome.org/libnautilus-extension/stable/libnautilus-extension-nautilus-menu-provider.html

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: nautilus 1:3.14.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.16.2-0ubuntu1
Architecture: i386
CurrentDesktop: GNOME
Date: Sun Mar 8 09:35:05 2015
GsettingsChanges:
 b'org.gnome.nautilus.list-view' b'use-tree-view' b'true'
 b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'date_modified', 'date_accessed', 'owner', 'group', 'permissions', 'mime_type', 'where']"
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
dino99 (9d9) wrote :

works as expected now

Changed in nautilus (Ubuntu):
status: New → Invalid
dino99 (9d9) wrote :

hm, kind of ghost reviving on xenial 64 bits (with genuine packages)

Changed in nautilus (Ubuntu):
status: Invalid → New
tags: added: xenial
dino99 (9d9) wrote :

the error:

org.gnome.Nautilus[1695]: ** (nautilus:8309): CRITICAL **: nautilus_menu_provider_get_background_items: assertion 'NAUTILUS_IS_MENU_PROVIDER (provider)' failed

dino99 (9d9) wrote :

Looks like 'python-nautilus' could be blamed for that issue (1.1-4): latest update oct 2013, still depends on python2.7 (libpython2.7)

dino99 (9d9) on 2016-09-15
tags: added: yakkety
removed: vivid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sadi Yumuşak (sa-yu) wrote :

I've just noticed that my kern.log contains this error message 4864 times although I don't see any other visible problem - Ubuntu 16.10 (64-bit)

Which are the perceptible consequences of this bug?

When answered please set status back to "confirmed". Thank you.

Changed in nautilus (Ubuntu):
status: Confirmed → Incomplete
bladepif (bladepif) wrote :

Hello I also have this bug in ubuntu 16.04.
I have different SMB mount points mounted with autofs.
When this error appears, I can not see the content of this drives anymore and can not connect them anymore. Restarting autofs will also not help. I have to reboot to regain access to the SMB.

stinger (dev-t) wrote :

ihmo spamming the system log is a perceptible consequence.
Under Zesty, on every selection i get this message now. This is a regression.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Medium
paz (mozit) wrote :

nautilus[1988]: nautilus_menu_provider_get_background_items: assertion 'NAUTILUS_IS_MENU_PROVIDER (provider)' failed

Ubuntu 17.04.01 - still spamming the syslog.

Andy Holmes (andyholmes) wrote :
GLEPIN Cyprien (betaweb34) wrote :

Hi,

I've the same bug on my syslog "nautilus_menu_provider_get_background_items: assertion 'NAUTILUS_IS_MENU_PROVIDER (provider)' failed" followed by this error "Allocating size to GtkVScrollbar 0x55a3b35f4380 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?".

Is there a fix ?

Thx

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.