Settings > Appearance > Wallpaper does not change wallpaper until Nautilus process is killed and restarted

Bug #1405867 reported by jerrylamos on 2014-12-26
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Iain Lane

Bug Description

Vivid update in the last week selecting new wallpaper does not work unitil reboot.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: unity 7.3.1+15.04.20141216-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.15.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Dec 26 16:49:13 2014
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e12] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Lenovo ThinkCentre M6258 [17aa:3048]
   Subsystem: Lenovo Device [17aa:3048]
InstallationDate: Installed on 2014-11-25 (31 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141125)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-28-generic root=UUID=285177a7-5498-4980-a3f2-7e3f655ca886 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/10/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 5CKT69AUS
dmi.board.name: LENOVO
dmi.chassis.vendor: LENOVO
dmi.chassis.version: NONE
dmi.modalias: dmi:bvnLENOVO:bvr5CKT69AUS:bd01/10/2011:svnLENOVO:pn6234A1U:pvrThinkCentreM58p:rvnLENOVO:rnLENOVO:rvrNONE:cvnLENOVO:ct3:cvrNONE:
dmi.product.name: 6234A1U
dmi.product.version: ThinkCentre M58p
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.0+15.04.20141219-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.58-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.16.2.901-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.916+git20141119-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Fri Dec 26 16:42:49 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.16.2.901-1ubuntu3

jerrylamos (jerrylamos) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Is nautilus running and handling the desktop rendering?

affects: unity (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Confirmed → Incomplete
jerrylamos (jerrylamos) wrote :

"Thank you for your bug report. Is nautilus running and handling the desktop rendering?"

How do I tell? All I do is reboot and do System Settings > Appearance > Wallpaper > select and it doesn't change wallpaper until reboot. 14.10 works fine.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu Vivid Vervet (development branch)"
Linux Lenovo2 3.18.0-8-generic #9-Ubuntu SMP Mon Jan 5 22:51:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

Thanks for any suggestions

Sebastien Bacher (seb128) wrote :

can you right click on the desktop and get a menu displayed?

jerrylamos (jerrylamos) wrote :

Yes, The menu is just fine, New Folder, New Document, etc...Change Desktop Background.
 "Change Desktop Background" results in a window with Settings Appearance,
however the background does not change even though a different background is selected.

How do I get Systems Settings > Appearance > Wallpaper to change short of re-booting?

Right clicking the desktop and selecting "Change Desktop Background" didn't.

Anything else to try?

Timo Aaltonen (tjaalton) wrote :

confirming the bug

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Chris J Arges (arges) wrote :

I have this same issue, I can workaround by changing wallpaper and doing:
gsettings set org.gnome.desktop.background show-desktop-icons false
gsettings set org.gnome.desktop.background show-desktop-icons true

jerrylamos (jerrylamos) wrote :

Another solution is to use Files > Pictures > jpg right click and set wallpaper.

Do note as booted with vivid the wallpaper is hashed badly and I have to set wallpaper every time.

The hashing is a separate bug. This is a Lenovo M58p with:

DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu Vivid Vervet (development branch)"
Linux Lenovo2 3.18.0-12-generic #13-Ubuntu SMP Thu Jan 29 04:35:32 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

Adolfo Jayme (fitojb) on 2015-02-03
summary: - Settings > Appearance > Wallpaper does not change wallpaper
+ Settings > Appearance > Wallpaper does not change wallpaper until
+ Nautilus process is killed and restarted
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
Iain Lane (laney) on 2015-02-09
Changed in nautilus (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.14.2-0ubuntu3

---------------
nautilus (1:3.14.2-0ubuntu3) vivid; urgency=medium

  * 0001-application-use-correct-order-to-watch-for-GSettings.patch: Connect
    to wallpaper changed signal before reading its value, so that we receive
    changed signals with recent glib versions which require this ordering.
    (LP: #1405867)
 -- Iain Lane <email address hidden> Mon, 09 Feb 2015 11:40:40 +0000

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released

still same problem with
 libnautilus-extension1a 1:3.14.2-0ubuntu4 amd64
(works fine w 13.10 14.04 14.10 same pc different partition)
Computer
Processor 4x Intel(R) Core(TM) i3-4130 CPU @ 3.40GHz
Memory 8052MB (720MB used)
Operating System Ubuntu Vivid Vervet (development branch)
User Name corrado (corrado)
Date/Time lun 02 mar 2015 15:41:26 CET
Display
Resolution 1680x1050 pixels
OpenGL Renderer Unknown
X11 Vendor The X.Org Foundation

jerrylamos (jerrylamos) wrote :

Bug still exists with
 libnautilus-extension1a 1:3.14.2-0ubuntu4 amd64
re-installed nautilus with synaptic, reboot, no help.

DISTRIB_DESCRIPTION="Ubuntu Vivid Vervet (development branch)"
Linux Lenovo2 3.19.0-7-generic #7-Ubuntu SMP Thu Feb 26 20:19:34 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

I don't know how to display the commands in comment #11 to see what I have.

problem seems gixed. thanks.

sorry ... fixed ..

jerrylamos (jerrylamos) wrote :

Fixed for me here, I'm the originator of the bug report.

I still have another wallpaper bug #1404247 on every boot the wallpaper is hashed horizontally. Files > Pictures > select a jpg > set as wallpaper fixes the wallpaper until the next boot.

For me is still there, ubuntu 15.04 x64, nautilus is

1:3.14.2-0ubuntu6

My output of:

apport-bug nautilus

To post a comment you must log in.