Copy, cut, and paste in Nautilus fail in certain circumstances

Bug #1322925 reported by Helmut Fedder on 2014-05-24
638
This bug affects 164 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Utopic
High
Unassigned

Bug Description

The title says it.

Since upgrade to 14.04, copy / cut / paste of files among various folders I have write rights on does not work most of the times.

Using the terminal to copy / move does work normally.

nautilus:
  Installed: 1:3.10.1-0ubuntu9.1
  Candidate: 1:3.10.1-0ubuntu9.1
  Version table:
 *** 1:3.10.1-0ubuntu9.1 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.10.1-0ubuntu8 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

[Test Case]

1. Open a Nautilus window and switch to List view
2. Go to location with write permission
3. Select a file and try to rename.
4. When prompted to rename (filename becomes a text entry), open new tab.
5. Select a file, try to copy and paste. You will see that file is not copied and pasted.
6. Go back to original tab. If the file that was selected in step 3 is still selected, unselect it.
7. Try to copy and paste. It should work.
8. Try to rename again, and open new tab.
9. Close old tab, and try to copy and paste. It won't work, and there is no way to restore, except opening a new window.

[Regression Potential]

Already fixed upstream with https://git.gnome.org/browse/nautilus/commit/?id=8032628adc9c8286050716d609c574dc7273dfcb

Brian Burns (aundae) wrote :

I am having the same issue. With multiple instances of Nautilus open, I cannot cut / copy / paste between instances like I used to be able.

Dan (dan-pologea) wrote :

I confirm this behavior. I can not cut / copy / paste using the shortcuts nor using menu entries. Nautilus has become unusable. I am using Nautilus (Files) 1:3.10.1-0ubuntu9.1 in Ubuntu 14.04.

Happens to me too

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
gonguinguen (gonguinguen) wrote :

I confirm this behaviour. I'm experiencing this problem after splitting nautilus window (with ctrl+T command). The problem isn't inmediate, but after a while working with splitted window, copy/paste doesn't work.

In addition, I recently found some files on some other folder, and I realised that those files where the ones I was trying to paste. So, when I tried to paste "nothing happened", but now I see that the files where probably going to another destination folder. I cannot confirm this because I couldn't reproduce the problem, but if this is the case, **it's really critical**, as files could be copying to a different folder without the user even getting to know.

Sorry about my grammar errors :P

I can confirm this behavior. Ubuntu 14.04 updated July 15th from clean install.

8200 (8200) wrote :

I also have this annoying problem. Ubuntu 14.04 amd64 with all latest updates.

Do you need any information for solving this bug?

Dan (dan-pologea) wrote :

I confirm this very annoying bug in Ubuntu 14.04. Nautilus (Files) became unusable. Copy and paste stop working (no matter how you want to access them, e.g. shortcuts, menu) after an undetermined period of time since starting the application. I am using Ctrl+T to split the window but I can not confirm it is related to it or not. Nautilus (Files) is the most used application in Ubuntu and copy/paste files is the most common action. We badly need this solved.

Ahmad Syukri Abdollah (syockit) wrote :

This bug is similar to #988251 except that the older one claims that the options (copy, paste) are greyed out, whilst in our case, it is not, but it gives no effect when you click it.

I can confirm that:
(1) Shortcut keys (Ctrl-C, Ctrl-X, Ctrl-V) do not work within the same tab, nor between tabs of the same window.
(2) Context menu items do not work (Right click>Copy/Cut/Paste), same as (1)
(3) In new windows ("File>New Window" or Ctrl-N), the above (1) and (2) work.
(4) You can copy files on a new window but cannot paste on bug-affected window.

This has been the case since at least Ubuntu 12.04

For now, I'm working around it by copying the path of affected window (Ctrl-L, Ctrl-C) and creating new window to go to the place (Ctrl-N, Ctrl-L, Ctrl-V, Return), but it gets painful when there are lots of tabs.

I've yet to find how to reproduce it.

summary: - copy paste not working in Ubuntu 14.04 nautilus
+ Copy, paste stops working randomly in Ubuntu 14.04 nautilus

Yes, I am having the same issue. May be this issue existed since 12.04, but I never faced any. This issue seems to be very apparent in ubuntu 14.04.

Mike Stroud (stroudmw) wrote :

I also have this annoying "Ctrl+C/Ctrl+V" problem. Ubuntu 14.04 LTS. Installing Parcellite helped, but I still need to clear it's history and re-boot from time-to-time.

Daniel Harvey (daniel.harvey) wrote :

This affects me. Does seem related to Bug #988251.

It affects me too.
It happens often when I start multiple instances of nautilus by holding shift and clicking on the nautilus icon on the launcher.

Heineken (lars-heineken) wrote :

This is especially annoying during file ordering and clean up. After setting up all tabs as needed, copy and paste fails after a while. Please tell how to assist fixing this bug.

Gary Dymock (garydymock) wrote :

Copy and Paste stop responding for me also - I have had to stop using 14.04 (from 12.02).

There are other issues but this is one of the most notable - it extends to copy/paste operations across apps and browsers.

Pierre Proske (pierre-6) wrote :

I have this problem too, it's been there for a couple of months I think. It's random and intermittent, and fixed by restarting nautilus, which of course is annoying when lots of tabs have been set up.

bizmate (diegogullo) wrote :

I can also suffer the same issue. It is surprising how something so basic is not tested (automated) before a release.

description: updated

By the way, Ctrl+A to Select all files is also failing.

The Bright Side (me-knowingme) wrote :

Affected. Drag and drop still works.

Leandro Heck (leoheck) wrote :

Someone know some workaround?
This problem is very annoying.
I already have this problem for months.

Daniel Harvey (daniel.harvey) wrote :

Workaround

What I do is this:
1. Open the destination in another tab in Nautilus.
2. Select the files/folders in the original tab.
3. Right click and select "Move To..." or "Copy To..."
4. The other open tabs are shown under "Places" in the dialog.
5. Select and go.

Would love to see this fixed but I survive with this workaround.

Raj Sanmugam (rajy06) wrote :

I am experiencing the same issue since installing 14.04 lts clean.

Renne (renne) wrote :

On Ubuntu 14.04 LTS Desktop amd64 I have the problem, too. The "Paste" in context menu is either greyed out or it is shown but complains about missing writing permissions - although I just created the target directory or stored other files just minutes ago.

I have the same issue.

I'm got several issues in 14.10:
-> Copy&Paste in nautilus
-> system freeze if using touchad on nvidia dirver (prime)
-> sound mic (sometimes fails )

Dialekti Valsamou (torobotaki) wrote :

Chiming in to say my 14.04 LTS has the same problem.

aungaungminmaung (amcupid2) wrote :

who can solve this bug , I also the same issue .

Marek (marek-ovcacik) on 2014-11-02
no longer affects: nautilus
iBART (mogio) wrote :

14.04 LTS, i cannot copy and paste sometimes.

Cut|Copy + Paste stops working quite regularly in my Nautilus since Ubuntu 14.04 and still in 14.10. The delete button also becomes disabled. No greying out of menu itmes. The shortcuts (Ctrl + X|C|V), delete button and menu items simple stop working.

danishbacker (danishbacker) wrote :

Same issue here.
started noticing this issue after running this command.
"ssh-add ~/.ssh/myec2key.pem"

DEDan (zsdedan) wrote :

This bug affects me in version of Ubuntu 14.10

I think we resolved this issue.

We had this problem every day in some boxes after update from precise to trusty. When we tried to update wine, we can't because synaptic found broken packages. The history was that solving wine problem we solved this too.
A fast search for packages versions with "precise" text in there give us as result some libs, etc. Removing them and updating them solved our problem.

Exactly with this Downgrade: liblcms2-2:amd64 (2.6-3ubuntu1~precise1, 2.5-0ubuntu4)

If anyone can confirm this...

Sorry, forget previous post. We have the problem again. We'll continue testing...

I have this bug in 14.04 with the last updates from canonical.

Josue (josueportiz) on 2014-11-25
no longer affects: nautilus
Happyday19c (happyday19c) wrote :

Still affcted in 14.04:nautilus

I am experiencing this bug on both my computers running 14.04.

As with #5 it happens a while after I split windows (ctrl+T). I also tend to have one or more sftp mounts open when it happens, but that may just be "correlation and not causation" as I often work on remote shares.

LH (lh89) wrote :

please mark this as high priority - its maddening... happens to me several times a day

JohnRB (rbxtnc) wrote :

I am having a similar issue on Ubuntu 14.10 x86_64 on 3.16.0-29-generic, but my mouse commands work fine and any keyboard input does not register at all. When this happens I have to close and relaunch most of the time that fixes it but sometime even that doesn't and then i have to go ahead and restart the whole desktop session.

I can confirm this problem affects me as well on several computers running 64-bit Ubuntu 14.04 that have been clean installed (not upgraded from previous versions). I usually work with several Nautilus windows that each have several tabs open in them, spread on multiple workspaces. I move around and copy or cut and paste, rename files, etc.

I mostly use keyboard shortcuts. Ctrl+T to open new tabs, Ctrl+L to access the location bar, Ctrl+A to select all files, Shift or Ctrl + arrows to make selections, Ctrl+C/X/V to cut/copy paste, Alt+Tab to switch between windows, Alt+Shift + number to select tab, Ctrl+Alt + arrows to choose workspaces, Ctrl+Logo + arrows to arrange windows on screen, etc.

When the problem occurs, seemingly randomly, shortcuts local to the currently open tabs stop working (Ctrl+C/X/V, Ctrl+A). Global shortcuts and shortcuts local to the encompassing windows keep working (Alt+Tab, Ctrl+Alt + arrows, Ctrl+Logo + arrows, Alt+Shift + number, Ctrl+L, etc.).

Killing Nautilus (or logging off then back in) fixes the problem temporarily. My work around is to drag and drop the files between windows or tabs, but this is really cumbersome.

I don't remember having this problem with previous versions of Ubuntu.

iflow (anton-jungwirth) wrote :

I have got the same problem on Ubuntu 14.04 64bit (with all available updates), but I'm using the file manager Nemo (version: 1.8.4).
Closing all file manager windows and reopen them temporarily fixes the problem. However this is very annoying if you have got a lot of windows/tabs open...

Since 10.04 (fresh install) I was affected by this bug and this other one :
Bug #1240198 (Wrong keyboard layout active after booting into desktop)

Suprisingly the two bugs are linked, but think about all shortcuts affected here.

None of them affect me anymore after I have changed my input configuration via im-config.

I have launched im-config in console (with sudo to resolve the bug for all users)
and I have Changed
default (use auto mode set by /etc/default/im-config)
to
ibus (active intelligent input Bus (IBUS) @)

I do not remember if I had to install something to be able to do this.

If like me, you are affected by the two bugs, you may give it a try and repport it here.

Good luck.

isync (o-zucker) wrote :

I have observed that copy/paste _reproducible_ stops working after renames.

Try this:
1. Open a folder/dir with subfolders/subdirs
2. Expand one of the subfolders, not by clicking/entering it, but by clicking the triangle tree symbol to "expand" next to the dir
3. The subdir's files are revealed
4. Rename one of the files in this subdir tree, and choose a name that triggers a re-ordering of the listed files in this subdir
5. Select some files in this subdir and press CTRL+C
6. The files won't get "selected"/"greyed", and paste'ing is not possible anymore for this session of Nautilus

Hi isync, Tried but Not _reproducible_ here.
The file get selected and get pasted.
I don't know if your bug is the one that affected me. See #40

adelphes (adelphes) wrote :

isync: I also tried what you suggested and (from a clean start), the copy and paste works ok.

For me, this issue appears to happen randomly after a period of time and like everyone else, I'm extremely frustrated by this. Copy and paste is a fundamental part of a file explorer and for it to fail so badly in the default program and not be fixed for months is pathetic.

Rant over, I've found that if nautilus is run from a terminal, after copy/paste fails, these errors appears in the window:

 (nautilus:18784): Gtk-WARNING **: Inserting action group 'ClipboardActions' into UI manager which already has a group with this name

(nautilus:18784): Gtk-CRITICAL **: gtk_widget_get_clipboard: assertion 'gtk_widget_has_screen (widget)' failed

(nautilus:18784): Gtk-CRITICAL **: gtk_clipboard_request_text: assertion 'clipboard != NULL' failed

These errors appear over and over whenever a paste operation occurs (copy and cut don't seem to report anything). I don't know whether this helps fix the issue, but it should at least point towards the area.

klemens_u (klemens) wrote :

I'm having the same problem and it is really annoying, because copying files is bread and butter. Please look into this fast!

circum (ferenc-engard) wrote :

I confirm that the bug affects nemo, too -- so presumably the root cause is not in nautilus. I am hit by the bug right after upgrading to 14.04 from 13.10.

I can reproduce the error with the following scenario:

start nemo
press shift-ctrl-n to create a folder. A new folder with 'Untitled Folder' created, the name is selected.
press shift-ctrl again. The order is important -- shift before, ctrl after. The selection goes away, and now the folder 'Untitled Folder' itself is selected.
after that, you cannot cut or copy -- neither with kbd shortcut, neither with menu items. As nemo visually gives feedback upon cutting a file, I can see that the cut action is not performed.

I hope this helps.

nemo 2.0.8

Thanks to Alexander's comment on https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/988251/comments/29, I was able to work out steps to reproduce the bug.

1. Open a Nautilus window.
2. Go to location with write permission
3. Select a file and try to rename.
4. When prompted to rename (filename becomes a text entry), open new tab.
5. Select a file, try to copy and paste. You will see that file is not copied and pasted.
6. Go back to original tab. If the file that was selected in step 3 is still selected, unselect it.
7. Try to copy and paste. It should work.
8. Try to rename again, and open new tab.
9. Close old tab, and try to copy and paste. It won't work, and there is no way to restore, except opening a new window.

Detailed info is reported upstream at https://bugzilla.gnome.org/show_bug.cgi?id=742513

circum, nemo is probably affected in a different manner. This bug is specific to nautilus in the way it occurs, and the patch only fixes the core program. (The library isn't affected, but nemo doesn't use it anyway.)

If the package is from Ubuntu's repository, please create a bug report here instead:
https://bugs.launchpad.net/ubuntu/+source/nemo
(but version 2.0.8 seems to be from PPA)

Miklos Juhasz (mjuhasz) wrote :

I verified that the upstream patch fixes this bug and attached the debdiff for Ubuntu 14.04. There is a package built in my ppa:mjuhasz/backports

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Invalid
Sebastien Bacher (seb128) wrote :

The vivid version of nautilus includes the bugfix

Changed in nautilus (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Thanks Miklos and Ahmad, I've uploaded the debdiff for trusty as well. Could somebody add the SRU informations [1] to the bug description (basically impact/test case description/regression potential)?

[1] https://wiki.ubuntu.com/StableReleaseUpdates

Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → Fix Released

Hello Helmut, or anyone else affected,

Accepted nautilus into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.10.1-0ubuntu9.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: trusty
description: updated
summary: - Copy, paste stops working randomly in Ubuntu 14.04 nautilus
+ [SRU] Copy, paste stops working randomly in Ubuntu 14.04 nautilus
description: updated
Miklos Juhasz (mjuhasz) on 2015-01-08
description: updated

Hi guys

I can confirm that the bug is gone with the proposed package in Ubuntu 14.04 Trusty Tahr.
Nautilus version 1:3.10.1-0ubuntu9.5

Thanks!

Miklos Juhasz (mjuhasz) on 2015-01-10
tags: added: verification-done
removed: verification-needed
Mathew Hodson (mathew-hodson) wrote :

Someone should open a Trusty task for this bug so its status can be properly tracked.

description: updated
tags: added: i386
jong (agitato816) wrote :

exactly same issue on ubuntu 14.04!

Changed in nautilus (Ubuntu Trusty):
status: New → Fix Committed
importance: Undecided → High
klemens_u (klemens) wrote :

I can confirm this very annoying behaviour on my newly setup Ubuntu 14.04LTS. A quick fix would be highly appreciated.

chrisguoado (chrisguoado) wrote :

Looks like this annoying issue is finally fixed in the new updated 3.10.1 in my Ubuntu 14.04.

AnGus King (angus-s) wrote :

I am running version 1:3.10.1-0ubuntu15 on a newly insalled Ubuntu 14.10 and encounter this problem. Happy to test any fix

The verification of the Stable Release Update for nautilus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu9.5

---------------
nautilus (1:3.10.1-0ubuntu9.5) trusty; urgency=medium

  * debian/patches/fix-copy-paste.patch:
    - "nautilus-list-view: Fix copy, paste not working randomly" (lp: #1322925)
 -- Miklos Juhasz <email address hidden> Thu, 08 Jan 2015 13:30:27 +0100

Changed in nautilus (Ubuntu Trusty):
status: Fix Committed → Fix Released
JmZ (cs-stjames) wrote :

Don't know if my problem is linked :

In Nautilus, when viewing in List mode, if I want to change a filename and "navigate" through the different words of the filename (Ex. : "This is a filename example.txt") using CTRL+left/right arrows, the CTRL key acts as if I had used the Escape key -- every time.

In Icon mode, CTRL key works fine though.

Ubuntu 14.04, Nautilus 3.10.1, IBus deactivated

Steve Langasek (vorlon) wrote :

This was SRUed to trusty, but has not been SRUed into utopic. Miklos, could you please upload the corresponding fix to 14.10?

Changed in nautilus (Ubuntu Utopic):
status: New → Triaged
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

I've sponsored to utopic as well

Hello Helmut, or anyone else affected,

Accepted nautilus into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.10.1-0ubuntu15.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Utopic):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Download full text (3.3 KiB)

Sincere apologies - I am now travelling and unable to test.

On 5 February 2015 at 05:18, Chris J Arges <email address hidden>
wrote:

> Hello Helmut, or anyone else affected,
>
> Accepted nautilus into utopic-proposed. The package will build now and
> be available at
> http://launchpad.net/ubuntu/+source/nautilus/1:3.10.1-0ubuntu15.1 in a
> few hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: nautilus (Ubuntu Utopic)
> Status: Triaged => Fix Committed
>
> ** Tags removed: verification-done
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1416607).
> https://bugs.launchpad.net/bugs/1322925
>
> Title:
> [SRU] Copy, paste stops working randomly in Ubuntu 14.04 nautilus
>
> Status in Nautilus:
> Fix Released
> Status in nautilus package in Ubuntu:
> Fix Released
> Status in nautilus source package in Trusty:
> Fix Released
> Status in nautilus source package in Utopic:
> Fix Committed
>
> Bug description:
> The title says it.
>
> Since upgrade to 14.04, copy / cut / paste of files among various
> folders I have write rights on does not work most of the times.
>
> Using the terminal to copy / move does work normally.
>
> nautilus:
> Installed: 1:3.10.1-0ubuntu9.1
> Candidate: 1:3.10.1-0ubuntu9.1
> Version table:
> *** 1:3.10.1-0ubuntu9.1 0
> 500 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main
> i386 Packages
> 100 /var/lib/dpkg/status
> 1:3.10.1-0ubuntu8 0
> 500 http://de.archive.ubuntu.com/ubuntu/ trusty/main i386
> Packages
>
> [Test Case]
>
> 1. Open a Nautilus window and switch to List view
> 2. Go to location with write permission
> 3. Select a file and try to rename.
> 4. When prompted to rename (filename becomes a text entry), open new tab.
> 5. Select a file, try to copy and paste. You will see that file is not
> copied and pasted.
> 6. Go back to original tab. If the file that was selected in step 3 is
> still selected, unselect it.
> 7. Try to copy and paste. It should work.
> 8. Try to rename again, and open new tab.
> 9. Close old tab, and try to copy and paste. It won't work, and there is
> no way to restore, except opening a new window.
>
> [Regression Potential]
>
> Already fixed upstream with
>
> https://git.gnome.org/browse/nautilus/commit...

Read more...

I can confirm for Nautilus 3.10.1 on Ubuntu 14.04 64-bit: the bug is gone!

(After all these, well, years... I had already Pavlovian conditioning going on... ;) All caused by, did I see that right: a wrong return value.)

Thanks Ahmad and everyone else involved in fixing this!

Ross Gayler (r-gayler) wrote :

I can also confirm that it is fixed for me:
Ubuntu 14.10 64-bit
Nautilus 1:3.10.1-0ubuntu15.1

Thanks to all involved. Terrific!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu15.1

---------------
nautilus (1:3.10.1-0ubuntu15.1) utopic; urgency=medium

  * debian/patches/git_fix_copy_paste.patch:
    - "nautilus-list-view: Fix copy, paste not working randomly" (lp: #1322925)
 -- Miklos Juhasz <email address hidden> Thu, 08 Jan 2015 13:30:27 +0100

Changed in nautilus (Ubuntu Utopic):
status: Fix Committed → Fix Released
Alexander Hall (compuguy1088) wrote :

This issue seems to still happen on 15.04 (vivid) and Utopic, but it cannot be duplicated via post #46's instructions (that and it seems to affect copy and paste in all applications, in general.

Luchostein (luchostein) wrote :

I confirm that this issue still happens on every application with Ubuntu 14.04 LTS

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu Trusty):
status: New → Confirmed
Changed in xorg (Ubuntu Utopic):
status: New → Confirmed
Changed in xorg (Ubuntu):
status: New → Confirmed
Mike (pub-mikeb) wrote :

I just installed Ubuntu 15.04 RTM, and faced out with multiple problems with the copying files from HDD to USB flash-drive.

1. Not all files copied! You can't be sure that all what you selected is really copied.
2. You can delete folders in USB drive (Directory is not empty).
3. The copied files are corrupted sometimes.
4. You can't even formate the drive.
5. The progress bar of the copying process moves very quickly, but after this window disappears, you have to wait until this process will be really finished (in background), e.g. if you try to unmount/safely remove USB, you'll get the warning, that the drive is still busy or something like that.

Non of described above issue doesn't happen with the same USB drive on Windows or on Fedora 21, thus it seems to be an Ubuntu specific case.

P.S. I'm in shock that this kind of critical issue is not fixed for during one year and even new releases (14.10 LTS, 15.04) comes with such extremely important bug, when you can't rely on OS in the data copying process.

Viktor (viktor.aksionov) wrote :

This bug with copy/paste still persist

Ubuntu 14.04
Nautilus: 1:3.10.1-0ubuntu9.7

Mike (pub-mikeb) wrote :

After a couple of days trying to deal with this bug, I concluded that this issue is a stop-bug for me. I can't continue using the OS, which is unreliable with the executing such essential task as file management especially when this bug is not being treated for the year. Hope to see this bug fixed as soon as possible, to be able to come back to Ubuntu.

Thanks.

max (max-illis) wrote :

I seem to have the same problem with a little twist:

I have the copy/ paste issue - it is intermittent but very annoying

But when I use F2 to edit a filename in Nautilus I would normally expect the filename to be highlighted, without the extension. What actually happens is the filename is highlighted briefly and then the cursor moves to the end of the file with no highlight. I can't seem to actually highlight the name. Highlighting elsewhere - in a browser for example - works as expected

Ubuntu 15.04
Nautilus 3.14.2

max (max-illis) wrote :

Sorry - should've added that I think these are related as they started occurring at the same time

max (max-illis) wrote :

I think you can ignore this ^^. I think I've tracked it down to this bug https://bugs.launchpad.net/pushbullet-indicator/+bug/1450728 in pushbullet-indicator that seems to interfere with the clipboard and somehow causing the selection bug I was experiencing

Apologies for cluttering up this bug thread

Sorin Irimies (mihaiirimies) wrote :

On 15.04 copy paste issue when wring in Android Studio.

Pablo Guevara (pablomguevara) wrote :

This bug affects me on Ubuntu 14.04.3 LTS

no longer affects: xorg (Ubuntu Utopic)
no longer affects: xorg (Ubuntu Trusty)
no longer affects: xorg (Ubuntu)
Mathew Hodson (mathew-hodson) wrote :

This bug was for a specific problem in Nautilus as outlined by the test case.

Please report a new bug for problems with other applications.

summary: - [SRU] Copy, paste stops working randomly in Ubuntu 14.04 nautilus
+ Copy, cut, and paste in Nautilus fail in certain circumstances
Changed in nautilus (Ubuntu):
assignee: nobody → Jack (lenguyenduyhungdng)
assignee: Jack (lenguyenduyhungdng) → nobody
123vier (flowrist) wrote :

Still happens in Gnome 3.10.1 on 14.04.4.

Subjectively it seems to happen more often when accessing remote sftp directories.

johnmne (phi-reporter) wrote :

Just now this bug appeared on Ubuntu 16.04.
Probably due to an update..

Info (output trimmed):

$ dpkg-query -s nautilus
Version: 1:3.18.4.is.3.14.3-0ubuntu5

Jose Valencia (jvalenciag4) wrote :

Having this issue on Ubuntu 16.10 Nautilus Version: 1:3.20.3-1ubuntu3.1

pigs-on-the-swim (dw1-4) wrote :

In Ubuntu 17.04 I can not paste in Nautilus ("Files" 3.20.4).
- Menue item missing in right-click-contexct-menue
- no function at all using Ctrl + V
- no function at all with Shift + Insert (old Win3.1 style used to work in older versions)
What appears: Nothing. Absolutely nothing happening.
This worked in former versions (12, 14, 15, 16.04, ...)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.