Can't copy a file from SMB share to the local file system: Software caused connection abort

Bug #1312362 reported by Just Asking For A CD on 2014-04-24
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
samba
Fix Released
Medium
nautilus (Ubuntu)
High
Unassigned
samba (Ubuntu)
High
Unassigned

Bug Description

The error reported is "Software caused connection abort". See the screenshot.

It pops up right at the end of the copy operation. This doesn't happen when copying the very same file using a different protocol. Neither does it happen when using another device to copy the very same file over SMB.

It worked until the upgrade from 13.10 to 14.04.

Also see http://askubuntu.com/questions/450206/how-to-fix-a-software-caused-connection-abort-error-in-ubuntu-14-04

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nautilus 1:3.10.1-0ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 24 20:35:35 2014
ExecutablePath: /usr/bin/nautilus
GsettingsChanges: b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'date_modified', 'date_accessed', 'group', 'where', 'mime_type', 'octal_permissions', 'owner', 'permissions']"
InstallationDate: Installed on 2011-10-14 (923 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: Upgraded to trusty on 2014-04-19 (5 days ago)

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
importance: Low → High

There you are - hope it helps. Because SMB is out of bounds since Ubuntu 14.04.

https://bugzilla.gnome.org/show_bug.cgi?id=729010

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Ubuntu 14.04 x64 (thespectre13) wrote :

I also have been experiencing this issue.

I have Ubuntu 14.04 installed on a Laptop a Desktop and also in VirtualBox and they all are having the same problem.

I can copy files to an iomega NAS connected to a Linksys Router but I can not copy files from it.

Regardless of what type or size of file that I try and copy from the NAS it fails with the “Software caused connection abort” error.

This problem was not present in Ubuntu 12.04, 12.10, 13.04 and 13.10.

This error is also not present in Windows 7 or Windows Vista.

Michael Paul (wurmschleuder) wrote :

Affected by this bug also, I found this workaround for Ubuntu 14.04:

As user who needs to access the server, do this:

Step 1
create folders in your home directory which then serve as mountpoints. For each share, you need one folder.
example: /home/user/myshare_on_NAS

Step 2
Next, create a text file that contains your credentials that are needed to access your shares on the server, name it something like ".mynascred" Edit this file, it should then look like this:
username=myusername_for_server
password=mypassword_for_server
Save, then make sure no one except you can access that file (right-click, properties->permissions)

Step 3
make sure, the package cifs-utils is installed

Step 4
with root permissions, edit /etc/fstab to add your shares:
//ip-of-server/share /home/user/myshare_on_NAS cifs noauto,users,credentials=/home/user/.mynascred 0 0

This is all. Log off and back, then you should be able to access your shares using at least Ubuntu/Xubuntu standard filemanager. No additional mount commands or scripts are required with Ubuntu 14.04 (this might be different with older versions)

Hope that helps somehow,
Michael

Hello,

Same issue here. Really big problem for me.

Medion Life NAS, 1.5TB, all routers irrelevant- same issue. Absolutely no problems with Win7, XP, Ubuntu KK, MM 10.10, LL with either accessing, copying or uploading files to any folder.

11.04 can upload files and create folders, but cannot download files, be it copy, send to or open. All file types tried and the only ones I can pull from the NAS are small text files and .htm or .html files which will work ok.

I can however open a *.jpg in GIMP from the NAS which I cannot copy from the NAS- mmm, interesting.

I just fired up an old Lucid Lynx box and a Karmic Koala box and it works seamlessly. Issue only occurs with 11.04.

I have just changed from Nautilus to Nemo and there is NO difference- the issue still occurs.

The origin of the problem seems to be a change in Samba itself. So I presume sooner or later other distributions will have the same problem - as soon as they upgrade Samba to the same level.

This is the link to the bug at Samba:
https://bugzilla.samba.org/show_bug.cgi?id=10584

It looks like this bug affects Zyxel NAS based devices. Among which are the Medion devices. IOMega seems to be affected too.

They're on it now - looking to the Samba source code changes done by Zyxel. I hope they find out soon what's going on - because I'm not going to throw away a perfectly good working device.

Changed in samba (Ubuntu):
importance: Undecided → High
Changed in samba:
importance: Unknown → Medium
status: Unknown → Incomplete
Changed in samba:
status: Incomplete → In Progress
Changed in samba:
status: In Progress → Fix Released
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Changed in samba (Ubuntu):
status: New → Triaged
Horne (horne-b) wrote :

The Samba developers are pretty adamant that this isn't a bug in any version of their software. They place the blame for this problem squarely on the shoulders of Iomega, Zyxel, and anybody else who modified their code for their NAS boxes. The problem, apparently, is that newer versions of Samba hit servers with multiple requests at the same time, and for some reason the Zyxel and Iomega boxes can't handle this. The best solution they've come up with is to modify the smb.conf file on your server to include this setting: "max mux = 1".

luh3417 (raen) wrote :
Download full text (9.5 KiB)

Hi I am having this issue as of about a week ago running 14.04 Ubuntu on Intel® Core™ i7-3770 CPU @ 3.40GHz × 8 This is my conf file. Happy to provide any other info.

more /etc/samba/smb.conf
#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
# - When such options are commented with ";", the proposed setting
# differs from the default Samba behaviour
# - When commented with "#", the proposed setting is the default
# behaviour of Samba but the option is considered important
# enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
 server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
# wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
; wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
; interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself. However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
; bind interfaces only = yes

#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
# syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d

####### Authentication #######

# Server role. Defines in which mode Samba will operate. Possible
# values are "standalone server", "member server", "classic pri...

Read more...

luh3417 (raen) wrote :

Sorry wromg one the conf file begins with the amendment but it still does not work ie
[...]

 # NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.

#======================= Global Settings =======================

[global]
max mux = 1

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP
[...]

luh3417 (raen) wrote :

Sincere aplogies. Ignore my posts. It is working now. Thanks for your posts and bug killing.

mycroes (mycroes) wrote :

Same issue happens for me with a Shuttle Omninas KD20, which doesn't give shell access (and the known hack to get shell access doesn't work on latest firmware). Strange thing is that it doesn't happen on every file. Also, it seems that smbclient will happily fetch the files without issues, even though Nautilus will consistently fail to copy the file, as will gedit fail to open it. I filed a support request at shuttle with a link to samba bug 10548 (https://bugzilla.samba.org/show_bug.cgi?id=10584), hoping that will get me somewhere.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.