"select items matching" (ctrl+s) only selects one file in list view (due to interactive_search ubuntu change)

Bug #1300308 reported by cometdog on 2014-03-31
154
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Nautilus
Unknown
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

steps to reproduce:
1. open folder in files/nautilus which contains multiple files and/or folders
2. type ctrl+s to bring up the "select items matching" dialog
3. type glob pattern into text entry field which should match multiple files
4. choose OK

observed behavior:
 - only the first matching file is selected

expected benavior:
 - all matching files should be selected

This bug makes the "select items matching" feature completely nonfunctional, and is a regression from earlier versions of nautilus / files.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nautilus 1:3.10.1-0ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 31 12:06:55 2014
InstallationDate: Installed on 2014-03-01 (30 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140228)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

cometdog (ericctharley) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Paweł (paff) wrote :

The same issue here.

On bugzilla.gnome.org António Fernandes wrote:
"So far, this bug has only been confirmed by Ubuntu users. Ubuntu ships a
modified nautilus"

Please rise importance.

Paweł (paff) wrote :

What I can add with this strange behaviour, that if I use pattern that should work for many files - it will always mark the same file.

I have such files:
01_Stary_niedzwiedz.mp3
02_Uki.mp3
03_Lokomotywa.mp3
04_Kaczuszki.mp3
05_Banke_lap.mp3
07_Gruszka.mp3
08_Ja jestem Gummi_Mis.mp3
09_Olimpiada_w_Jarzynowie.mp3
10_Cztery_slonie.mp3
11_Uwierz_w_siebie.mp3
12_Mucha_w_mucholocie.mp3
13_Niech_zuje_gol.mp3
14_Spacer_to_przygoda.mp3
15_Piosenka_Buni.mp3
16_Smoczek_smoczek.mp3

If I use pattern "*.mp3" it will always point seccond file "02_Uki.mp3". If I change extension of that file, and next try with the same pattern nautilus will select file "11_Uwierz_w_siebie.mp3".
Whatever file I will select before using "select items matching" its always chose the very same file matching the pattern.

Paweł (paff) wrote :

So like in bugs 1315896 and 1311928 such behavior occurs only in "list mode", and matching works in "icon mode"

summary: - "select items matching" (ctrl+s) only selects one file
+ "select items matching" (ctrl+s) only selects one file in list view

Hi, I've tested in Nautilus 3.12.1 from Debian and I don't see this bug. So it seems that this is *not* an upstream bug.

Sebastien Bacher (seb128) wrote :

Correct, it seems to be due to the patch from bug #1164016 to restore the typeahead feature in Ubuntu

summary: - "select items matching" (ctrl+s) only selects one file in list view
+ "select items matching" (ctrl+s) only selects one file in list view (due
+ to interactive_search ubuntu change)
teo1978 (teo8976) wrote :

Hasn't Canonical had enough evidence that it's time to replace Nautilus with something else?

I mean, this bug is the result of an Ubuntu patch that had to be done in order to revert an upstream regression that made Nautilus completely unusable but that the upstream developers refused to revert. And it is only one of a never-ending list of regressions that have been introduced upstream in Nautilus BY DESIGN in recent years.

Why keep using a file browser (which is a fundamental component of a Desktop system) which is maintained upstream by a bunch of retards?

Constantly figuring out patches to revert changes that break usability in intolerable ways (changes that the upstream developers won't ever recognize are wrong, let alone fix), then having to fix bugs that are caused by those patches, and so on?
Striving to maintain decent quality and UX by fighting against the active and stubborn efforts of the upstream developers to DEGRADE it?
Isn't it less work to switch to a sane file browser and abandon Nautilus altogether?

Julien Olivier (julo) wrote :

<OFF TOPIC>
For me, this bug would have never happened if Canonical stopped "fixing" upstream code. When upstream (here GNOME) chooses to modify its own code, Canonical should respect the developers and not patch the software to make it act like they desire. If the sofwtare isn't considered good enough by Canonical, instead of patching it, they should just switch to another piece of software, leaving the original code untouched.
</OFF TOPIC>

Sebastien Bacher (seb128) wrote :

@teo1978, other filemanagers are available in the archive, should be easy enough to install one

@julo, that's wishful thinking and oversimplification, you can't bounce users between different applications every time they upgrade, and you can't "just follow upstream" for pieces which are part of the desktop because users associate the frustration of changes they don't like to the distribution. That way to look at things work for applications users decide to install, not for things that come with the system

On Thu, Feb 19, 2015 at 12:41:49PM -0000, Julien Olivier wrote:
> <OFF TOPIC>

Can we please keep the rants off the bug tracker?

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Sebastien Bacher (seb128) wrote :

@Julien, oh, also the "Canonical" in your comment is just plainly wrong, those nautilus changes are Ubuntu changes. The patch has been contributed by a community member and the decision to use it discussed by the Ubuntu Desktop Team. Canonical has enough to do and is not trying to supervise every patch applied to the Ubuntu archive...

Julien Olivier (julo) wrote :

@seb128: OK, sorry, just replace Canonical by Ubuntu everywhere in my post. But my opinion stands.

Sebastien Bacher (seb128) wrote :

@Julien, sure, the bug tracker is not a forum to discuss opinions though...

Adolfo Jayme (fitojb) wrote :

Indeed, please refrain from spamming everyone subscribed with rants. This is a bug tracker, people, not a forum.

Changed in nautilus:
status: New → Unknown
Lem (lem-jjr) wrote :

FWIW, this bug is present in Ubuntu 15.04 beta 2.

Ctrl-S select pattern works in icon view (will select multiple files), but not in list view (will only select one file).

If it helps, this also affects a selection once it is pasted/copied to a destination, same pattern as selection. i.e. pasting a selection of files in icon view mode, the selection is retained, whereas pasting in list view, only one file remains selected.

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
tags: added: rls-x-incoming
Simplehuman (simplehuman) wrote :

Still actual for Nautilus 3.18.2 in Xenial, added tags for affected Ubuntu versions.

tags: added: vivid wily xenial
Will Cooke (willcooke) on 2016-02-15
Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
tags: removed: rls-x-incoming
Iain Lane (laney) on 2016-02-15
Changed in nautilus (Ubuntu):
status: Fix Released → Triaged
Will Cooke (willcooke) on 2016-02-15
Changed in nautilus (Ubuntu):
status: Triaged → Confirmed
Iain Lane (laney) on 2016-02-15
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
wil-m (wil-m) wrote :

confirming, bug is still here:

Gnome Ubuntu 16.04

nautilus --version
GNOME nautilus 3.18.5

Simplehuman (simplehuman) wrote :

same bug in 16.10 Nautilus 3.20.3

tags: removed: vivid
tags: added: yakkety
removed: wily

The problematic behavior is present in Ubuntu 18.04, Nautilus 3.26.3.

Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.