G_IS_OBJECT (object) warnings on start (due to 19_unity_open_location_xid)

Bug #1285895 reported by Sebastien Bacher on 2014-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

Those warnings are due to the change added in https://launchpad.net/ubuntu/+source/nautilus/1:3.6.3-0ubuntu13

"#1 0xb719e57d in g_return_if_fail_warning (
    log_domain=log_domain@entry=0xb728f16f "GLib-GObject",
    pretty_function=pretty_function@entry=0xb729272e <__FUNCTION__.12471> "g_object_set", expression=expression@entry=0xb7291377 "G_IS_OBJECT (object)")
    at /build/buildd/glib2.0-2.39.90/./glib/gmessages.c:1080
No locals.
#2 0xb726ba59 in g_object_set (_object=0x0,
    first_property_name=first_property_name@entry=0x8155aa5 "xubuntu-open-locations-xids") at /build/buildd/glib2.0-2.39.90/./gobject/gobject.c:2211
        object = 0x0
        var_args = <optimized out>
        __FUNCTION__ = "g_object_set"
#3 0x080c3877 in nautilus_freedesktop_file_manager1_set_xubuntu_open_locations_xids (object=0x0, value=0xb1a715a8) at nautilus-freedesktop-generated.c:597
No locals.
#4 0x0807ad7d in nautilus_freedesktop_dbus_set_open_locations_xids (fdb=0x0,
    locations=0xb1a715a8) at nautilus-freedesktop-dbus.c:238
        __FUNCTION__ = "nautilus_freedesktop_dbus_set_open_locations_xids"
#5 0x080690ca in update_dbus_opened_locations (app=0x81c00c0)
    at nautilus-application.c:1736
        i = <optimized out>
        l = <optimized out>
        sl = <optimized out>
        locations = <optimized out>
        locations_size = <optimized out>
        locations_array = 0x847edf0
        __FUNCTION__ = "update_dbus_opened_locations"
        b = {x = {0 <repeats 16 times>}}
        wb = {x = {3221219472, 136104592, 136104592, 3072882514, 3221219472,
            28, 3221219324, 3073011712, 136104592, 137519712, 136104592,
            3073011712, 3221219472, 0, 137458352, 3072892150}}
#6 0xb72656b3 in g_cclosure_marshal_VOID__VOID (closure=0x83172b0,
    return_value=0x0, n_param_values=1, param_values=0xbfffe890,
    invocation_hint=0xbfffe83c, marshal_data=0x0)
    at /build/buildd/glib2.0-2.39.90/./gobject/gmarshal.c:85
        callback = <optimized out>
        cc = 0x83172b0
        data1 = 0x8326260
        data2 = <optimized out>
        __FUNCTION__ = "g_cclosure_marshal_VOID__VOID"
#7 0xb7263a7e in g_closure_invoke (closure=0x83172b0,
    return_value=return_value@entry=0x0, n_param_values=1,
    param_values=param_values@entry=0xbfffe890,
    invocation_hint=invocation_hint@entry=0xbfffe83c)
    at /build/buildd/glib2.0-2.39.90/./gobject/gclosure.c:768
        marshal = 0x80671a0 <g_cclosure_marshal_VOID__VOID@plt>
        marshal_data = 0x0
        in_marshal = 0
        real_closure = 0x83172a0
        __FUNCTION__ = "g_closure_invoke"
#8 0xb7276029 in signal_emit_unlocked_R (node=node@entry=0x81cd400, detail=0,
    instance=0x8326260, emission_return=emission_return@entry=0x0,
    instance_and_params=0xbfffe890)
    at /build/buildd/glib2.0-2.39.90/./gobject/gsignal.c:3551
        tmp = <optimized out>
        handler = 0x8324f40
        accumulator = 0x0
        emission = {next = 0xbfffec10, instance = 0x8326260, ihint = {
            signal_id = 20, detail = 0, run_type = G_SIGNAL_RUN_FIRST},
          state = EMISSION_RUN, chain_type = 4}
        handler_list = 0x8324f40
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0,
              v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0,
              v_double = 0, v_pointer = 0x0}, {v_int = 0, v_uint = 0,
              v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0,
              v_double = 0, v_pointer = 0x0}}}
        signal_id = 20
        max_sequential_handler_number = 1286
        return_value_altered = 1
#9 0xb727d963 in g_signal_emit_valist (instance=instance@entry=0x8326260,
    signal_id=signal_id@entry=20, detail=detail@entry=0,
    var_args=var_args@entry=0xbfffe9cc "\214\275\032\b|\375\004\b̸\004\b\240\005") at /build/buildd/glib2.0-2.39.90/./gobject/gsignal.c:3307
        instance_and_params = 0xbfffe890
        signal_return_type = <optimized out>
        param_values = 0xbfffe8a4
        i = <optimized out>
        n_params = <optimized out>
        __FUNCTION__ = "g_signal_emit_valist"
#10 0xb727dbf3 in g_signal_emit (instance=instance@entry=0x8326260,
    signal_id=20, detail=detail@entry=0)
    at /build/buildd/glib2.0-2.39.90/./gobject/gsignal.c:3363
        var_args = 0xbfffe9cc "\214\275\032\b|\375\004\b̸\004\b\240\005"
#11 0xb7ceb57f in gtk_widget_realize (widget=0x8326260)
    at /build-area/gtk+3.0-3.10.7/./gtk/gtkwidget.c:4994
        priv = 0x83261e0
        region = <optimized out>
        __FUNCTION__ = "gtk_widget_realize"
#12 0x08068982 in nautilus_application_create_desktop_windows (
    application=application@entry=0x81c00c0) at nautilus-application.c:487
        screen = <optimized out>
        window = 0x8326260
        __FUNCTION__ = "nautilus_application_create_desktop_windows"
#13 0x0806a0e0 in nautilus_application_open_desktop (application=0x81c00c0)
    at nautilus-application.c:1394
No locals.
#14 init_desktop (self=0x81c00c0) at nautilus-application.c:1439
        should_show = <optimized out>
#15 nautilus_application_startup (app=0x81c00c0) at nautilus-application.c:1648
        self = 0x81c00c0
        __FUNCTION__ = "nautilus_application_startup"
#16 0xb7265709 in g_cclosure_marshal_VOID__VOIDv (closure=0x81bd3e8,
    return_value=0x0, instance=0x81c00c0, args=0xbfffecbc "(\263\033\b\240",
    marshal_data=0x8069ac0 <nautilus_application_startup>, n_params=0,
    param_types=0x0) at /build/buildd/glib2.0-2.39.90/./gobject/gmarshal.c:115
        cc = 0x81bd3e8
        data1 = 0x81c00c0
        data2 = <optimized out>
        callback = <optimized out>
#17 0xb7262457 in g_type_class_meta_marshalv (closure=0x81bd3e8,
    return_value=0x0, instance=0x81c00c0, args=0xbfffecbc "(\263\033\b\240",
    marshal_data=0x44, n_params=0, param_types=0x0)
    at /build/buildd/glib2.0-2.39.90/./gobject/gclosure.c:988
        real_closure = 0x81bd3d8
        class = <optimized out>
        callback = <optimized out>
        offset = 68
#18 0xb7263cce in _g_closure_invoke_va (closure=closure@entry=0x81bd3e8,
    return_value=return_value@entry=0x0, instance=instance@entry=0x81c00c0,
    args=args@entry=0xbfffecbc "(\263\033\b\240", n_params=0, param_types=0x0)
    at /build/buildd/glib2.0-2.39.90/./gobject/gclosure.c:831
        marshal = 0xb7262410 <g_type_class_meta_marshalv>
        marshal_data = 0x44
        in_marshal = 0
        real_closure = 0x81bd3d8
        __FUNCTION__ = "_g_closure_invoke_va"
#19 0xb727d080 in g_signal_emit_valist (instance=instance@entry=0x81c00c0,
    signal_id=signal_id@entry=6, detail=detail@entry=0,
    var_args=var_args@entry=0xbfffecbc "(\263\033\b\240")
    at /build/buildd/glib2.0-2.39.90/./gobject/gsignal.c:3215
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0,
              v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0,
              v_double = 0, v_pointer = 0x0}, {v_int = 0, v_uint = 0,
              v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0,
              v_double = 0, v_pointer = 0x0}}}
        accumulator = 0x0
        emission = {next = 0x0, instance = 0x81c00c0, ihint = {signal_id = 6,
            detail = 0, run_type = G_SIGNAL_RUN_FIRST}, state = EMISSION_RUN,
          chain_type = 136032536}
        instance_type = <optimized out>
        emission_return = {g_type = 0, data = {{v_int = 0, v_uint = 0,
              v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0,
              v_double = 0, v_pointer = 0x0}, {v_int = 0, v_uint = 0,
              v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0,
              v_double = 0, v_pointer = 0x0}}}
        rtype = 4
        static_scope = 0
        fastpath_handler = <optimized out>
        closure = 0x81bd3e8
        run_type = <optimized out>
        l = <optimized out>
        fastpath = <optimized out>
        instance_and_params = <optimized out>
        signal_return_type = <optimized out>
        param_values = <optimized out>
        i = <optimized out>
        n_params = <optimized out>
        __FUNCTION__ = "g_signal_emit_valist"
#20 0xb727dbf3 in g_signal_emit (instance=instance@entry=0x81c00c0,
    signal_id=6, detail=detail@entry=0)
    at /build/buildd/glib2.0-2.39.90/./gobject/gsignal.c:3363
        var_args = 0xbfffecbc "(\263\033\b\240"
#21 0xb734b89a in g_application_register (
    application=application@entry=0x81c00c0,
    cancellable=cancellable@entry=0x0, error=error@entry=0xbfffed44)
    at /build/buildd/glib2.0-2.39.90/./gio/gapplication.c:1807
        __FUNCTION__ = "g_application_register"
#22 0x080695f0 in nautilus_application_local_command_line (
    application=0x81c00c0, arguments=0xbfffef14, exit_status=0xbfffef18)
    at nautilus-application.c:1305
        perform_self_check = 0
        version = 0
        browser = 0
        kill_shell = 0
        open_new_window = 0
        no_default_window = 0
        select_uris = 0
        remaining = 0x0
        self = 0x81c00c0
        options = {{long_name = 0x8145a7d "check", short_name = 99 'c',
            flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0xbfffed24,
            description = 0x81452d8 "Perform a quick set of self-check tests.", arg_description = 0x0}, {long_name = 0x8145a83 "browser",
            short_name = 0 '\000', flags = 1, arg = G_OPTION_ARG_NONE,
            arg_data = 0xbfffed2c, description = 0x0, arg_description = 0x0}, {
            long_name = 0x8145a8b "version", short_name = 0 '\000', flags = 0,
            arg = G_OPTION_ARG_NONE, arg_data = 0xbfffed28,
            description = 0x8145304 "Show the version of the program.",
            arg_description = 0x0}, {long_name = 0x816104d "geometry",
            short_name = 103 'g', flags = 0, arg = G_OPTION_ARG_STRING,
            arg_data = 0x81c0024,
            description = 0x8145328 "Create the initial window with the given geometry.", arg_description = 0x8145a93 "GEOMETRY"}, {
            long_name = 0x8145a72 "new-window", short_name = 119 'w',
            flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0xbfffed34,
            description = 0x814535c "Always open a new window for browsing specified URIs", arg_description = 0x0}, {
            long_name = 0x8145a9c "no-default-window", short_name = 110 'n',
            flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0xbfffed38,
            description = 0x8145394 "Only create windows for explicitly specified URIs.", arg_description = 0x0}, {long_name = 0x8145aae "no-desktop",
            short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE,
            arg_data = 0x81c001c,
            description = 0x81453c8 "Never manage the desktop (ignore the GSettings preference).", arg_description = 0x0}, {
            long_name = 0x8145ab9 "force-desktop", short_name = 0 '\000',
            flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x81c0020,
            description = 0x8145404 "Always manage the desktop (ignore the GSettings preference).", arg_description = 0x0}, {long_name = 0x8145ac7 "quit",
            short_name = 113 'q', flags = 0, arg = G_OPTION_ARG_NONE,
            arg_data = 0xbfffed30, description = 0x8145acc "Quit Nautilus.",
            arg_description = 0x0}, {long_name = 0x814ef96 "select",
            short_name = 115 's', flags = 0, arg = G_OPTION_ARG_NONE,
            arg_data = 0xbfffed3c,
            description = 0x8145444 "Select specified URI in parent folder.",
            arg_description = 0x0}, {long_name = 0x8154e9d "",
            short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_STRING_ARRAY,
            arg_data = 0xbfffed40, description = 0x0,
            arg_description = 0x8145adb "[URI...]"}, {long_name = 0x0,
            short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE,
            arg_data = 0x0, description = 0x0, arg_description = 0x0}}
        context = 0x81c1318
        error = 0x0
        argc = 1
        argv = 0x81c0960
        __FUNCTION__ = "nautilus_application_local_command_line"
        files = <optimized out>
        idx = <optimized out>
        len = <optimized out>
#23 0xb734c3fd in g_application_run (application=0x81c00c0, argc=argc@entry=1,
    argv=argv@entry=0xbfffeff4)
    at /build/buildd/glib2.0-2.39.90/./gio/gapplication.c:2083
        arguments = 0x81c0960
        status = 0
        __FUNCTION__ = "g_application_run"
#24 0x08067e2b in main (argc=1, argv=0xbfffeff4) at nautilus-main.c:104
        retval = <optimized out>
        application = 0x81c00c0"

Related branches

Sebastien Bacher (seb128) wrote :

Hey Marco, that seems to be due to one of your changes, could you have a look to the issue?

Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Low
status: New → Won't Fix
status: Won't Fix → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

Thank Marco, I've added the bug reference to the changelog and commited/sponsored

Changed in nautilus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu7

---------------
nautilus (1:3.10.1-0ubuntu7) trusty; urgency=medium

  * debian/patches/19_unity_open_location_xid.patch:
    - don't try to call functions on null objects (lp: #1285895)
    - delay dbus registration until we don't have a bus
 -- Marco Trevisan (Trevino) <mail@3v1n0.net> Fri, 28 Feb 2014 10:43:25 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers