[Gutsy] nautilus crash - caused when changing folder

Bug #127803 reported by Dave Walker on 2007-07-23
This bug report is a duplicate of:  Bug #127826: nautilus crash opening directory. Edit Remove
4
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Unknown
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

When nautilus is launched the initial folder opens without issue, but crashes directly after changing to another location.

Version: nautilus/gutsy uptodate 1:2.19.5-0ubuntu1

$ nautilus -q
$ nautilus .
seahorse nautilus module initialized
Initializing gnome-mount extension
** Message: Failed to write /home/dave/img.php?image=36063__am2_2464_577lo.jpg to thumbnail pixbuf loader: Unrecognised image file format
** Message: Failed to write /home/dave/img.php?image=36063__am2_2464_577lo.jpg to thumbnail pixbuf loader: Unrecognised image file format

** ERROR **: file nautilus-navigation-window.c: line 834 (activate_nth_short_list_item): assertion failed: (index < g_list_length (window->details->short_list_viewers))
aborting...
Aborted (core dumped)

Dave Walker (davewalker) wrote :
Dave Walker (davewalker) wrote :

Actually i am not satisfied that this is caused due to the image problem, as with this file removed the problem still exists.

$ cat nautilus-debug-log.txt
===== BEGIN MILESTONES =====
0x8187880 2007/07/23 20:53:14.5888 (GLog): file nautilus-navigation-window.c: line 834 (activate_nth_short_list_item): assertion failed: (index < g_list_length (window->details->short_list_viewers))
0x8187880 2007/07/23 20:53:14.5889 (USER): debug log dumped due to signal 5
0x8187880 2007/07/23 20:53:14.5891 (USER): debug log dumped due to signal 6
===== END MILESTONES =====
===== BEGIN RING BUFFER =====
0x8187880 2007/07/23 20:52:40.1739 (USER): window 0x8245028 open location: old="(none)", new="x-nautilus-desktop:"
0x8187880 2007/07/23 20:52:40.2818 (USER): create new navigation window=0x822b140
0x8187880 2007/07/23 20:52:40.2818 (USER): window 0x822b140 open location: old="(none)", new="file:///home/dave"
0x8187880 2007/07/23 20:52:41.2001 (USER): finished loading window 0x8245028: x-nautilus-desktop:
0x8187880 2007/07/23 20:52:41.3955 (USER): change view of window 0x822b140: "file:///home/dave" to "OAFIID:Nautilus_File_Manager_Icon_View"
0x8187880 2007/07/23 20:52:41.5416 (USER): finished loading window 0x822b140: file:///home/dave
0x8187880 2007/07/23 20:53:11.8165 (USER): create new navigation window=0x822b410
0x8187880 2007/07/23 20:53:11.8165 (USER): window 0x822b410 open location: old="(none)", new="file:///home/dave/"
0x8187880 2007/07/23 20:53:12.2062 (USER): change view of window 0x822b410: "file:///home/dave/" to "OAFIID:Nautilus_File_Manager_Icon_View"
0x8187880 2007/07/23 20:53:12.5439 (USER): finished loading window 0x822b410: file:///home/dave/
0x8187880 2007/07/23 20:53:14.3273 (USER): selection changed in window 0x822b410
        file:///home/dave/bin
0x8187880 2007/07/23 20:53:14.5255 (USER): fm_directory_view_activate_files window=0x822b410
        file:///home/dave/bin
0x8187880 2007/07/23 20:53:14.5259 (USER): directory view open_location window=0x822b410: file:///home/dave/bin
0x8187880 2007/07/23 20:53:14.5259 (USER): window 0x822b410 open location: old="file:///home/dave/", new="file:///home/dave/bin"
0x8187880 2007/07/23 20:53:14.5259 (USER): finished loading window 0x822b410: file:///home/dave/
0x8187880 2007/07/23 20:53:14.5888 (GLog): file nautilus-navigation-window.c: line 834 (activate_nth_short_list_item): assertion failed: (index < g_list_length (window->details->short_list_viewers))
0x8187880 2007/07/23 20:53:14.5889 (USER): debug log dumped due to signal 5
0x8187880 2007/07/23 20:53:14.5891 (USER): debug log dumped due to signal 6
===== END RING BUFFER =====

Jonh Wendell (wendell) wrote :

Exactly same error here, but it happens when i change the folder inside nautilus...

Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Confirmed

Agreed, I have changed the title and description to reflect.

description: updated
Dave Walker (davewalker) wrote :

Latest version in repo seems to have been patched: nautilus 1:2.19.5-0ubuntu1

This bug can now be closed.

Dave Walker (davewalker) wrote :

1:2.19.5-0ubuntu2 rather

Sebastien Bacher (seb128) wrote :

duplicate of bug #127826

Changed in nautilus:
importance: Undecided → Medium
status: Confirmed → Fix Released
Changed in nautilus:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.