Nautilus doesn't remember setting for showing hidden files correctly when org.gtk.Settings.FileChooser show-hidden is true

Bug #1247221 reported by Johannes Betz on 2013-11-01
158
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Description: Ubuntu 13.10
Release: 13.10
nautilus: 1:3.8.2-0ubuntu2

The default setting of not showing hidden files can be changed with strg+h. After all windows are closed nautilus remembers to show hidden files again when opening a new window. If strg+h is pressed again to hide hidden files nautilus does so but still keeps showing hidden files in new windows. When changed via gui the setting is remembered correctly.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1247221/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → nautilus (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Leon (leonbo) wrote :

I belive this fixed it for me: gsettings set org.gtk.Settings.FileChooser show-hidden false

John Doe (johnd03) wrote :

Same issue still exists in 14.04 Beta1

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
summary: Nautilus doesn't remember setting for showing hidden files correctly
+ when org.gtk.Settings.FileChooser show-hidden is true
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
John Doe (johnd03) wrote :

seems to be fixed. thanks.

John Doe (johnd03) wrote :

Hi.

Well this Bug appeared again. "show hidden files" is checked when i open nautilus. When I turn it off and close/open nautilus again, its checked again and of course hidden files aren shown again. Please fix this. Thank you in advanced.

kind regards

JD

Timo Palomaa (timppis) wrote :

@johnd03: I don't quite understand your earlier comment ("seems to be fixed"), the status on the gnomebugs tracker is still "unconfirmed" so certainly not fixed on purpose at least.

John Doe (johnd03) wrote :

@timppis: The Issue dissappeared. No hidden files were shown. But since some updates I can see the hidden files again.

Eric Ongerth (ericongerth) wrote :

My similar bug report on 14.04 got linked to this one. But mine is not identical.

The difference: on this report the original poster writes, "When changed via gui the setting is remembered correctly." In my case that is not true. No matter whether I use Ctrl+H or View > Show Hidden Files, the setting is never remembered after I close nautilus.

If I'm remembering correctly, this used to be remembered. In 14.04 the *preference* for it is remembered (in Edit > Preferences) but the current value of the setting is not remembered.

Something that should be added to the symptoms in this bug report: it's not just that the setting is not remembered; it's also that the preference (In Edit > Preferences > Views ) is apparently set to Show Hidden and Backup Files by default when you install or upgrade. That probably was not the intended behavior.

As of now, the solution has fixed the issue. Thanks.

Eric Ongerth (ericongerth) wrote :

Technically, the title of this bug report is a little misleading.

It says "Nautilus doesn't remember setting for showing hidden files correctly when org.gtk.Settings.FileChooser show-hidden is true".

But nautilus also doesn't remember the setting when the preference is false. So the title of this discussion is giving the false impression that this problem is only happening in one of those two cases, when actually it is both.

...Or else I have a distinctly different bug.

full name (register3) wrote :

Not surprisingly, this bug made it to 14.04 final release. Congratulations, Ubuntu team.

Sebastien Bacher (seb128) wrote :

@Eric: your issue seems a different one indeed (can't confirm it either, does it happen in a guest session?)

Eric Ongerth (ericongerth) wrote :

@Sebastien: I tried a guest session just now.

1. This was my first time using a guest session since installing 14.04.

2. On this first opening of the guest session, the nautilus preference was found to be unchecked, so it did not show hidden files.

3. Leaving the preference unchanged, I used Ctrl+H to show hidden files, and observed that some files were displayed.

4. I closed nautilus and then opened it again. Hidden files were not shown. I repeated this sequence again to be certain.

5. I changed the preference to Show Hidden Files (checked), and observed that hidden files were displayed.

6. I closed nautilus and opened it again. Hidden files were shown; the preference was respected as before.

7. Leaving the preference unchanged, I used Ctrl+H to hide hidden files, and observed that hidden files were no longer shown.

8. I closed nautilus then opened it again. The setting was not remembered, and only the preference was respected.

Conclusion: in a guest session, it appears that only the preference determines the behavior when nautilus is opened. Once it is already open, the temporary setting can be changed via Ctrl+H (or View > Show Hidden Files), but it will be forgotten when nautilus is closed.

This is the same behavior as in my regular user session. The only difference is that for my regular user, the preference defaulted to Show Hidden the first time I used nautilus after installing 14.04, while in a guest session the default was NOT to Show Hidden.

Sorry for the length of my post : it is difficult to be exact about these things in a short post.

John Doe (johnd03) wrote :

any news about this? It's really annoying to see the hidden files if you dont want to.

regards

Eric Ongerth (ericongerth) wrote :

John Doe, if you have not done so already, uncheck "Show hidden and backup files" in nautilus' Edit > Preferences > Views. At least that will change your default so you won't be reverting to showing hidden every time you open a nautilus window. It won't remember your use of View > Show Hidden Files (or Ctrl+H) from one use to another, but at least your default will be what you want.

John Doe (johnd03) wrote :

@ericongerth: Thanks. SInce its driving me crazy. :)

I'm asking myself why this made up into the Final Version. :(

arkmundi (rkerver) wrote :

So I'm one of those kinda lazy just want to go from LTS to LTS upgrades and have everything work guys - just did the upgrade to 14.04. And am experiencing this issue. And see no way to edit Nautilus preferences so default behaviour is keep "hidden files" hidden. The edit->preferences menu item is hidden when it should be visible and the "hidden files" are visible when they should not be. Was this a joke?

Cris Grada (cristiangrada) wrote :

I can confirm the same problem using Gnome 3.14.1; Nautilus doesn't remember hidden files toggle, nor clicking the button in preferences menu, nor the Ctrl+H; it works since session is open, but when closing and reopen it the option is on again.

Cris Grada (cristiangrada) wrote :

I tried this (using dconf-editor in Gnome 3.14.1):
Terminal → dconf-editor → org → gtk → settings → file chooser
The Show hidden option must be UNCHECKED and BE CONFIRMED at the bottom page button -> Set to default
This worked. Please see the #4 comment on this page.

Rui Neto (rnetocombr) wrote :

How to reproduce the bug:

1. Open Nautilus: Everything normal, hidden files are hidden.
2. In Nautilus press CTRL + H: Hidden files are shown.
3. Close Nautilus and open again: hidden files are back hidden.
4. Open Gedit;
5. In gedit try to open file. In the file chooser dialog, press ctrl + h. Hidden files will be shown, to be choosen. Close Gedit without choosing a file.
6. Open nautilus. Hidden files are shown again.

Resume: when showing hidden files in the file chooser dialog, this preference sticks when re-opening nautilus.

PS: You can revert to the default behavior in nautilus:

Edit -> Preferences -> Uncheck "Show hidden files"

In UX terms, its counterintuitive.

Rui Neto (rnetocombr) wrote :

Gnome developers says it is fixed in 3.18. Can we backport the fix or upgrade the version ? ( https://bugzilla.gnome.org/show_bug.cgi?id=710093#c12 ).

Changed in nautilus:
status: New → Fix Released
Rui Neto (rnetocombr) wrote :

To clarify: its not fixed. Ubuntu 16.04 uses nautilus 3.14.3. The bug is fixed in latest stable version, 3.20.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.