Emblems get lost on file overwrite

Bug #120775 reported by xtknight on 2007-06-17
2
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Steps to reproduce:

Create a file in gedit ("file1"). Save it to the desktop. Right click on "file1", goto properties, and set any emblems you want. Now, add a few letters to the file in gedit, and save again. All emblems on "file1" are gone. If this is "by design" it shouldn't be!

Paul Dufresne (paulduf) wrote :

Setting to nautilus (Gnome file manager).

I was able to repeat this bug on Gutsy with dpkg -l nautilus:
ii nautilus 1:2.19.4-0ubun file manager and graphical shell for GNOME
[I choosed 'favorite' emblems.)

So I am setting to confirmed.

Paul Dufresne (paulduf) wrote :

I tried to find duplicates on Ubuntu, or if it was already reported upstream on http://bugzilla.gnome.org/browse.cgi?product=nautilus but did not found that.

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Invalid
Paul Dufresne (paulduf) wrote :

Well, Sebastien, you are much more qualified than me, but I am afraid I disagree that this bug is a duplicate of bug #84262.
In the broad sense, yes, position and emblems information seems lost when the file is overwritten.

This bug exist not only on desktop, but others nautilus windows.
Which is not the case of bug #84262.

I doubt that fixing position of the icon we'll fix it's emblems, although I agree it could.
Prefer to keep these 2 bugs separated however, because I won't believe until I see that fixing position of icon will fix emblem.

Changed in nautilus:
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

Don't overwrite the maintainer changes, better to argue if you disagree with a decision. The bugs are due to the same things, gedit does it saving by using a new file and renaming and nautilus detects it as something new

Changed in nautilus:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers