Right click "Set as Wallpaper" creates duplicates of source file for files stored in ~/Pictures

Bug #1181601 reported by bear7 on 2013-05-18
76
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Wishlist
nautilus (Ubuntu)
Low
Unassigned

Bug Description

In Ubuntu 13.04 (Unity) from the right click menu (on the picture file) when "set as Wallpaper" is selected wallpaper is changed however source file is copied (not moved) into ~/Pictures/Wallpapers which btw is also created. Original file is still located in original location (for example on the desktop) - so, file is really duplicated.

If source file is already located inside ~/Picutres/Wallpapers folder, file is also duplicated: new file has "(copy)" added to his name (ie.: name_of_file (copy).jpg).

Workaround for this is to open file in Eye of GNOME Image Viewer and choose set as wallpaper from the right click menu which works fine.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: nautilus 1:3.6.3-0ubuntu16
ProcVersionSignature: Ubuntu 3.8.0-20.31-generic 3.8.11
Uname: Linux 3.8.0-20-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sat May 18 19:41:01 2013
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'800x550+49+24'"
InstallationDate: Installed on 2013-04-26 (22 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

bear7 (bear7) wrote :
description: updated
bear7 (bear7) on 2013-05-18
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
maxx (maxx-krakoa) wrote :
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Federico Vera (fedevera) wrote :

This bug also affects 13.10 and 14.04

Jaime Marques (jimmy93) wrote :

same on ubuntu 14.04

tags: added: ubuntu-desktop-trusty
tags: removed: ubuntu-desktop-trusty
Changed in nautilus:
status: New → Invalid
Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Wishlist
status: Unknown → Confirmed

This bug still affects Ubuntu 17.04, Gnome Shell 3.24.

znorris (znorris) wrote :

This still impacts Uhuntu 18.04 with Gnome 3.28.1

Goncalves-st (goncalves-st) wrote :

Interesting enough, we're in 2020, ubuntu 20.04 and this bug is still present. no shortcuts setting wallpaper with right click lads. You need to go the hard way

Sebastien Bacher (seb128) wrote :

That's not really a bug by itself, copying the file ensure you still have a wallpaper if you clean your download directory or remove the removal media the file was on

bear7 (bear7) wrote :

In second paragraph you’ll find this:

If source file is already located inside ~/Picutres/Wallpapers folder, file is also duplicated: new file has "(copy)" added to his name (ie.: name_of_file (copy).jpg).

That’s a bug. Otherwise why would I need two copies of the same file?

Sebastien Bacher (seb128) wrote :

Right, that's a bug, but not what that ticket title nor first point is about though. That's the issue when you conflicts several problems in one report, it gets difficult to know what the issue is about and get it properly prioritized

bear7 (bear7) wrote :

Ticket tile explains exactly whet the issue is. There is only one issue documented in second paragraph, not several. First paragraph only gives an explanation of what is occurring for better context. It sounds now you haven’t read it all or didn’t understand in first place, and now you are trying come up with some excuse. No need for it. There is a bug, period.

Sebastien Bacher (seb128) wrote :

I've updated the title now to correctly reflect the issue

summary: - Right click "Set as Wallpaper" creates duplicates of source file
+ Right click "Set as Wallpaper" creates duplicates of source file for
+ files stored in ~/Pictures
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.