Ubuntu

Clicking on Nautilus’ launcher icon opens new window instead of restoring the minimized one when browsing external drives/locations

Reported by Steffen Krumbholz on 2013-04-19
714
This bug affects 145 people
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
Medium
Unassigned
nautilus (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Sometimes left clicking the nautilus launcher icon doesn't bring up a minimized nautilus window. Instead of restoring the window a new instance of nautilus is showing up.

Steps to reproduce:

1. Open a nautilus window by clicking on the launcher icon.
2. Navigate to a symlinked directory whose target is located on a different harddrive (for example: a symlink to a folder on a sd-card).
3. Minimize the nautilus window.
4. Try to bring up that window again by clicking the launcher icon.

What happens:

1. A new instance (window) of nautilus is opened.
2. There's no obvious way to access the first window again. The only way is ALT+TAB.

What schould happen:

If a nautilus window is already open and minimized clicking the launcher icon should bring up that window. This was the behavior of nautilus windows in Ubuntu 12.10 (quantal).

Ubuntu 13.04 Raring Ringtail (development branch)
nautilus 3.6.3-0ubuntu16
unity 7.0.0daily13.04.18~13.04-0ubuntu1

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: nautilus 1:3.6.3-0ubuntu16
ProcVersionSignature: Ubuntu 3.8.0-18.28-generic 3.8.6
Uname: Linux 3.8.0-18-generic i686
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
Date: Fri Apr 19 11:33:13 2013
EcryptfsInUse: Yes
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'geometry' b"'814x493+136+38'"
 b'org.gnome.nautilus.window-state' b'sidebar-width' b'182'
InstallationDate: Installed on 2011-07-23 (635 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
MarkForUpload: True
SourcePackage: nautilus
UpgradeStatus: Upgraded to raring on 2013-04-14 (4 days ago)

Steffen Krumbholz (skrumbholz) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, is that under unity? Do you have specific steps to reproduce?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Steffen Krumbholz (skrumbholz) wrote :

Sebastien, thank you for your response. Please read my bug report carefully. :) I think I provided the informations already.

Sebastien Bacher (seb128) wrote :

ok, fair enough ;-)

Changed in nautilus (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
aguzers (aguzers) wrote :

kinda annoying,
i dual boot ubuntu 13.04 with win7 , nautilus attempt to open new window when i click the nautilus (nautilus in minimize mode), it happen when i browse win7 data drive but if i acces my home folder (or ubuntu drive) n minimize it, this problem not appear.
sorry about my english :D

Mario (mario-mds) wrote :

Yes. The same happens to me: Any folder different from /home/myuser does that.

By the way: Can this new version of Nautilus show the status bar (in the lower right area, right under the list of files)?

Also: Can I set the 'tree view' in the folders located to the left?

Thanks in advance guys.

Steffen Krumbholz (skrumbholz) wrote :

There's a workaround for this issue. Hover over the Nautilus launcher icon and scroll the mouse wheel. :)

Mario (mario-mds) wrote :

Too late now. Using Thunar. Has no bugs (at least no Nautilu's ones), it's fast, has tree-view, shows previews of photos and videos...
Who needs Nautilus?

benjamin villanueva (itagomo) wrote :

thanks for the tip skrumbholz . =)

Leonardo Donelli (learts92) wrote :

I tried to give a look into the problem, even though i'm not expert in unity internals, GTK, desktop files, ecc. There is a big chaos. There is a transition going on between using nautilus.desktop and nautilus-home.desktop (apparently Unity used to use nautilus-home.desktop but is converging to the "standard" nautilus.desktop), as a result there are various .desktop files. There are also .desktop files for the mounted external drives (and launcher icons for external drives have strange / incosistent behaviour, by the way: when clicking on them the nautilus window that opens is 'assigned' to the nautilus launcher [the small arrow is on that] but the drive launcher still controls it: it can bring the window on foreground if it isn't).
On top of that, nautilus already has functions to determine if a specific location is already open, and in that case it avoids opening a new window for it (unless you use the --new-window parameter).

AlmogBaku (almog-baku) wrote :

it happend to me too..
There is no any solution yet?

AlmogBaku (almog-baku) wrote :

Also, when two windows is opened, it works as excepted

Edwin Pujols (edwinpm5) wrote :

Just now I noticed that with directories mounted on /media (via a direct invokation of udisks in a script) nautilus works as expected. Well, at least for me, at least right now.

Bruce (brunces) wrote :

This bug also affects me when I have a Nautilus window of my external drive minimized. If I click the Nautilus icon, it simply opens a new window, instead of showing that minimized one. I'm not quite sure, but it seems to happen frequently with mounted devices.

Shukhrat Mukimov (mukimov) wrote :

I can confirm, that this bug can be reproduced in latest 13.04. Nautilus opens second instance, instead to recover the old one. It's always reproduced for me.

Vahid Mardani (vahid-mardani) wrote :

I have the same problem, in 13.04. i decided to use another file manager.until debug

Changed in bamf (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in nautilus (Ubuntu):
importance: Low → Medium
Adolfo Jayme (fitoschido) wrote :

I can no longer reproduce this bug in Saucy, the icon now works as expected. Can anyone else confirm this?

On 9/11/2013 5:44 AM, Adolfo Jayme Barrientos wrote:
> I can no longer reproduce this bug in Saucy, the icon now works as
> expected. Can anyone else confirm this?
>
Can't confirm, see the same in updated saucy,
To refresh -
Open nautilus, browse to any dir. mounted in /media/<username>/,then
minimize nautilus.
Clicking on the launcher icon opens a new nautilus window at user Home
instead of minimized window

In my saucy install this is still present. Just to confirm it is present in saucy.

summary: - Nautilus opens new window instead of restoring the minimized window
+ Clicking on Nautilus’ launcher icon opens new window instead of
+ restoring the minimized one when browsing external drives/locations
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Hey, all. I have a workaround on this. Try this. (Feedback, Please. I may lost some step.)
1. Use fstab to mount your (external) disk into another directory on /media . For example /media/disk
   a. Please use auto, (if ntfs) ntfs-3g as mount option.
2. Create a link of /media/disk and give it a name based on your username. Put this link on the same directory (e.g. /media/)
3. Well, try it now.
Well, I don't know that the bug I reported already exist.

This bug exists only if you pin Nautilus to panel.

Michal Grňo (michal-grno) wrote :

I noticed this bug *after* the update to Saucy.

Кирилл (kirill-myxa) wrote :

I noticed that if open at least 2 tabs in window (even if both tabs show contents of an external hard drive) - it will open and minimized as it should.
(Ubuntu 13.10)

Ricardo Graça (devius) wrote :

Actually there is no need to minimize the original Nautilus window to reproduce this bug. All it takes is the Nautilus window loosing focus, e.g. when changing to another application and then attempting to get back to the Nautilus window showing an external drive.

Adam Niedling (krychek) on 2013-10-24
tags: added: saucy
Michal Grňo (michal-grno) wrote :

Recently I've found that this bug also affects process windows while copying from an external drive - those windows cannot be accessed by clicking on nautilus' icon. Sometimes it gets focus when I click on external drive icon, sometimes it doesn't. Strange.

Vahid Mardani (vahid-mardani) wrote :

The same problem always happens to me. on 13.04 and after upgrade to 13.10. so always i have two nautilus windows. its hurt me.

Sebastien Bacher (seb128) wrote :

Hey Marco, you worked on similar issues with the nautilus copy dialog in the past, do you want to have a look to this one?

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
EliCoten (launchpad-elicoten) wrote :

I'm using 13.10. It seems to be somewhat related to this: http://askubuntu.com/q/235805/38137

If you click on the Hard Drive launcher icon, a folder window appears but the indicators show that it is a file window. If you then minimize this window, it appears to go to the "Files" launcher, but actually the correct way to restore it is to click on the Hard Drive launcher icon again.

This is ok (ok, perhaps a little confusing for the user - the indicator should really point to the Hard Drive launcher not the Files launcher when such a window is open) provided that the hard drive icon remains docked to the launcher. The real problem comes when you undock the Hard Drive/Partition's icon from the launcher - then you have the same behaviour with no reasonable alternative.

I hope this explanation makes sense.

I can confirm this bug is present also in Ubuntu 14.04 64 bit

tags: added: amd64 trusty

I have 3 other partitions apart from Ubuntu 14.04 one, one of which is set in fstab to be automatically mounted at startup (and not by gvfsd). I've noticed the behavior mentioned in this bug applies for the other partitions, but not for this one. Maybe this info could be useful. Here is the relative fstab line:

UUID=4031F06913658C89 /mnt/DATI auto nosuid,nodev,nofail,x-gvfs-show 0 0

Changed in unity (Ubuntu):
importance: Medium → High
tags: added: ubuntu-desktop-trusty
removed: trusty
Boza (nemanja-boki92) wrote :

This bug exists in 14.04 (64 bit).
If I UNPIN nautilus from Launcher, it works like it should work.

And now.. In 13.10 workaround was to hover with mouse and scroll. But now that not possible for unfocused windows. Fkkk.

Adolfo Jayme (fitoschido) wrote :

@Boza: See bug 1098578, that behavior is coming back as an option.

Adolfo Jayme (fitoschido) wrote :

(Sorry, I meant bug 1288957.)

Luigi R. (xluigi84) wrote :

I can confirm what reported by EliCoten, If we click on the drive icon we get the last window minimized although there is no pointer on it.

tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers