Unable to restore trash if the containing directory is removed

Bug #1152706 reported by Redsandro on 2013-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

When you delete something, it goes into trash.
.Trash-$UID/files/TrashedFile.ext
.Trash-$UID/info/TrashedFile.ext.trashinfo

The trashinfo contains the path relative to .Trash-$UID's parent directory that is the location to which the trashed file or directory should be restored.

Imagine accidentally trashing 1000 files, and at some point rmdir the containing directory before you realize you need to restore the trash.

In Ubuntu 12.04, no problem, the .trashinfo path would be created when restoring the trash if it didn't exist.
In Ubuntu 12.10, you get 1000 popups saying "There was an error getting information about the destination. Details: Error when getting information for file '/mountpoint/path/to/file': No such file or directory."

For every popup, you can manually do a mkdir -p '/mountpoint/path/to/file', hit "RETRY" and it will work.

Something has changed in the past 11 months that SERIOUSLY cripples the handling of trash.

I am not sure this bug is in the right place, or that something else handles the trash for Nautilus. Nemo, fork of Nautilus, has the same problem. If not filed correctly, please think with me where to file this in the right place, because it's pretty important.

Redsandro (redsandro) wrote :

Correction: I don't know if 12.04 had that problem. I just remembered I had Lubuntu, and when I try pcmanfm now (just installed on 12.10), it does NOT have this trash problem.

So work-around for restoring trash when parent-directories are also removed: Use PcManFM for handling the trash.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Redsandro (redsandro) wrote :

Thanks for providing me with the correct bugtracker.
Here's the link to the bugreport: https://bugzilla.gnome.org/show_bug.cgi?id=695460

Changed in nautilus (Ubuntu):
status: New → Confirmed
status: Confirmed → New
Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
status: New → Fix Released
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu14

---------------
nautilus (1:3.6.3-0ubuntu14) raring; urgency=low

  * debian/patches/git_enable_copy_from_recent.patch:
    - Allow copying from Recent
  * debian/patches/git_restore_from_missing_directories.patch:
    - Allow restoring deleted files when the containing directories
      no longer exist (LP: #1152706)
 -- Jeremy Bicha <email address hidden> Thu, 04 Apr 2013 19:48:10 -0400

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.