Update to nautilus 3.8

Bug #1130746 reported by Jeremy Bicha on 2013-02-20
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

I've remerged our Nautilus 3.8 packaging with the latest Ubuntu packaging and pushed to the attached branch. Two patches need reworking:

* 19_unity_open_location_xid.patch
* 16_unity_new_documents.patch: The Raring "fix" took advantage of a bug that has since been fixed https://git.gnome.org/browse/nautilus/commit/?id=9323dd

And we may need Compiz to handle drawing the wallpaper first (LP: #1159430)

Original bug report
===================
I've built nautilus 3.7.90 on raring and things seem to work fine. This required reverting 7 commits for GTK 3.6, 1 commit that needed gnome-disks 3.7.90 (and udisks 2.1.90), and 1 commit that needed gsettings-desktop-schemas. It sounds like the Desktop Team is still considering updating GTK to 3.8 for raring which would reduce the number of patches needed.

GNOME 3.7 is now feature frozen so the risk going forward of disruptive changes should be minimal. One additional change is that as of yesterday, nautilus master no longer handles drawing the desktop wallpaper but we can revert those changes for the benefit of metacity users (Compiz/Unity currently doesn't handle drawing the wallpaper either). One regression is that gnome-shell 3.7 changed the search provider API so we need a patch to get nautilus 3.7 to work with the earlier API.

There are several improvements in the new nautilus, some of which are fairly tricky to attempt backporting.
- There is now optional tree navigation in the list view
- Nautilus supports a --select commandline option to select a given URI (this sounds like something the Unity files lens needs for its Right click >Show in Folder option)
- Full list at http://git.gnome.org/browse/nautilus/tree/NEWS

Related branches

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed

- Nautilus supports a --select commandline option to select a given URI (this sounds like something the Unity files lens needs for its Right click >Show in Folder option)

FYI, nautilus-file-lens does not need that, since the same thing can actually be done by launching nautilus /path/to/any/file_to_select and that's already done in trunk.

theghost (theghost) wrote :

One of the main benefits of a newer nautilus would be the reactivation of recursive file search, which is broken in 3.6 and is a kind of regression compared to older Ubuntu versions. In short this regression would not be very user friendly.

How is the status on this request ? Is there a chance to see nautilus 3.7 in Raring without PPAs ?

Sebastien Bacher (seb128) wrote :

> How is the status on this request ? Is there a chance to see nautilus 3.7 in Raring without PPAs ?

not really, the new GTK still has regressions and didn't made it to raring, it's a bit late at this point to get those fixed, land it and get proper testing/fixing of new issues before release. (the new GTK is needed by the new nautilus).

Even if we get GTK in we would need to update/rewrite some of our nautilus patches, test the new version, ask for a feature freeze exception, land it and deal with new bugs it will bring ...

it's wiser to wait next cycle at this point

Jeremy Bicha (jbicha) on 2013-06-05
description: updated
Jeremy Bicha (jbicha) on 2013-06-10
summary: - Update to nautilus 3.7.90
+ Update to nautilus 3.8
tags: added: saucy upgrade-software-version
removed: patch
Sebastien Bacher (seb128) wrote :

Ok, I tried that today and ran into bug #1159430 ... I added a comment there. I'm going to have a look at reverting the background changes for the first upload and at getting the template working before upload

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.8.2-0ubuntu1

---------------
nautilus (1:3.8.2-0ubuntu1) saucy; urgency=low

  [ Sebastien Bacher ]
  * Bring the 3.8 update work from the gnome3 ppa to the distribution vcs
  * debian/patches/16_unity_new_documents.patch:
    - updated to work on 3.8 (by adding a revert of the commit that broke it)
  * debian/patches/ubuntu_revert_no_wallpaper.patch:
    - revert upstream changes to use a rgba desktop view, until the other
      components are ready for that change, see lp #1159430 for details
  * debian/patches/ubuntu_sync_background_to_accountsservice.patch:
    - restore that dropped patch since we keep display the wallpaper there

  [ Iain Lane ]
  * debian/patches/disconnect-extra-location-widgets.patch:
    - updated for the new nautilus codebase

  [ Jeremy Bicha ]
  * New upstream release (LP: #1130746)
    - Share the show-hidden-files setting with the GTK file chooser
      (LP: #1039014)
    - Limit folder size and content count to a single filesystem (LP: #585472)
  * debian/nautilus.install:
    - Shell search provider doesn't need a separate library any more
  * Drop git patches
  * Refreshed patches

  [ Robert Ancell ]
  * debian/control:
    - Bump build-depends on libglib2.0-dev

  [ Rico Tzschichholz ]
  * New upstream release
  * debian/control:
    - Bump build-depends on libgtk-3-dev (>= 3.7.7)
  * debian/patches:
    - 09_no-initial-fade.patch:
    - 10_sync_background_to_accountsservice.patch:
      + Dropped, Nautilus doesn't draw the background itself any more
  * Refreshed patches

  [ Tim Lunn ]
  * Add build-dep on gsettings-desktop-schemas

  [ Marco Trevisan (Treviño) ]
  * debian/patches:
    - 19_unity_open_location_xid.patch: updated to apply properly
 -- Sebastien Bacher <email address hidden> Fri, 21 Jun 2013 17:10:06 +0200

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers