Add a context menu entry to create a new blank file

Bug #1113648 reported by Javier López on 2013-02-02
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Wishlist
nautilus (Ubuntu)
Wishlist
Unassigned
Raring
Undecided
Unassigned
Saucy
Wishlist
Unassigned

Bug Description

Release of Ubuntu: Raring, 13.04
Package Version: 3.6.3-0ubuntu5
Expected Results: Be able to create an empty file from the context menu
Actual Results: There's not possible till I create manually an empty file in $HOME/Templates

There is no easy way to create 'new blank' files in Files, you can do it by creating a file in $HOME/Templates/new or by installing an extension:

http://www.webupd8.org/2012/11/add-new-empty-file-entry-to-nautilus-36.html

I don't think normal people will be interested in doing any of those procedures, exist a Gnome bug about it:

https://bugzilla.gnome.org/show_bug.cgi?id=687139

But it's closed, so I'd like to see this fixed in Ubuntu at least, what about providing some default files so people using Ubuntu can create empty files since the first boot?

tags: added: usability
description: updated
Changed in nautilus:
importance: Unknown → Wishlist
status: Unknown → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-03-02
Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
Javier López (javier-lopez) wrote :

I don't understand how I bug like this one which forces to create files the hard way in one of the most popular applications installed by default can be classified as 'whishlist'. I'm pretty sure that many people will fail on this as soon as RR gets released.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Rocko (rockorequin) wrote :

I don't understand it either, but it's not Ubuntu's fault. The problem is upstream: Canonical repackages the gnome desktop, and AFAICS the gnome-devs have gone insane and think that removing commonly-used and useful functionality will make gnome better. They therefore don't think this is a bug - they did it on purpose! - which is why they have closed the upstream bug as "won't fix".

This bug is just one example in nautilus - do you notice that you can no longer create a new folder using the right click if the nautilus window is filled with file names? That there's no longer a status bar? That the menu has most of its functionality removed - you can't even create a new folder any more via the menu? That the tree view and split panes is no longer there?

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu6

---------------
nautilus (1:3.6.3-0ubuntu6) raring; urgency=low

  * debian/patches/16_unity_new_documents.patch: display the "new document"
    menu under unity, even if there is no template installed (lp: #1113648)
  * debian/patches/git_fix_touch_double_click.patch: upstream patch to try
    to fix double click not working on touch screens (lp: #1071922)
 -- Sebastien Bacher <email address hidden> Wed, 06 Mar 2013 18:49:59 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

By the way, this patch won't be sufficient to add a "New Document" menu in Nautilus 3.8.

Norbert (nrbrtx) wrote :

This patch adds "New document" to Unity desktop (which is driven by Nautilus).

Please add "Create new document" option to right-mouse-click menu in Files (as it was in 12.04 and before).

Sebastien Bacher (seb128) wrote :

@Norbert: what do you mean "in Files"? that patch should give you the same behaviour that was in 12.04

Norbert (nrbrtx) wrote :

@Sebastien
Under Unity this patch solves problem. But in Gnome Fallback it does not.

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

Gnome Fallback does not have "New document" option in Nautilus menu.

Norbert (nrbrtx) wrote :

Gnome Fallback still does not have "New document" option in Nautilus menu.

Sebastien Bacher (seb128) wrote :

> Gnome Fallback still does not have "New document" option in Nautilus menu.

right, GNOME sessions have the GNOME behaviour, we only change that for Unity

I hope you add similar functionality to gnome fallback session. Not all
users have Unity running. So bug is not completely fixed.

Sebastien Bacher (seb128) wrote :

> I hope you add similar functionality to gnome fallback session. Not all users have Unity running. So bug is not completely fixed.

No, there is no plan to do that, every time we patch over GNOME we get GNOME users angry at us saying we should respect the GNOME design decision and ship GNOME like it's intended to be, which is what we are doing as much as we can.

If you disagree with the GNOME design either report bugs to upstream GNOME or change your session to Unity or something else...

Norbert (nrbrtx) wrote :

OK,I understood.
I'll try to report to upstream.

Jeremy Bicha (jbicha) on 2013-06-14
Changed in nautilus (Ubuntu Saucy):
status: Fix Released → Triaged
Jeremy Bicha (jbicha) wrote :

I'm reopening this bug for Saucy since this patch won't work with Nautilus 3.8 which we'd like to add for Ubuntu 13.10 since it fixes numerous bugs and adds back a form of tree navigation.

This patch took advantage of a bug that has since been fixed. Nautilus developers prefer that users create whatever templates they want to use themselves in the ~/Templates/ directory. Perhaps we could add a ~/Templates/Text File in /etc/skel/ but that will only work for new users.
https://bugzilla.gnome.org/show_bug.cgi?id=687139

Changed in nautilus (Ubuntu Raring):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

Thanks Jeremy for the suggestion, but I don't like the skel idea much, that's hackish, would impact non GNOME users and wouldn't work for upgrades.

We should maybe teach nautilus to look for templates in e.g /usr/share/nautilus/templates as well as the user dir and put a default template in there.

Having a way to provide a default set of templates as been a popular wishlist for a long time, that would resolve that issue as well.

Jeremy Bicha (jbicha) on 2013-06-22
Changed in nautilus (Ubuntu Saucy):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) wrote :

Marking fixed for Saucy since Seb got this working again there.

Norbert (nrbrtx) wrote :

Bug exists in Saucy final.

Norbert (nrbrtx) on 2013-10-18
tags: added: quantal saucy
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 13.10 final.
Gnome Fallback still does not have "New document" option in Nautilus menu.
Please fix this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.