Ubuntu

backspace key no longer works in nautilus

Reported by Rocko on 2013-01-29
256
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

I know that that it's not Ubuntu's fault that the gnome-devs have removed so much of the useful functionality from nautilus 3.6, but one regression that I find particularly annoying is that the backspace key no longer works as a 'back' button. Instead, you have to press ALT-left arrow, which is much more complex, as well as non-intuitive (non-intuitive in the sense that many users tend to use backspace to go back in browsers).

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: nautilus 1:3.6.3-0ubuntu5
ProcVersionSignature: Ubuntu 3.8.0-2.6-generic 3.8.0-rc4
Uname: Linux 3.8.0-2-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
Date: Tue Jan 29 15:39:50 2013
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'800x550+853+1291'"
InstallationDate: Installed on 2012-08-25 (156 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
MarkForUpload: True
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Rocko (rockorequin) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Jeremy Bicha (jbicha) wrote :

Firefox on Linux also uses Alt+← to go back instead of Backspace. It has the advantage of symmetry with Alt + → for Forward and prevents accidentally going Back a page when all you intended to do was delete the previous character in a form but your focus was on the wrong spot.

With Nautilus 3.6's quick search I think it would be a bit more difficult to have Backspace do two different actions (which is itself non-intuitive).

Rocko (rockorequin) wrote :

Hmm. I also set my Firefox and chrome up to match their default configuration on all other OS's, ie so that backspace works as the back key (in FF it's just setting browser.backspace_action = 0, but in chrome you need a plugin). I just find it much more convenient than having to search for two keys to press.

My guess is that upstream will say the same thing regarding the backspace key - that it doesn't mesh nicely with the way quick search is implemented when you go back - but IMO it's a real pity they've done it this way, as I find it much slower to use nautilus now, both in that that 'back' takes you into the previous quick search, which you then have to cancel to see the whole contents of the folder, and in that backspace doesn't do anything any more. (And in that you can't right-click off away from file name to get the 'New Folder' context menu, which was something they introduced in nautilus 3.4 as an improvement and have now taken away again.)

Of course, a good solution would be to make all this configurable - but this doesn't match gnome's philosophy of reducing configuration and usability :) wherever possible.

As a workaround, Dolphin supports backspace to go back and is generally a much better file manager than nautilus, both in usability and in number of features. (It's just a pity that kioclient isn't as capable as the gvfs tools for when you're trying to integrate scripts with a GUI file manager.)

Rocko (rockorequin) wrote :

Some information from the upstream bug: it turns out that it is configurable - the way to restore the backspace key functionality is to add:

(gtk_accel_path "<Actions>/ShellActions/Up" "BackSpace")

to ~/.config/nautilus/accels.

It's obviously a pain to have to do this manually for every Ubuntu installation, but at least it makes nautilus more user-friendly again.

The upstream bug is flagged as resolved due to being a duplicate of what is actually not a duplicate bug, so I doubt upstream will take any further action.

Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Sasa Paporovic (melchiaros) wrote :

The upstream (692852 has been marked as dublicate)

https://bugzilla.gnome.org/show_bug.cgi?id=679822

has been marked as fixed:

Cosimo Cecchi [nautilus developer] 2012-08-23 10:11:03 UTC

"
Pushed a fix for [...ALT+ < >]to git master now.
"

----------------------------------------------------------

If there is a broader need for the "BACKSPACE" feature the configuration change mentioned upstream by

James 2013-01-31 02:34:19 UTC

"
Not sure if it's going to be a default, but you'll need to add this:

(gtk_accel_path "<Actions>/ShellActions/Up" "BackSpace")

to ~/.config/nautilus/accels to get Backspace back.

HTH for someone reading here.
"

must be incorporated in the ubuntu package independend of the upstream as far as I could see.

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Rocko (rockorequin) wrote :

The upstream bug shows this as the commit that removes the default backspace key action: http://git.gnome.org/browse/nautilus/commit/?id=2f1c80cc419b7e77972f63b448afe63d37994c74

so reversing this commit would fix this bug.

The upstream status is incorrect - it should be something like 'won't fix'.

Changed in nautilus:
importance: Medium → Unknown
status: Fix Released → Unknown
florin (florin-arjocu) wrote :

Actually Backspace does not do the GO-BACK action, it does GO-UP-A-FOLDER. It is different and a lot more convenient when working inside folders, I use it a lot more often that going back to previous folder as it is there on the keyboard and I can press it with just one finger.

Laurent B. (lbnetid+lp) wrote :

Thank you very much.
(gtk_accel_path "<Actions>/ShellActions/Up" "BackSpace") added to ~/.config/nautilus/accels actually does the trick...

S Barmeier (severinbarmeier) wrote :

For forward I'd find [Shift]+[Backspace] equally intuitive as [Alt]+[Right].

Zta77 (zta77) wrote :

It's always two steps forward and one step back with every Ubuntu release, isn't it? I don't care about the technicalities about whether it's Gnome, Canonical or Stallman who's responsible for introducing this bug. All I know is that it says "Ubuntu" on the package, and the maintainers of "Ubuntu" should put an effort into maintaining a level of functionality that Ubuntu users have been accustomed to. Luckily there was an easy fix for this, but it's still extremely annoying that one has to browse the web after every distupgrade in order to restore normal behaviour and functionality. I switched to Ubuntu for a reason, and this is NOT how Linux for Human Beings should be like!

Sebastien Bacher (seb128) wrote :

Right, Ubuntu has a responsability there and we hear you, that's one of the reason we stopped following unstable GNOME series in raring to focus on only landing stable version when they are ready

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Invalid
Stefano Bagnatica (thepisu) wrote :

Just my comment: the bad thing abot having ALT+LEFT instead of BACKSPACE, is that for pressing ALT+LEFT you need to use two hands. Instead with BACKSPACE I pressed it with only left hand, making right hand free to use mouse.

I know that I can customize hotkey association, but I think that hotkey customization is very few applied now respect of years ago.

Zta77 (zta77) wrote :

I don't know who make these decisions, but for what it's worth: I agree with the observation above. Also: It has always been Backspace (as long I remember), and there's no good reason to change it and annoy all us "old-timers" =)

Adam Niedling (krychek) wrote :

Please fix this! It's very annoying! :(

Adam Niedling (krychek) on 2013-10-14
tags: added: saucy
entonjackson (aj-mysc) wrote :

I can't believe this bug is still open...

makitso (makitso) wrote :

The (gtk_accel_path "<Actions>/ShellActions/Up" "BackSpace") fix mentioned above does NOT work for Ubuntu Gnome 13.10.

Ondřej Buriánek (zerem) wrote :

Huge annoyance :(
behaivor should be configurable: OLD (backspace + go to name by letter) vs NEW (start search by letter)

eon tux (cyberfoxqc) wrote :

The old trick backspace button to move up is more intelligent than the alt+arrow. But the Ubuntu dev's are more idiots than other developers Gnu/Linux. Do disapear the old good things is not a sign of intelligence. I have doing removing all Ubuntu os at my job for this disgraceful thing. Ubuntu is not for normal computer, is for smartphone only or needless gadget!

Try elementaryOS for a pure experience on a real pc, and Ubuntu won't bring back idiot things in you life!

Volodya (volodya) wrote :

Microsoft has attempted to do the same thing in the trial run of Nashville (it was the OS that was later turnt into Windows 98), they have removed "up" from the Explorer and kept only Forward and Back. This was a disaster (and anybody with any brain can understand why, if you went from a different directory there is no way to go up one level, since 'Back' takes you to a completely different point of the directory tree).

So, the question becomes, if even Microsoft was intelligent enough to return this feature, why did *anybody* in the free software community decide that it was good to remove it. Even the idiots who removed buttons from the phone or made something too small to be useful as a computer and too large to be a mobile (Apple, Inc) wouldn't dream of doing something as stupid as this outside of some test audience.

Sebastien Bacher (seb128) wrote :

@Volodya, thanks for sharing your opinion, some comments though:

- you are commenting at the wrong place, Ubuntu didn't remove that feature, GNOME did (you want to comment on https://bugzilla.gnome.org/show_bug.cgi?id=692852 instead, where the people who decided of the change are going to read you)

- a bug tracker is to discuss technical issues and their solution, your comment is not really useful to provide a solution ... user feedback/discussions are better placed on forums and lists

- that bug is about a keybinding change, your story while interesting is about having a "up" button in the UI. Nautilus doesn't have one of those but you can click on any folder in the pathbar UI which provides and equivalent access to upper locations

Volodya (volodya) wrote :

Re: the last comment

Pathbar UI is just one of the ways to set up the view in Nautilus, i always use 'Places' view, so that's not really a work around.

Sebastien Bacher (seb128) wrote :

I mean the breadcumb widget at the top of the view, e.g [usr][share][something]

Adam Niedling (krychek) wrote :

The problem with alt+up arrow is that you need both hands to do it so you have to release the mouse...

Rushi (rushi4687) wrote :

Can confirm this is still a problem on Ubuntu 13.10, 64-bit.
GNOME Nautilus: 3.8.2

Xavier Claessens (zdra) wrote :

Now that ubuntu restored type-ahead, I think backspace can be restored as well.

The attachment "0001-Restore-backspace-for-going-to-parent-folder.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu3

---------------
nautilus (1:3.10.1-0ubuntu3) trusty; urgency=medium

  * debian/patches/ubuntu_backspace_behaviour.patch: restore backspace
    behaviour, as a back button, thanks Xavier Claessens (lp: #1108637)
 -- Sebastien Bacher <email address hidden> Mon, 03 Feb 2014 18:18:01 +0000

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.