can't move desktop icons to other screen in multi-monitor setup

Bug #1090720 reported by Maximilian Federle on 2012-12-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
High
nautilus (Ubuntu)
Low
Unassigned

Bug Description

i) Steps to reproduce

i.a) Attach mutliple monitors to system
i.b) Try to drag and move a desktop icon to another screen

ii) Expected result

It should be possible to place icons at any desired location.

iii) Actual result:

The icon stays on its screen. However it is moved to the far left or right of the first screen, depending on whether the second screen was attached left or right to the first one.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: nautilus 1:3.6.3-0ubuntu3
ProcVersionSignature: Ubuntu 3.7.0-6.14-generic 3.7.0
Uname: Linux 3.7.0-6-generic x86_64
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
Date: Sat Dec 15 15:06:31 2012
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'1326x768+2644+157'"
InstallationDate: Installed on 2012-09-27 (78 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64+mac (20120905.2)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: Upgraded to raring on 2012-11-24 (21 days ago)

Maximilian Federle (ppd) wrote :
Jarred Casley (caz.au) wrote :

Exact same issue here on 6/03/2013 Ubuntu 13.04 xAMD64 build.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → High
status: Unknown → New
Changed in nautilus:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu10

---------------
nautilus (1:3.6.3-0ubuntu10) raring; urgency=low

  * debian/patches/git_margin_primary_workarea_revert.patch:
    - revert a buggy fix that broke dnd between screens (lp: #1090720)
 -- Sebastien Bacher <email address hidden> Wed, 20 Mar 2013 18:59:09 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.