Nautilus creates broken symbolic links to files located on GVFS mounts

Bug #1090344 reported by Ritesh Khadgaray on 2012-12-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Medium
nautilus (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned

Bug Description

1. Description of the problem:

Nautilus creates broken symbolic links to files located on GVFS mounts
https://bugzilla.gnome.org/show_bug.cgi?id=635864

2. Ubuntu release, software version, Release Number and Architecture of the selected components.

- 12.04 /12.10
- nautilus 1:3.4.2-0ubuntu4

3. How reproducible is the problem?

100%

4. Steps to Reproduce:

* Mount SFTP share (or samba share)
* Click and drag the file to the desktop
* Hold alt, then drop the file on the desktop
* Choose "Link Here" from the menu
* Enjoy the broken links!

a. Actual Results:

For ssh links:

lrwxrwxrwx 1 eric domain^users 15 2012-10-18 16:02 Link to bamf -> /home/eric/bamf

(expected /home/eric/.gvfs/sftp for eric on 10.153.108.202/home/eric/bamf or otherwise working link)

For Samba/Windows mounts:

lrwxrwxrwx 1 eric domain^users 23 2012-10-18 16:01 Documents and Settings -> /Documents and Settings

(expected /home/eric/.gvfs/c$ on ubundows.ubuntudomain.int/Documents and Settings or otherwise working link)

 b. Expected Results:

Working link created.

5. Known Workaround:

Either do it from the command-line or use Thunar, which works.

Ritesh Khadgaray (khadgaray) wrote :

proposed patch for precise based on upstream code.

Ritesh Khadgaray (khadgaray) wrote :

proposed patch for quantal

Ritesh Khadgaray (khadgaray) wrote :

[ Impact ]

* Nautilus creates broken symbolic links to files located on GVFS mounts

* The fix is trivial and has been backported form upstream

[ Test Case]

* Updated in bug decription

[Regression Potential]

* minimal potential for regression

Sebastien Bacher (seb128) wrote :

The issue is fixed with 3.6 in raring

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
Changed in nautilus (Ubuntu Precise):
importance: Undecided → High
Changed in nautilus (Ubuntu):
importance: Low → High
Changed in nautilus (Ubuntu Quantal):
importance: Undecided → High
Changed in nautilus (Ubuntu Precise):
status: New → In Progress
Changed in nautilus (Ubuntu Quantal):
status: New → In Progress
Sebastien Bacher (seb128) wrote :

Thanks Ritesh, I can confirm that the fix works on 3.4.2, I sponsored it to precise and quantal (after adjusting the bug reference and the patch name to include git_ prefix that we use for patches coming from upstream git)

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Invalid

Hello Ritesh, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.4.2-0ubuntu6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in nautilus (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Ritesh, or anyone else affected,

Accepted nautilus into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.5.90.really.3.4.2-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Ritesh Khadgaray (khadgaray) wrote :

Works fine for me , and fixes the stated bug.

nautilus 3.4.2-0ubuntu6 /precise
nautilus 3.5.90.really.3.4.2-0ubuntu4.1 /quantal

Thank you
-- ritz

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu6

---------------
nautilus (1:3.4.2-0ubuntu6) precise-proposed; urgency=low

  * debian/patches/symlink.patch:
    - broken symlinks created for files on gvfs mount (LP: #1090344)
 -- Ritesh Khadgaray <email address hidden> Wed, 05 Dec 2012 20:12:11 +0530

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.90.really.3.4.2-0ubuntu4.1

---------------
nautilus (1:3.5.90.really.3.4.2-0ubuntu4.1) quantal-proposed; urgency=low

  * debian/patches/git_remote_symlink.patch:
    - broken symlinks created for files on gvfs mount (LP: #1090344)
 -- Ritesh Khadgaray <email address hidden> Thu, 06 Dec 2012 11:37:34 +0530

Changed in nautilus (Ubuntu Quantal):
status: Fix Committed → Fix Released
steven kane (tropicsteve) wrote :

file manager and graphical shell for gnome nautilus (844kb) update will no install

Leonardo Borda (lborda) wrote :

it works for me thanks

With the updated version everything works fine, except for the case of browsing into /scratch on a remote server. I just renamed a file on such a location (/scratch on a remote server) and it instantly turned into a broken symbolic link (and I lost 5 GB of very precious data!!)
I am using nautilus 3.4.2

I hope there is fix around it...

Ritesh Khadgaray (khadgaray) wrote :

@Mohammad

  This is a different issue, and will also be seen with upstream.

-- ritz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.